Internet connection drops when using screensaver

Page 1 of 2 12 LastLast
  1. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
       #1

    Internet connection drops when using screensaver


    Since i installed windows 10 pro (clean install), every time my screensaver pops up after being idle for 10min, when i get back to the desktop my internet (wired) dropped and has to reconnect, this didnt occur on windows 7.

    In eventviewer i get this error:

    "Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0xAC9E17844***. The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server."

    - power options are set to maximum performance
    - adapter (pci-e intel nic) settings are the same ones used on windows 7, items used are all unchecked except ipv4 and a hook from software i use.
    - sleep/hibernate/.. is disabled
    - windows firewall/defender is disabled (i rather use my own protection software)
    - bios settings still the same as before

    Any suggestions? Its like my connection is dropping to save power even though it shouldnt.
      My Computer

  2. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
    Thread Starter
       #2

    Forgot to add, this screensaver has no options (Mystify), also tried adding the registry rule "pnpcapabilites" i found for windows 7, because the intel software overwrites the power tab on the adapter with its own power settings (all disabled offcourse) so maybe windows forgot to uncheck it or something, still the same problem.
      My Computer

  3. bro67's Avatar
    Posts : 8,409
    Mac OS Catalina
       #3

    It has nothing to do with the screen saver. It has to do with Power properties for when the computer starts to enter a lower power mode for conserving the battery, or if you do not need the computer running at 100% 24/7. You have to go into Device Manager in Control Panel and disable the USB and Network devices from turning off to conserve power. It has been this way since Windows XP.
      My Computers

  4. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
    Thread Starter
       #4

    But it shouldnt be doing that since the power settings are set to high performance? everything in there is set to never or disabled, this is the power tab on my nic:

    Internet connection drops when using screensaver-0innycg.jpg

    This is a desktop pc btw.
      My Computer


  5. Posts : 449
    win 10
       #5

    Have you tried a different screen saver?
    I would expect to see a Power management setting similar to 'Allow the computer to turn off this device to save power'? (should be unchecked)
    Can this setting be seen anywhere?
      My Computer

  6. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
    Thread Starter
       #6

    Trying the blank screensaver in a bit, will leave it for about an hour and will report back.

    The standard power tab gets overwritten with intel's software, it has a setting in the first box beneath "energy efficient ethernet" called "reduce link speed during system idle" which was already disabled.

    That "pnpcapabilities" setting in the registry should have taken care of unchecking the "allow the computer to turn off..", which is why i tried that, but the string wasnt there so i had to add it, unless windows 10 uses a differently named string for that? (the pnpcapabilities was for windows 7). I could try to remove the drivers and uncheck the default setting and then reinstall the drivers but it would be alot easier if there was a registry change? theres quite alot of advanced adapter settings on this nic and it took a while to research every setting and change it for my connection, but i guess i can backup those settings in a text file.
      My Computer


  7. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
    Thread Starter
       #7

    Tried the blank screensaver, still lost connection, went to device manager; uninstalled and deleted drivers from nic, let MS install theirs, unchecked all the options in the power management tab, still lost connection

    I can let my system sit idle without a screensaver and my connection never drops, this doesnt make much sense to be honest.
      My Computer


  8. Posts : 449
    win 10
       #8

    I would stick with the MS drivers for now, can you now try a repair?
    https://www.tenforums.com/tutorials/7...-10-image.html
      My Computer

  9. Synkro's Avatar
    Posts : 18
    Windows 10 Pro x64 2004
    Thread Starter
       #9

    "No component store corruption detected." with DISM
      My Computer


  10. Posts : 449
    win 10
       #10

    Try SFC /SCANNOW
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:31.
Find Us




Windows 10 Forums