Page 1 of 2 12 LastLast

  1. Joined : Jul 2016
    Posts : 6
    Windows 10
       13 Jul 2016 #1

    Can't get network to connect after reinstall (Missing protocols)


    I've been having some weird issues with my computer lately, so this weekend I decided to just do a full wipe and clean reinstall. So I got a fresh Win10 image from Microsoft, and installed that. However, after I was done I couldn't connect to the internet, and the diagnostics app said that one or more network protocols were missing. So I googled that error and started trying solutions I found, however none of them worked for me.


    In the end I decided that since this seems to be a common issue for Windows 10, even though it worked perfectly fine before, I'll just try downgrading to Windows 8.1. So I did that, however it still doesn't work. Now it's telling me that my Ethernet adapter doesn't have a valid IP configuration. Once again, I googled for at least an hour and tried several solutions, none of which fixed it.
    I was about to downgrade once more to Win7, but before that I decided to boot a Linux Live CD I had lying around, and I don't have any connectivity with that either, yet I know this CD worked perfectly fine before.


    So now it kinda looks like my ethernet controller just decided to kill itself in the time I first reinstalled Windows 10. Which seems like a really weird coincidence, but I guess stranger things have happened. So today I went out and bought a PCI Ethernet card (edimax EN-9235TX-32), plugged it into my box, and it's showing me the same exact problem I also tried manually installing drivers from the CD, although it says on their website that Windows 10 already ships with the correct drivers included, so as you might guess that didn't help either.

    I'm starting to get really frustrated by this, especially since I feel like I've probably tried every fix for this problem that's out there and nothing has helped me. Please if you have any ideas what might help, throw them at me, I don't mind retrying things I already did either. Feel free to include steps to check whether there might be a hardware problem, although I hope there isn't as I can't afford rebuilding the core system right now.
      My System SpecsSystem Spec


  2. Joined : May 2015
    Central IL
    Posts : 3,068
    EL Capitan
       13 Jul 2016 #2

    Always look in the Tutorials first, along with doing a search on here. There has been a long discussion, with the fix posted on this forum about how to solve it. The thread with the fix will actually come up if you were to search for "Windows 10 network missing protocols". Network Protocols

    The problem that caused this was that Microsoft removed guest browsing from Windows 10 in an attempt to tighten security. In return, we all get to see the disaster that they created.
      My System SpecsSystem Spec


  3. Joined : Jul 2016
    Posts : 6
    Windows 10
       14 Jul 2016 #3

    I haven't found that particular thread, however my initial google search did turn up this one, I tried every proposed solution from it and none of it worked for me. After looking through the first few pages of the link you gave me it looks like it contains a lot of the same fixes, I'm working through it now and will report back once I'm done.
      My System SpecsSystem Spec


  4. Joined : May 2015
    Central IL
    Posts : 3,068
    EL Capitan
       15 Jul 2016 #4

    There are quite a few of them that sprouted off of the original one after it got too long. I basically ended up using a combo of some of the info on other sites and fixed my father's when I ran into it. It was basically shut off a service, run a few tools, reboot and turn the service back on and suddenly it works.

    Of course having the Pro edition of Windows 10 helps when you run into these kind of problems.
      My System SpecsSystem Spec


  5. Joined : Jul 2016
    Posts : 6
    Windows 10
       16 Jul 2016 #5

    Alright, so I just finished working through the entire thread, trying and retrying everything that was proposed as a solution. Nothing worked, although I guess something has changed. The error the troubleshooter shows me now is "Ethernet" doesn't have a valid IP configuration.

    Since I guess it might help with further troubleshooting, here are the outputs for some of the console commands that apparently failed to even execute properly:

    Code:
    C:\Windows\system32>netsh int ip reset
    Resetting Global, OK!
    Resetting Interface, OK!
    Resetting Unicast Address, OK!
    Resetting Neighbor, OK!
    Resetting Path, OK!
    Resetting , failed.
    Access is denied.
    
    
    Resetting , OK!
    Restart the computer to complete this action.
    Code:
    C:\Windows\system32>netcfg -d
    SetupDiCallClassInstaller Erorr: 0x6
    SetupDiCallClassInstaller Erorr: 0x6
    SetupDiCallClassInstaller Erorr: 0x6
    SetupDiCallClassInstaller Erorr: 0x6
    Unable to stop the vmms service: 0x2307f8b0Successfully commited changes to the registry
    Successfully commited changes to the registry
    We are going to reboot now to complete the clean up. Save all of your work.
    Press any key to continue...
    Unable to automatically restart the system, please manually restart to complete the cleanup.
    Another thing I forgot to mention, when I tried adding the TCP-IP Tunnels Protocol (Ethernet Properties -> Install -> Protocol -> Have Disk -> C:\Windows\INF -> Internet Protocol (TCP/IP) - Tunnels) it's giving me an error saying Could not add the requested feature. The error is: This program is blocked by group policy. For more information, contact your system administrator.

    Hope this is something to go by, if not please tell me how to get more detailed information that we can work with.
    Last edited by ax1m; 16 Jul 2016 at 04:32. Reason: Additional information
      My System SpecsSystem Spec


  6. Joined : May 2015
    Central IL
    Posts : 3,068
    EL Capitan
       16 Jul 2016 #6

    Did you flush out all Ethernet and Wifi connections from your Gateway/Router? Make sure that in the Bios it shows the onboard Ethernet disabled when you use the other card. If you pull the card, you need to make sure that the onboard Ethernet is enabled. Also do not let it be a boot device.

    Also make sure when you go into the Device Manager in Control Panel. That you show Hidden Devices and then go and delete all devices in the Network portion. That includes drivers. Make sure that you do not allow Windows to install Device Drivers. That choice is in the System shortcut in the Control Panel.

    The VMMS service is Hyper-V. It should be disabled if you do not plan on using that feature. See if this fix for deleting Winsock from the Registry works. Locate the following subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
    3) Right click and delete the entire Winsock key and the Winsock2 keys.

    This is the Registry entry for Network adapters. From the
    HKEY_LOCAL_MACHINE




    subtree remove the following subkeys:


    \SOFTWARE\Microsoft\adapter
    \SOFTWARE\Microsoft\WindowsNT\CurrentVersion\NetworkCards\# (If only one adapter is loaded, # will be 1)
    \SYSTEM\CurrentControlSet\Services\adapter

    This is another key to check. Start Registry Editor (REGEDT32.EXE) and locate the following registry subkeys in the HKEY_LOCAL_MACHINE subtree, where number is the number of any network adapter that appears in the Installed Adapter Cards section in the Network tool in Control Panel:
    \SYSTEM\CurrentControlSet\Services




    \SYSTEM\CurrentControlSet\Services\NWLinkIPX\NetConf




    \SOFTWARE\Microsoft\<Directory Specifying Manufacturer>




    \SOFTWARE\MICROSOFT\WindowsNT\CurrentVersion\NetworkCards\<number>
    Manually remove all subkeys pertaining to the network adapter.
      My System SpecsSystem Spec


  7. Joined : Jul 2016
    Posts : 6
    Windows 10
       20 Jul 2016 #7

    Alright so I just took a couple days off from troubleshooting this problem since I was so sick of it. Just started up my computer, disabled the builtin LAN in BIOS and got ready to try the Registry fixes you proposed, but no need. It is working now. I'm not entirely sure why, but hey, it works, so I won't question it. Thanks a lot for your help, I hope this fix is permanent, if not I will revive this thread, but I'm marking it as solved for now.
      My System SpecsSystem Spec


  8. Joined : Jul 2016
    Posts : 6
    Windows 10
       14 Aug 2016 #8

    Alright so after a month of it working just fine, the issue reappeared this night. It was fine yesterday, then today when I got up, guess what internet is out again. This time the error is "Ethernet" doesn't have a valid IP configuration. Once again, I already tried the most common troubleshooting steps, such as winsock reset, int ip reset, ipconfig /release, /flushdns, /renew, reinstalling device drivers, none of which did anything.

    Really sorry to bother you again with this, but pls help?
      My System SpecsSystem Spec


  9. Joined : Dec 2013
    England
    Posts : 837
    Windows IP 15007 Windows 14393.693
       14 Aug 2016 #9

    Hi,
    Give this a try :SFC Command - Run in Windows 10 - Windows 10 Forums
    If it doesn't help try Dism:DISM - Repair Windows 10 Image - Windows 10 Forums
    and run sfc /scannow at least 3 times, HTH.
      My System SpecsSystem Spec


  10. Joined : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       14 Aug 2016 #10

    Try teh suggestions in this thread - one might help:

    Solved Resolve network issues - Windows 10 Forums
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
cant connect to certain sites missing protocols
hey, this is my first post so have mercy =x Im not sure when the problem started, maybe after a update or installing a game or something..no clue, but recently i have been having connection issues with certain sites at random. Its the same sites...
Network and Sharing
One Or More Network Protocols Are Missing
So I let Windows fix it for me, and I usually need to toggle my WiFi connection off and back on again. But then I have the same connection problem again. I read there was some recent update from Microsoft causing this problem. Does anyone know...
Network and Sharing
Network protocols missing, can not connect to only ONE COMPUTER
First of all, I want to say that I've tried every solution there is for this problem, from reinstalling drivers, wifi card, all cmd commands and even importing working registry values, from another computer... In short, nothing worked. Laptop...
Network and Sharing
I got missing network protocols and I'm about to cry. Help!!!
When I run the troubleshooting I keep getting the message that says: "One or more network protocols are missing in this computer". When I run the "netsh winsock reset" in the Administrator Command Center, I get the messages: " The following helper...
Network and Sharing
One or more network protocols missing?
So I've had this issue for about three days now. I am able to connect to my home router, but I am unable to connect to the Internet. Troubleshooter said "One or more network protocols are missing". Not sure what happened, never touched networking...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:20.
Find Us
Twitter Facebook Google+



Windows 10 Forums