Windows 10: Windows 10 - TPlink dual band only seeing 2.4GHZ networks? Not 5GHZ

  1.    23 Apr 2015 #1

    Windows 10 - TPlink dual band only seeing 2.4GHZ networks? Not 5GHZ


    Any ideas on this?

    AC600 Wireless Dual Band USB Adapter Archer T2U - Welcome to TP-LINK

    Worked fine in Windows 8.1
      My ComputerSystem Spec


  2. Posts : 4,333
    Win 10 Pro x64
       23 Apr 2015 #2

    krs360 said: View Post
    Any ideas on this?

    AC600 Wireless Dual Band USB Adapter Archer T2U - Welcome to TP-LINK

    Worked fine in Windows 8.1
    You need to get and install the driver for your wireless adapter from PC manufacturer's site.
      My ComputerSystem Spec


  3. Posts : 4,333
    Win 10 Pro x64
       23 Apr 2015 #3

    badrobot said: View Post
    You need to get and install the driver for your wireless adapter from PC manufacturer's site.
    What is the brand and model of your computer? We can help you look for the driver.
      My ComputerSystem Spec

  4.    24 Apr 2015 #4

    badrobot said: View Post
    What is the brand and model of your computer? We can help you look for the driver.
    Hi - thanks for the replies.

    The PC is custom built, however the USB adapter in question is the TP Link Archer T2U (link in OP)
      My ComputerSystem Spec

  5.    24 Apr 2015 #5

    This has been resolved now, managed to find the actual board it's running and downloaded the drivers direct from the manufacturer.
      My ComputerSystem Spec


  6. Posts : 4,333
    Win 10 Pro x64
       24 Apr 2015 #6

    krs360 said: View Post
    This has been resolved now, managed to find the actual board it's running and downloaded the drivers direct from the manufacturer.
    Nice. Thanks for reporting back.
      My ComputerSystem Spec

  7.    30 Jul 2015 #7

    krs360 said: View Post
    This has been resolved now, managed to find the actual board it's running and downloaded the drivers direct from the manufacturer.
    Do you have a link to this driver? I'm having the same issue.
      My ComputerSystem Spec

  8.    14 Aug 2015 #8

    DingusKhan said: View Post
    Do you have a link to this driver? I'm having the same issue.
    here: USB (RT2870/ RT2770/ RT307X/ RT2070 RT357X/ RT3370/ RT8070/ RT5X7X/ MT7610/ MT7601/MT7612U) - MediaTek
      My ComputerSystem Spec


 

Related Threads
I installed the 10 tech preview along side my win 7 ultimate, I reinstalled, the Windows 7 side of the HDD because after however many years the OS had a LOT of clutter, and even though windows update was a nightmare I finally got all the updates...
Is there anyone here that has some solid info/experience using Wifi Sense. \ Me and some fellow network engineers are trying to figure out how big of a security risk this is or is not in an Enterprise environment. We have 40,000 employees, we...
Source: Microsoft Health and Microsoft Band: The Next Step in Our Journey - The Official Microsoft Blog
Source... Update: Security Bulletin MS14-068 released - MSRC - Site Home - TechNet Blogs
Hi there trying various VM's on a HOST W10 under VMWARE WORKSTATION 10 -- (XP / W7 / W8.1 / W10 / Linux ) -- all these fail to start network either in BRIDGED or NAT mode. If the HOST is now a W8.1 system connections all work for these...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:09.
Find Us