Hello folks,

This issue started about a week ago, and I can not figure out what caused it and how to address it.

I use Pubmed (Home - PubMed - NCBI) a lot in my work. In a day, I visit that website at least 15-20 times.
One fine day, nothing changed but Pubmed was not reachable. Chrome gives me an error 'ERR_NAME_RESOLUTION_FAILED'

I ignored on the first day, thinking may be its undergoing some maintenance or something, still website not accessible is highly unusual, even during maintenance period. But the saga continued. I have no problem accessing any other websites. I googled to see if anyone else got this problem and how they addressed it. Except one on Mac board, nobody reported a solution that has worked. I don't know how to replicate those Mac ideas on PC so here I am.

I cleaned cache, tried incognito mode on Chrome, turned off machine, router for a while to reset DNS. Flushed DNS using command prompt. None solved the problem. I tried other browsers as well, Edge and Firefox, no luck there as well.

Since majority of the folks in my apartment complex have Optimum, we have a lot of Optimumwifi signal. I tried connecting to Optimumwifi and see if I can access Pubmed. I can. So there must be some issue with the router. This router is provided by Optimum so I can not play around with much of it. Still what else I can try to fix this issue?

Many thanks