Windows 10 Homegroup Pictures Library "Working on it"


  1. Posts : 3
    Windows 10
       #1

    Windows 10 Homegroup Pictures Library "Working on it"


    I have two computers in a Homegroup. I have been able to share files with no issue between the two - except today I noticed that I get a "Working on it" message and File Explorer hangs when trying to pull up the Pictures library from one of the computers. The other libraries (Videos, documents, etc.) work fine.

    I've removed sharing. I've removed the offending computer from the Homegroup.

    Neither fixed.

    Any ideas?
      My Computer

  2. ksio89's Avatar
    Posts : 116
    Windows 10 Pro
       #2

    How are you sharing the Pictures folder? You have two ways to share libraries among Homegroup users on Windows:

    1) choosing to share Pictures library between Homegroup users;

    2) right-clicking the Pictures library folder on This PC, and selecting "Share with>Homegroup (view and edit)". Try to do the last step and see if you are able to access Picture folder from the other computer member of your Homegroup.
      My Computer

  3. bro67's Avatar
    Posts : 8,169
    Mac OS Catalina
       #3

    It sounds like the Index is messed up on both machines. If just two computers, use standard Folder Sharing, instead of using Home Group to share a shortcut to a library.
      My Computers


  4. Posts : 3
    Windows 10
    Thread Starter
       #4

    I'm pretty sure I tried both methods. The odd thing is that it worked for a second twice since I posted this, but it eventually hangs again.

    ksio89 said:
    How are you sharing the Pictures folder? You have two ways to share libraries among Homegroup users on Windows:

    1) choosing to share Pictures library between Homegroup users;

    2) right-clicking the Pictures library folder on This PC, and selecting "Share with>Homegroup (view and edit)". Try to do the last step and see if you are able to access Picture folder from the other computer member of your Homegroup.
      My Computer


  5. Posts : 3
    Windows 10
    Thread Starter
       #5

    Good idea. I've been using the Network area in Quick Access which seems to work too.

    bro67 said:
    It sounds like the Index is messed up on both machines. If just two computers, use standard Folder Sharing, instead of using Home Group to share a shortcut to a library.
      My Computer

  6. bro67's Avatar
    Posts : 8,169
    Mac OS Catalina
       #6

    There is a Registry fix that you can do. Doing a System Restore does not always fix it, because it depends on what is exactly causing the issue. Could be an update that Microsoft pushed out, could be any third party security software that you are using, or it could just be the problem that Home Group has had for a long time, that if you make any major changes on one machine, even reinstalling the network drivers or repair the OS. One of the other machines on the network gets lost and still associates the security key with a non-existent device.
      My Computers


  7.   My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:28.
Find Us




Windows 10 Forums