Static IP adress vs DHCP

  1.    30 Jun 2016 #1

    Static IP adress vs DHCP


    I've just updated a W7 machine to W10. The update has take all the settings from W7 and the machine was operating without problem before the update.

    When running W7 the machine had a static IP address of and all of the other machines could access the machine using the IP address or the name defined to the network.

    After updating to W10 the machine continues to have a static IP address of and the same machine name. Other machines can access it using the IP address but the machine name now resolves to which is a DHCP address. The machine has not used this address, if ever, for at least a year.

    I can't change the machine IP as some of the applications that run on it store the IP address which is why it was moved to a static one in the first place.

    I'm assuming the problem is the router which allocates DHCP addresses. I've deleted the original entry in the devices table and it has been refreshed correctly but it hasn't made a difference. The router is a Technicolor TG582n

    I've even tried adding an entry to the HOSTS file which hasn't made a difference.

    Any ideas?

      My ComputerSystem Spec

  2.    01 Jul 2016 #2

    Hi there
    Go into router settings -- your router is assigning IP addresses - but you can "reserve" some and start DHCP addresses from a specific number.

    In the network settings of your machine with fixed IP - disable DHCP in the networking panel (Windows) and put your IP address in. You might need gateway and DNS server ip address(es) to be set - that you can get from the router.

    Cold boot ALL computers / phones etc etc on your network.

    You might also need to change the IP of the router (normally or similar addresses are for the router and gateway)

    Should then work fine.

      My ComputerSystem Spec

  3.    01 Jul 2016 #3

    Does your router support specific IP address reservations? Any client in the Address Reservation table will always get the same IP address. The client gets set to DHCP but it always pulls the same IP address from the router. That way the router handles the DNS name lookup for the local network.

    Click image for larger version. 

Name:	Capture.JPG 
Views:	1 
Size:	186.8 KB 
ID:	87666

    Also, is the network connection on the computer set as a private network?

    Is Network Discovery turned on?

    Click image for larger version. 

Name:	Capture1.JPG 
Views:	0 
Size:	95.0 KB 
ID:	87667
      My ComputerSystem Spec

  4.    01 Jul 2016 #4

    Thank you for your replies. The problem is still there this morning despite all of the other machines being closed down.

    Yes the router supports a DHCP range, it's set for 65-253 so there is no clash of addresses.

    I've cold booted everything all ready

    The router is on

    Network Discovery and File and Printer sharing are both on.

    CompA can see and access everything else on the network without problem.

    I had the same problem on another machine earlier in the week, but was able to cure it by switching to a DHCP address, unfortunately I can't easily do this with the current machine and having a DHCP address causes problems.
      My ComputerSystem Spec


Related Threads
Solved mailapp don't know server-adress?? in Browsers and Email
Greetings. I want to try Windows 10 mailapp, but I can't get it to work. I want to try with my Microsoft mail (it is a domain). When opening the maip-app first it wrote, the the mailserver did not exists. Then I typed in the microsoft...
In an attempt to track down this event: I get this result: Note that the MAC address that received the DHCPNACK message is reported as disconnected. It is for a wireless card. After power cycling the router the IP address lease had been...
DHCP question in Network and Sharing
What does it mean when it's said, "set your IP addresses as reserved (fixed) IP addresses outside of the routers DHCP address pool?" I have an Asus RT-AC87U and have set up a few devices for static IP's but I'm not sure which addresses would be...
The laptop computer is attached to a corporate domain. The DNS servers are providing DHCP settings. After logging onto the network, there is NO IPV4 address assigned despite DHCP enabled. Using ipconfig command, the setting is an obscure IP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:55.
Find Us