Page 2 of 2 FirstFirst 12
  1.    28 Jun 2016 #11
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 381
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    What drives me crazy is that occasionally (and briefly) things work the way I want. Then they go back to not working. I'm sure it's something I'm doing rather than the whims of the gods but I sure can't figure it out.
      My ComputerSystem Spec
  2.    28 Jun 2016 #12
    Join Date : Oct 2014
    Posts : 1,438
    win 10 Insider

    New insider build a few minutes ago and still that stupid error msg. Wonder what is holding the bad info to trigger it.
      My ComputerSystem Spec
  3.    28 Jun 2016 #13
    Join Date : Oct 2014
    Posts : 1,438
    win 10 Insider

    Looks like the problem lies within the NAS as I did a System Only reset and now the error has gone - for now!!

    I will now use another userid on my wife's comp when trying again.
      My ComputerSystem Spec
  4.    29 Jun 2016 #14
    Join Date : Oct 2014
    Posts : 1,438
    win 10 Insider

    From my main comp, back to square one. Same error. Absolutely ridiculous that we can't seemingly use a private share.
      My ComputerSystem Spec
  5.    30 Jun 2016 #15
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 381
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    I found a little more information on this (from the web, so I'm sure it's accurate ).

    The Windows limitation seems to be one connection between a Windows user and NAS server - not just one set of network credentials. If you establish a connection to a public share (i.e., not credentials needed) you cannot establish a connection to a private share on that same server. And vice versa - if you establish a connection to a private share you cannot also establish a connection to a public share. Whichever you establish first is all you get.

    I'm not sure about connections to multiple public shares. Windows may consider that one connection since this limitation seems to be based on network credentials.

    I read posts saying that it would work if you use the IP address instead of name for a second connection. That would not work for me. Windows still new I was trying to get to the same server.

    I read another post saying that it would work if added additional network names to the Windows etc\hosts file . That also would not work for me. Windows still new I was trying to get to the same server.

    Perhaps it would work if alias DNS names could be added to the little DNS server in my router, but I don't know how to do that.

    I'm almost sure I'm trying to go down the wrong path. I can't believe that Windows developers think it is reasonable to disallow a user to have connections to multiple shares on a NAS server.
      My ComputerSystem Spec
  6.    30 Jun 2016 #16
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 381
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    Success. Sort of. Maybe. I'm not sure how to apply this, and whether or not this will help anybody else, but I've gotten a bit farther (and uncovered some real stupidity on my part).

    In my testing I was accessing the various shares incorrectly.

    Click image for larger version. 

Name:	NAS access #1.PNG 
Views:	1 
Size:	30.2 KB 
ID:	87592
    Under Network I was clicking on MYBOOKLIVE, clicking on name of one of the secured shares - "Secure" in this case - And then trying to enter the credentials. In order to try using the IP address for access I was trying 192.168.1.234\userid. Dumb!

    Instead, I should have been putting \\192.168.1.234 in the panel's pat field. Then I would get:
    Click image for larger version. 

Name:	NAS access #2.PNG 
Views:	1 
Size:	30.4 KB 
ID:	87598
    Now I am using the IP addr to access the NAS server and Windows will accept the appropriate credentials.

    However, Windows then have a connection using that IP addr for that share. I cannot access another secured share that requires different credentials. (I probably can access a different secured share that required the same credentials. I'll have to try that.) There is probably some way to tell Windows to clear the connection so I can establish a different one, but I haven't found it. Logging off of Windows clears the connection but is not very convenient.

    In my case I want my backup software to access the secured share. I'd really like to find a way for this to work without telling it to use the IP address rather than the name. If it uses a hard-coded IP addr, I'd better give the NAS a static addr. I really don't like doing that.
      My ComputerSystem Spec
  7.    30 Jun 2016 #17
    Join Date : Oct 2014
    Posts : 1,438
    win 10 Insider

    I feel your pain. No idea why we have to have this problem. We both know how it should work!

    I tried to see just what was returning that error by using a notebook that had been switched off for weeks. Still got the error so I thought it must have been triggered by the NAS. Then I reset the NAS and it was OK for the first access then the error returned. Does this also mean the NAS is more involved than thought?

    I seem to have cracked the backup to the secure folder, though. I have created a separate user and given that user full rights to 'secure'. Then, while logged on with that user, I created the backup and scheduled it weekly. This schedule can be seen in Task Scheduler.

    Even when logged into my standard user, that backup schedule runs and backs up to the secure folder with no problem. I am resigned to logging into the backup user to access the secure folder when I want to check it.

    Hope this helps as a viable work around.
      My ComputerSystem Spec

 
Page 2 of 2 FirstFirst 12


Similar Threads
Thread Forum
impossible to access network share from system context
For a number of reasons I need the system context to be able to access and read certain public network shares. These shares are located on a samba server, and are public read to everyone. Environment is WORKGROUP. My Win10 machine can ping the...
Network and Sharing
net share brings up System Error 5 – “Access Is Denied”
Hi, I have a "server" that ran win 7 and which I now updated to Win 10. On this server, there is truecrypt installed and a batch file which I call from a remote computer using psexec. This batch file mounts a truecrypt volume and shares this...
Network and Sharing
Cannot access Windows 10 Share
Hello I am having trouble networking 2 Windows 10 computers together on my network. This is kind of odd, I have a Windows 7 PC that can hit the file share with no issues. And on the troubled computer I can access the shares on the Windows 7...
Network and Sharing
Solved WIn 10 10586 64 Pro Slow Share Access over SMB and ReadyNAS 516
I have a share mapped to my ReadyNAS 516 to all of my media over SMB. There are multiple directories in that share from small to large. Every time I access that share from Windows 10 I get the green progress bar and it takes forever to cache and...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:55.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums