Windows 10: Can't change drivers for any of my USB wifi adapters

  1.    23 Jun 2016 #1

    Can't change drivers for any of my USB wifi adapters

    I've had an on-going problem as documented here:
    Wifi loses connection every few hours (tested on 2 diff wifi adapters)

    It sounds like a very similar problem to what many others have reported regarding wifi problems with Windows 10:
    Windows 10 internet connection dead every two hours
    Connection drops completely when trying to use the Internet

    And there's tons more complaints like this on Google if you do a search.

    I've tried many things (as suggested in those threads), and so far none have worked. What I'm trying to do now is to manually set my wifi driver to something else, but Windows 10 isn't allowing me. I have plugged in two different USB wifi adapters (one is a Rosewill, the other is a newer one by Netgear), and I have installed the manufacturer driver files that come with those adapters, but it seems Windows 10 ignores it. When I go to my
    Device Manager → Network adapters → 802.11n USB Wireless LAN Card → Properties

    The driver listed is this:
    Driver Provider: MediaTek, Inc,
    Driver Date: 6/6/2014
    Driver Version:
    Digital Signer: Microsoft Windows

    I have tried to use the "Update Driver..." process to manually set it to manufacturer drivers. No dice. It just says "The best driver software for your device is already installed."

    I also tried the "Uninstall" button to get rid of the MediaTek driver. But after I reboot the system, Windows 10 automatically installs it again.

    It seems the surefire solution is to downgrade to Windows 7, but I don't want to go through that pain.

    Can anyone help?
      My ComputerSystem Spec

  2. Posts : 407
    Windows 10 Pro x64, Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
       23 Jun 2016 #2

    What model Adapters are you trying? Many use chips that are the same and MediaTek may be the manufacturer.
      My ComputerSystem Spec

  3.    23 Jun 2016 #3

    I have a Rosewill RNX-N1/N1MAC, which is about 5 yrs old, and also a Netgear a6210 (802.11ac Dual Band with High Gain Antenna) which I bought about 1 yr ago.

    BTW, can you go to your Device Manager → Network adapters → 802.11n USB Wireless LAN Card → Properties and see what drivers your system has? Just curious.
      My ComputerSystem Spec


Related Threads
I've had experience this problem for a while now on my newly built windows 10 rig. Every few hours, my Wifi simply stops working; the connection is lost. Sometimes it reconnects after a minute or so. Most of the time, I would need to manually...
hello i tried change adapters and bindings order but its not working i followed this but when i re enter the pop-up in the picture (after setting my new priority order) the new order is gone and the old is there Open Network Connections by...
Good day all, My son disconnected the wifi on his laptop. I know it is in Parameters - Réseau et internet (network - internet) - Wifi but the button to activate won't move. Don't know what to do. Thank you 57339
Hi All, Tried a few different things to try and resolve this issue and it is just bugging me. The system is running fine it just crashes when I try to restart my computer. I only notice I had a fault because when I shut my computer down the...
So a few days ago I went ahead and upgraded to win 10 pro from 8.1. After the upgrade I wanted to set up a fwew vm's and just do some basic network setup. As i go to rename my nics it tells me that access is denied. I made sure I am the admin and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:11.
Find Us