1.    20 Jun 2016 #1
    Join Date : Jun 2016
    Posts : 4
    Windows 10

    Wifi loses connection every few hours (tested on 2 diff wifi adapters)


    I've had experience this problem for a while now on my newly built windows 10 rig. Every few hours, my Wifi simply stops working; the connection is lost. Sometimes it reconnects after a minute or so. Most of the time, I would need to manually disable/enable the wifi adapter in my Network Settings to get it back up again.

    It happened with a relatively expensive adapter that I bought not to long ago - Netgear A6210 USB 3.0 dual-band wifi adapter. I found a thread about this issue here. I've not been able to resolve it with any of the tips provided (including downloading a generic 3rd party Mediatek driver). I've used this same adapter without this problem on my older Win7 machine. I thought maybe this adapter "went bad".

    So I tried to replace this adapter with an older Wifi adapter made by Rosewill, using older Rosewill drivers. The same issue occurs. (Again, this Rosewill adapter worked perfectly in my Win7 system) So I have a hunch the problem is Windows 10 itself. Does it not place nicely with existing or older wifi adapters on the market? Would I need to buy a new adapter specifically certified for Windows 10?

    Anyone have any insights on this would be greatly appreciated.
      My ComputerSystem Spec
  2.    21 Jun 2016 #2
    Join Date : Dec 2015
    Posts : 167
    Windows 10 Ent, Pro & Home

    Have you turned off Power Management in device Manager? Go to device Manager/ network adapters/Wireless network device/right click properties/ Power management tab/ uncheck everything.
      My ComputerSystem Spec
  3.    22 Jun 2016 #3
    Join Date : Jun 2016
    Posts : 4
    Windows 10
    Thread Starter

    Quote Originally Posted by wyldman68 View Post
    Have you turned off Power Management in device Manager? Go to device Manager/ network adapters/Wireless network device/right click properties/ Power management tab/ uncheck everything.
    Just tried this... no dice =(

    Still the same old pattern of disconnects every few hours
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Internet connection from WiFi Hotspot
I have setup a WiFi Hotspot with MyPublicWiFi. Allowed Sharing in Local Area Connection *2. Everything seems to be in order as the Screenshot shows. But when I try to connect a mobile it gets connected to "MyPublicWiFi", no internet sharing from...
Network and Sharing
WiFi Connection drops after MAC ID change
I recently changed my wifi Mac Id using Technetium as my original ID got blocked. I had to reinstall the drivers and restart the PC to get the Network card working. But that it is fine, the Wifi connection disconnects every 5 minutes or so. Please...
Network and Sharing
Lost WiFi connection on pc
My PC would be connected to WiFi, but I wouldn't be able to go on any site. I restarted my PC and the damn thing locked up on the HP logo screen! So I had to hold the power button to turn of my laptop. What the heck?
Network and Sharing
Solved Connection problems through WiFi
I think it's quite a weird problem : I've a desktop in my house which is connected to the router by LAN and I've a laptop,a smartphone which are connected to the router by WiFi. This morning, when I tried to Google something from my laptop, Firefox...
Network and Sharing
How to setup a WIFI connection.
I had upgraded to Win10, but it locked-up my monitor (don't ask), so I had to wipe the hard drive and reinstall Win8.1 in order to get my display to work. Before, in Win8.1 and in Win10, my internet connection was working. Now Win8.1 says "your PC...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums