Windows 10: Windows 10 internet connection dead every two hours

  1.    20 Jun 2016 #1

    Windows 10 internet connection dead every two hours


    Hi Friends,

    I had Windows 7 Home Basic (64 Bit) on my PC just a few days ago, which has been upgraded to Windows 10. But whenever I use the internet via a LAN connection to a router, I get disconnected after a certain period of time for no apparent reason. I went into Control Panel > Device Manager > Network Adapters. Right-click on it and tried to update it, but it said its already updated. For example, please have a look at the below image, its for example only.

    http://images.dailytech.com/nimage/Windows_10_Build_10061_Device_Manager_Wide.png

    My motherboard is - Gigabyte GA-H61M-S1

    I know that it does not support Windows 10. Under the Specification link, you should find this

    "Operating System : Support for Microsoft® Windows® 8/7/Vista/XP"

    GIGABYTE - Motherboard - Socket 1155 - GA-H61M-S1 (rev. 2.0)


    But this very page also offers the drivers for Windows 10 under the link called "Support & Downloads", here there are

    GIGABYTE - Motherboard - Socket 1155 - GA-H61M-S1 (rev. 2.0)


    Imgur: The most awesome images on the Internet

    And, I have installed them also, but the problem is still there.

    Can you please help?

    I have tried a few tricks as suggest by a few YouTube videos listen below, but nothing has helped me so far.

    How to fix Windows 10 internet connection issues - YouTube

    How to fix internet connection problem for windows 10 users - YouTube

    How to FIX One or more network protocols are missing / Windows sockets registry entries are missing - YouTube

    one or more network protocols are missing on this computer!! - [Fix] - YouTube

    Whenever I start my PC, internet connection is there, but I get disconnected every 2 hours for some weird reason.

    I tried the Troubleshoot Problems option in Control Panel > Network and Sharing Center, but it gave me this error "one or more network protocols are missing on this computer"

    It looks something like the below image,

    https://www.tenforums.com/attachments...ols-error2.png

    Thanks a lot.
      My ComputerSystem Spec


  2. Posts : 2,278
    Windows 10.3 Home 1703 x64 (Home per choice)
       20 Jun 2016 #2

    You can download the latest driver here: Realtek.
    Latest driver is 10.8.311.2016 from 11-Mar-16.
      My ComputerSystem Spec


 

Related Threads
Solved Windows 10 - No internet connection in Network and Sharing
Hello, i have suddenly noticed a problem with internet connection. I cannot download any apps from Microsoft store (with unknown error message). Strange is that each other software (cloud clients, browser, ....) works perfectly. I have already...
I have been having an extreme problem with connecting to the internet. After upgrading to windows 10 from windows 7 home version (I assume windows 10 is the problem) I had connectivity for over a month. Thus I cannot roll back to windows 7 anymore....
Hi all. I have a weird problem with my internet connection. After i had instaled win 10, my interned slowed down. Before i had speed around 50 mbps (old result under) http://e-speedtest.com/test/785260 Now my speed is 10-15 mbps - no more....
Internet Explorer dead in Browsers and Email
Everything was hunky dory until just after I downloaded CrystalDiskInfo via Cnet. Probably just a coincidence as I have had no trouble using either before. I E refused to start and the only option was to reload W 10 afresh.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:46.
Find Us