Sudden Internet Speed Drop Solved

Page 1 of 2 12 LastLast
  1.    #1

    Sudden Internet Speed Drop

    Hello. About 3 weeks ago I noticed I was getting between 40-60mb download, when my ISP package says 200mb. I was previously getting the full 200mb and then some. Technicians from my ISP came out, ran new cabling through the house and out to the pole, then tested it at the pole, at the box on the side of the house and inside at the cable end. They consistently got 200mb+. When connected directly to the cable modem on my desktop however, I consistently get only 40-60mb (mostly 60mb)

    Nothing has changed on my Windows 10 Pro 64bit computer, except possibly Windows Updates. I have installed nothing, ran nothing, I know everyone I get emails from and have clicked nothing. I am an old fart and do not browse "those" sites. I play a single game on here "ARK".

    Here is the kicker: This speed is on all 3 computers in the room....but not my Roku boxes.

    I think it is a Windows Update that caused the issue.

    I have reset my adapter, grabbed the most current drivers from Dell (It's an Alienware), grabbed the most current router (ASUS RT-N56U) firmware. I have disabled Windows Firewall and Defender, and have no other protection on here.

    I watched the techs tests, they was no hanky-panky on their part.

    I have troubleshot this until I am at my wit's end.


    I would appreciate no comments about returning to Windows 7, I like 10 just fine, and no comments about the Alienware, I got lazy and didn't want to build one.

    Thank you for any constructive replies and attempts at a fix, in advance.
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 6,029
    Mac OS High Sierra 10.14.3 Beta (18D21c)

    Sounds more like a router issue. If it happened after you updated drivers on the computers and firmware on the router, I would start there. Reboot the router, rollback the drivers on the computers and see if it returns back to normal. If using Wireless for all devices, check to make sure that WiFi is set to Wireless-n 40mhz channel bandwidth.

    The Roku's would not react too much to a slowdown in speed, because of how the software on them cache's the media stream.
      My ComputerSystem Spec

  3.    #3

    Those were the steps I too after the issue started. I was able to get my full 200mb for a while, but then noticed it had dropped, and took the above steps to troubleshoot the problem.

    Odd thing: I have a "clean profile" on my computer for troubleshooting, and get the full 200mb there. However, the two other computers in the room do not, neither do my tablets or phones. I tried creating clean profiles on the other two computers and they still didn't get the full 200mbs. Only the clean profile on my system..

    I need tips or tricks or steps to troubleshoot farther, I am out of ideas.
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 6,029
    Mac OS High Sierra 10.14.3 Beta (18D21c)

    Do as I stated above. What I posted is standard SOP in eliminating this problem, along with using a few commands to flush thr DNS and reset some other stuff that can get screwed up in the Networking profile.
      My ComputerSystem Spec

  5.    #5

    They were updated after the issue started, and there was no change, so I tried to roll the drivers back and replace the firmware with the older version, and there is still no change. I do appreciate the suggestions.
      My ComputerSystem Spec

  6. jimbo45's Avatar
    Posts : 7,167
    Windows / Linux : Centos, Ubuntu, OpenSuse

    Hi there

    Check your router (or your connection) hasn't dropped back from 5GHZ band to 2.5GHZ band -- on the 2.5GHZ band especially if there are a lot of people on the same channel your speed will drop.

    If you are using LAN / direct connection check also quality of cable --degraded LAN cable can cause horrendous drop in speeds.

    I've given up direct connection via LAN --am using Wifi-Internet via ethernet-->wifi bridge on an older router --still getting >250 mib/s -- however if I switched to 2.5 Ghz band this would drop to around 55 Mib/s -- BIG difference.

    Note the ethernet-->wifi bridge is a great idea if you don't want LAN stuff all over the place --on 5GHZ with current ac technology max speed is 433 mib/s - so you don't lose out using this --even if you have a Gb LAN adapter connection you won't get that through the average ISP (at least not yet). You can even transfer quite large files on local LAN quite decently fast too with that typeof connection.

    My connection is fibre -- all the way -- no copper / older adsl type technology anywhere - and here there isn't that much contention (around 15% of the ENTIRE population is away in France currently watching the Football !!!!!) so the difference between 2.5GHZ and 5GHZ bands is a good test as a lot of people are away not causing contention on the 2.5 GHZ band.

    If you DON'T use wifi and you aren't getting the speed you are paying for - bring back the technicians to recheck your signals.

    The Wifi broadband speed test works on android phone (and probably iPhones) so try that as another check too. That should confirm whether it's a Windows problem (which I doubt) or the problem lies elsewhere.

    Finally check your service contract -- sometimes "Unlimited usage" doesn't quite mean that - you could be getting capped. There in tiny print (probably on page 174 of the service contract !!) might be a "fair usage" clause somewhere -- although exactly what that would mean in a Court I don't know -- would streaming or downloading and watching 3 or 4 ultra 4K HD movies which eat up several tens of GB's each be "unreasonable" !!!!

      My ComputerSystem Spec

  7.    #7

    Believe it or not, I fixed it using another post from these forums. I cannot remember the exact post, I have been up all night troubleshooting and read so much...anyway, here is the fix:

    Disclaimer: Messing about in the registry can brick your system. That being said, you do this at your own risk. I am not responsible if you accidentally impregnate your neighbor's cat, or blow up the microwave, or brick your computer.

    1. Download the .reg files attached to this post. They are the Winsock settings from a fresh install of Windows 10, and will work on 32 or 64 bit versions of Windows.
    2. Hit Win Key + R to bring up the RUN dialog. Type 'regedit.exe' in the box, no quotes.
    3. Use the > arrows to browse to HKEY_LOCAL_MACHINE >SYSTEM >CurrentControlSet >Services
    4. Scroll down until you see folders labeled Winsock and Winsock2
    5. Right click the Winsock folder and choose 'Export' Do the same for Winsock2. Name them Winsock_original.reg and Winsock2_original.reg. Save them in an easy place to get to. You have just backed up these keys in case something goes wrong.
    6. Close the registry editor.
    7. Double click Winsock.reg and merge it into the registry. Do the same for Winsock2.reg. They are attached to this post.
    8. Reboot once or maybe twice.

    POOF. Fixed. I am now downloading at 220mb.

    If anything goes wrong, just repeat the above steps, but after deleting the keys, double click Winsock_original.reg and merge it, then do the same for Winsock2_original.reg, and reboot again. This will restore it back to the original entries. Again, this is done at your own risk, mmmmkay?

    Winsock.reg Winsock2.reg
    Last edited by y0himba; 19 Jun 2016 at 21:17.
      My ComputerSystem Spec

  8.    #8

    Interesting. Glad it is fixed.
      My ComputerSystem Spec

  9.    #9

    I think that suggestion fixed it for me aswell.
      My ComputerSystem Spec

  10.    #10

    Doing this, restarting, flushing my DNS cache took me from 31mbps (115mbps before) to an all-time high of 130mbps! My official speed is 150mbps fibre.
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
changes in internet speed. in Network and Sharing
Hello. Late last year I upgraded my internet to fibre optic with speed up to 38mbps. The provider is EE which I have been with them for a long time and before EE it was orange. My question is since the new fibre was connected last November the...
I bought and iBUYPOWER pc (BB902) , and when test my internet speed and i get 40 mb, when my internet connection in all my other devices is 100 mb and the modem is really close to my PC I use this realtek rtl8811au wireless lan 802.11ac usb 2.0...
Good day, Up until recently Ive had a steady and stable internet connection on all devices, however recently on one laptop the connection is now incredibly slow (multiple tests on show download speeds of 0.1 Mbps while on another...
Hi all. I have a weird problem with my internet connection. After i had instaled win 10, my interned slowed down. Before i had speed around 50 mbps (old result under) Now my speed is 10-15 mbps - no more....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:10.
Find Us