Windows 10: Lost Internet connection when upgrading to Windows 10


  1. Posts : 5
    Windows 10 64-bit
       05 Jun 2016 #1

    Lost Internet connection when upgrading to Windows 10


    When upgrading from Windows 7 to Windows 10 I lost Internet connection.

    On the installation DVD for the motherboard asus z170 pro gaming it says "Windows 10 Ready", so the network drivers should work I think. Just to be sure, I did download the latest drivers from here:
    https://www.asus.com/se/Motherboards...Desk_Download/

    But it doesn't seem to make a difference, since I'm gettings this message when trying to run the installation:
    Another version of this product is already installed. Installation of this version cannot continue. to configure or remove the existing version of this product, use Add/Remove programs on the Control Panel.
    Should I remove the existing version and install again?

    I have also tried "Method # 1: Resetting Winsock and TCP/IP" described on this page:
    http://appuals.com/best-fix-losing-i...ng-windows-10/

    It didn't make any difference. Then they suggest:
    "Method # 2: Updating Network Adapter Drivers", but this is basically what I've already have done, but I didn't go through the Device Manager and if I would have I wouldn't know which dll (or whatever file) to look for. Instead I did download the latest drivers, run the installation file (AsusSetup) and got the message:
    Another version of this product is already installed. Installation of this version cannot continue. to configure or remove the existing version of this product, use Add/Remove programs on the Control Panel.
    Actually if I use D-link Wifi Adapter it does connect to my router and I can get internet connection that way, but not when going through the "LAN (RJ-45) port" on "ASUS Z170 PRO GAMING".

    So when using Windows 7 I was able to connect through:
    "LAN (RJ-45) port" on "ASUS Z170 PRO GAMING"
    D-link Wifi Adapter

    After upgrading to Windows 10, I can only use:
    D-link Wifi Adapter.

    So why do Microsoft release an upgrade that messes up my internet connection? Any suggestions on how to correct this?
      My ComputerSystem Spec


  2. Posts : 3,854
    Mac OS Sierra
       06 Jun 2016 #2

    Uninstall the Network device and drivers, reboot and then reinstall the latest drivers from Asus website for the onboard adapter.
      My ComputerSystem Spec


 

Related Threads
I did the upgrade from W-8.1 to 10 in November and have had several problems since. The most pernicious problem is the loss of my Internet Connection. I had my ISP service dude have a go; but no joy. He concluded it is a software problem....
Hello! I did my upgrade quite shortly ago. Basically before that upgrade I had 2 connections at the same time: Local Area Connection with Ethernet and my PPPOE connection as advised by my provider. I've been using my PPPOE connection for years...
Solved Internet connection lost in Network and Sharing
On Friday, there was an update by Windows 10 and immediately afterwards I lost my internet connection. I contacted the chat help and the lady there had me try a couple of things which did not help including reversing the update. i contacted my...
I have been having an extreme problem with connecting to the internet. After upgrading to windows 10 from windows 7 home version (I assume windows 10 is the problem) I had connectivity for over a month. Thus I cannot roll back to windows 7 anymore....
Hello, I am running Windows 10 Pro (10240) and have a guest Windows 10 VM (10528) which were working fine. Both were activated and connected to internet correctly. Today I booted the VM as native boot VHDX. This installed some drivers,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:48.
Find Us