Windows 10: The specified network provider name is invalid

  1.    04 Jun 2016 #1

    The specified network provider name is invalid


    My internet connection is working, everything is OK, but...
    I cannot share any folder on my PC. I haven't used sharing several months now, It was working perfect back then.

    The problem:


    Some screens of current network settings:

    Code:
    C:\Users\andre>ipconfig /all
    
    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : FLAM-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
    
    Ethernet adapter Ethernet:
    
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 00-25-22-EB-0D-0B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::71e9:3539:a402:784e%6(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Saturday, 4 June, 2016 07:30:32
       Lease Expires . . . . . . . . . . : Sunday, 5 June, 2016 07:30:32
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 167781666
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-2A-BE-D9-00-25-22-EB-0D-0B
       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Code:
    C:\Users\andre>nbtstat -n
    
    Ethernet:
    Node IpAddress: [192.168.1.2] Scope Id: []
    
                    NetBIOS Local Name Table
    
           Name               Type         Status
        ---------------------------------------------
        FLAM-PC        <00>  UNIQUE      Registered
        WORKGROUP      <00>  GROUP       Registered
        FLAM-PC        <20>  UNIQUE      Registered
        WORKGROUP      <1E>  GROUP       Registered
        WORKGROUP      <1D>  UNIQUE      Registered
        ☺☻__MSBROWSE__☻<01>  GROUP       Registered
    Fixes tried to apply:
    Run the built-in Troubleshooter
    NIC driver uninstall, update
    Kapersky Internet Security uninstall
    Windows firewall turned off
    Reinstalled in adapter properties
    • Client for Microsoft Networks
    • File and Printer Sharing for Microsoft Networks

    sfc /scannow

    • netsh winsock reset
    • netsh int ip reset
    • netsh int ipv4 reset
    • netsh int ipv6 reset
    • ipconfig /release
    • ipconfig /flushdns
    • ipconfig /renew
    • ipconfig /registerdns

    Winsock keys fix
    Code:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
    The services that need to be turned on are listed below:
    • DNS Client
    • Function Discovery Provider Host
    • Function Discovery Resource Publication
    • Peer Networking Grouping
    • HomeGroup Provider
    • HomeGroup Listener
    • SSDP Discovery
    • UPnP Device Host
    1. Open your Registry Editor (Start -> Run -> regedit.exe)
    2. Navigate to Computer:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder
    3. Backup the string ProviderOrder (copy what you have into Notepad or something)
    4. Alter the string ProviderOrder to "RDPNP,LanmanWorkstation,webclient"
    No luck
      My ComputerSystem Spec


  2. Posts : 3,434
    EL Capitan
       04 Jun 2016 #2

    The specified network provider name is invalid


    Really cannot tell what those small thumbnails say.

    If it is from the update that caused protocols to go missing. That is because Microsoft locked down Guest sessions for networking in 10.

    There is a Tutorial on here how to fix the problem, along with a very long thread.
    Last edited by bro67; 04 Jun 2016 at 12:12.
      My ComputerSystem Spec

  3.    04 Jun 2016 #3

    bro67 said: View Post
    Really cannot tell what those small thumbnails say.
    But they are clickable
      My ComputerSystem Spec


  4. Posts : 3,434
    EL Capitan
       04 Jun 2016 #4

    FlamingSoul said: View Post
    But they are clickable
    Yes, but on a iPhone, Taptalk does not render them properly, so they come out all blurred.

    That is why I posted that. It was not so much for them. It is the fact that the board software and Taptalk do not like each other for some reason.
      My ComputerSystem Spec


 

Related Threads
What is the use of this program and can I make it use less CPU? I heard people saying that a virus can cause this but thats only when idle.. (it only uses around 2.2% on idle) when I fire up a game it jumps up to around 14-30% usage.
I upgraded to Windows 10 w/Edge from 8.1 sometime ago. Since then I have experienced several glitches using my e-mail. I use a sub of centurylink (zimbra) e-mail. Problems that are constant: I cannot hear any audio on videos unless I right click the...
Hello Two things have recently happened 1/ just had my W10 auto upgrade and all is working well. 2/ found out that my email provider virgin.net is ceasing to exist. I'm running this email through windows live mail and all seems to be working...
Device Association Framework Provider host in Windows Updates and Activation
McFee detects programs wanting access. How do I know if the above request is Windows 10 related and how do I know if it is safe to allow access?
There is no way in the Mail App to explicitly specify a username for an email account - I guess it just assumes it's whatever is in front of the @ sign in the email address. However, my ISP uses the entire email address as the username for accessing...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:00.
Find Us