Windows 10: Build 10041 Samba doesn't show C drive properly !!!!

  1.    23 Mar 2015 #1

    Build 10041 Samba doesn't show C drive properly !!!!

    Hi there

    3 Linux servers with different distros seem to be unable to read the C drive directory properly on a new Windows 10041 (Real) machine.

    Seems to be NO problem in accessing the other shared drives on the computer. This problem only seems to be when SAMBA wants to access the computer (Windows to Windows works OK even a windows 10 VM on the Linux HOST to a real W10 machine).

    Attached Thumbnails Attached Thumbnails samba.png  
      My ComputerSystem Spec

  2. lehnerus2000's Avatar
    Posts : 1,772
    W7 Ultimate SP1 (64 bit), LM 18.3 MATE (64 bit), W10 Home 1703 (64 bit), W10 Pro 1703 (64 bit) VM
       23 Mar 2015 #2

    SAMBA Issue?

    It could be a SAMBA issue.

    The Linux Mint 17.1 install on my laptop does something similar.
    I have 12 shared folders (NTFS) on my Windows 7 desktop.

    The only shared folder the laptop can see is the one with "read and write" set on it.
    The other 11 "read only" folders do not appear in the file browser.

    My friend's Arch Linux system can see and access all the folders (with the correct restrictions).

    Luckily I can use the W7 install on the laptop to transfer files to my W7 install on my desktop (or vice versa).

    I have no idea what is happening and I can't even come up with a plausible hypothesis.
      My ComputerSystem Spec

  3. badrobot's Avatar
    Posts : 5,121
    Win 10 Pro x64
       23 Mar 2015 #3

    It's a surprise that a linux distro is having that issue. I tested samba sharing between 10041 and the Ras-Pi 2 and everything seems to be fine. Raspberry Pi can see all C folders including hidden folders.

    Click image for larger version. 

Name:	windows_samba_raspi.jpg 
Views:	79 
Size:	976.1 KB 
ID:	15225

    Even permissions are set correctly. I tried copying a file from Windows C folder to Ras-Pi desktop and everything is okay.

    Click image for larger version. 

Name:	windows_raspi_share.jpg 
Views:	21 
Size:	29.6 KB 
ID:	15227
      My ComputerSystem Spec

  4.    24 Mar 2015 #4

    Hi there

    On my ANDROID phone I can access all W10 shared folders too -- the phone reports an SMB:// IP address of windows. (Android 5.0) using EZ-File explorer from google play store.

    Could be something with Samba -- it's not a mega issue as most of my shared folders are not on the "C" drive.

    It only happens with W10 though -- other windows releases work perfectly.

    A get around though

    1) Get the IP address of the Windows machine --say
    2) create a directory on your Linux system /mnt/winc
    3) mount the windows disk as root or sudo mount -t cifs // /mnt/winc

    You'll be prompted for your password for the windows share

    Then it's fine the winc directory has all the files. You might need to set to RW if you want to write to the shares.

    I'll mess around and see if some sort of Host resolution works too --I don't want to rely on specific IP addresses - but it works for the moment.

    Attached Thumbnails Attached Thumbnails snapshot13.png  
    Last edited by jimbo45; 24 Mar 2015 at 06:31.
      My ComputerSystem Spec

  5. lehnerus2000's Avatar
    Posts : 1,772
    W7 Ultimate SP1 (64 bit), LM 18.3 MATE (64 bit), W10 Home 1703 (64 bit), W10 Pro 1703 (64 bit) VM
       24 Mar 2015 #5

    Thanks jimbo45

    Thanks jimbo45.

    I'll test it out later (I'm behind schedule on a bunch of projects).
      My ComputerSystem Spec


Related Threads
I'm doing fabbo with Win10 /s Because of some annoyances - hopefully fixed in the RTM Version - my USB drives cannot be ejected safely from their controller in Win10. So I eject them with the hardware release mechanism from the external...
Getting a SSD soon to install Windows 8.1.1, so I figured I'd try this out on bare metal before I replace the drive as my main. I tried an earlier build in a VM and thought it was alright, but I can't really test it in a thorough way through a VM....
I had full touch support with windows 8.1 and with windows 10 10041 its has limited with 10 touch points. Could this be an hp driver issue?
Hi there Build 9879 doesn't work properly in Unity mode ---(VMware workstation 10.0.4 and 11.0) Not a mega issue but Unity mode is great if you want to concurrently test things without flipping back into the VM's full screen mode. Part of...
Hi! I just installed the latest build, but for some reason, when I turn my PC on, I see the usual BIOS thing, then it's pitch black. I know the boot menu is still there, but nothing on the screen. Is there any way to fix this? Edit: I can access...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:41.
Find Us