Page 1 of 2 12 LastLast
  1.    17 Apr 2016 #1
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop

    Can't access NAS by name


    Yesterday I did a clean (re)install of Windows 10. All seemed ok, but today I cannot access a NAS disk by name. I can access it by IP address, and nslookup correctly resolve both name and addresses. But if I try to access \\MyBookLive (I know, - a cleverly original name.) - I get an error saying "Windows cannot access \\MyBookLive", giving an error code 0x80004005.

    For the time being, I've mapped the IP address so I can access the drive, but I recall getting security warning popups in the past when I've done that so I hope this is temporary. And the IP address is set DHCP so I can't guarantee it will stay the same.

    Any idea how to resolve this?
      My ComputerSystem Spec
  2.    17 Apr 2016 #2
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 9,349
    Windows 10 (Pro and Insider Pro)

    WD has some useful applications. Try WD quickview, it will give quick access to state of drive and also a way to go to drive.
    Just a suggestion.

    Also host name may have changed with some firmware updates.
      My ComputerSystem Spec
  3.    17 Apr 2016 #3
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    The WD application that maps drives seems to use the address rather than name of the server. Two other PCs are accessing the server by name so I'm pretty sure the name hasn't changed. (But that doesn't mean I used the right name or specified it correctly in the Map process.) I'll dig around some more.
      My ComputerSystem Spec
  4.    17 Apr 2016 #4
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 9,349
    Windows 10 (Pro and Insider Pro)

    Do you have network discovery turned on? New installations of Windows sometimes needs few days to get all connectivity...
    Attached Thumbnails Attached Thumbnails 2016_04_17_19_46_571.png  
      My ComputerSystem Spec
  5.    17 Apr 2016 #5
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    Yes, I have network discovery turned on ... at least on the place you showed. I don't know about other options I might have wrong. In a detail display of the Network part of the file explorer display, Windows says it uses SSDP to discover the NAS server. I have no idea if that's what I should be using (or how to change it if it's not right).
      My ComputerSystem Spec
  6.    17 Apr 2016 #6
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 9,349
    Windows 10 (Pro and Insider Pro)

    It most probably doesn't matter.

    Can you connect to your WD and check name? I can connect to mine with clicking on MyBookLive icon in windows explorer, or by giving IP number in browser. Check for name setting (if you have change it) or for quick solution to give it static IP number.

    Edit: also download and run WD Discovery app from WD site. It may help.
    Attached Thumbnails Attached Thumbnails 2016_04_17_20_31_291.png  
    Last edited by AndreTen; 17 Apr 2016 at 16:03.
      My ComputerSystem Spec
  7.    17 Apr 2016 #7
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 9,349
    Windows 10 (Pro and Insider Pro)

    I found a thread on WDC forums and some possible solutions to your problem.

    If you didn't already, you ca read the from this post on...
      My ComputerSystem Spec
  8.    17 Apr 2016 #8
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    I've now read that post - I had missed it. I'm a little reluctant to mess with the LAN Manager Security Level because
    1. it worked on the now problematic PC before I did a clean reinstall of Windows 10 (although sometimes not right after a reboot)
    2. it works correctly on 2 other PCs - 1 running Win10, the other running Win7. I didn't have to do anything special on those PCs.
      My ComputerSystem Spec
  9.    18 Apr 2016 #9
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 9,349
    Windows 10 (Pro and Insider Pro)

    Must agree with you. It works for me on Windows Insider and on RTM Windows 10 with clean install.

    Try first with some of the WDs tools. I will come back on the (my) afternoon.
      My ComputerSystem Spec
  10.    18 Apr 2016 #10
    Join Date : May 2015
    Central IL
    Posts : 4,367
    Mac OS Sierra

    Just means that the Tables are screwed up and need flushed. Unplug the router and make sure that it flushes the tables, along with reset the Winsock on the machines.

    Names are great when a device may have a DHCP vs. Static IP. If the device has a static IP. Use that, vs the name.

    Western Digital does some screwball stuff with their version of Samba for the embedded Linux they use.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
No LAN access
Hello everyone, I installed Windows 10 Enterprise and after 30 minutes, after one restart, LAN stopped working. I have internet connection but I can't acces my LAN (laptop and storage server). My PC has a Realtek PCI GBE Family Controller. I...
Network and Sharing
Solved Internet Access but no Network Access
Hello, I am new to this thread and I encountered some problems with my internet. My internet worked fine and I didn't do any changes to it up until it stopped working. I've managed to fix the internet access to allow me to access the internet on...
Network and Sharing
Solved can't access network device normally? weird access ...
Hello : I can't access network device normally ? It is a internet power switch . For example if I type in 192.168.1.5/20000 , I can access the device . But with 192.168.1.5:20000 gives no access . Ideas , If I could get the latter to work...
Network and Sharing
Access to shared folders but no access to save or move files
Clean install of w10. I am signed in w/a local account which is also an admin account on the PC I'm saving/moving too. I have read/write access to these folders but I cannot save to the folders. Any idea what's going on? 33597
Network and Sharing
Access Denied. You don't have permission to access "" on this server.
ERROR MESSAGE Access Denied You don't have permission to access "http://steamcommunity.com/id/Fazy_aka_TaZx/home/invites/" on this server.Reference #18.b1f31502.1439008845.47ab9a03 Hello there, I use steam. So basically what's happening...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:03.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums