I am the sad and disappointed owner of a 4G LTE Dell Venue Pro 11CRAPLET (BayTrail). It is a crap tablet.
From bad touch screen drivers and lack of connected sleep on the device, itfrustrated me that I finally installed W10 TP Build 9926. Forgetthat it destroyed my Macrium Backup installation. Forget that it is anunfinished product: I am no longer losing 40% battery discharge over 8hours - mind you 40% of both the tablet and the special keyboard with a batteryinside) as I did on 8.1 due to the USB 3.0 driver that prevented sleep. Win 8.1 wasn't too bad but I was unable to sleep the tablet properly and 4G LTE never worked at proper speeds. But it worked.

With Windows 10 TP I have a problem. I cannot get 4G LTE to work.

I did 2 Win10TP installations.

First installation did not install the hardware (Dell Wireless 5808 Gobi 4G LTE Mobile Broadband Card). Doing a manual search in the Device Manager did not reveal it. Upon installation of the Windows 8.1 driver, the device appeared and so did the relevant toggle switches (in the right side menu where the Charms Bar used to be as well as the main Network & Internet settings page). My carrier is T-Mobile and T-Mobile icon appeared, complete with the phone number for the SIM and its options to connect on data and to roam. Regardless of the toggles, the tablet never connected to the network and always gave me a "device cannot be registered on the network" error. I tried a Verizon card and that card was recognized but it could not connect to the Verizon network either.

I reverted back to Windows 8.1 and after convincing myself, I did a second install. This time the Device Manager showed the Dell Wireless 5808 Gobi 4G LTE Mobile Broadband Card right from the first screen. The driver was a generic Microsoft one and it refused to change even when I installed the correct drivers. The T-Mobile carrier icon persisted and so did the different toggles UNTIL I forced the correct drivers (Update Driver ...Have Disc...navigate to where I extracted the driver...etc). Then the toggle switches disappeared and as it sits now, there are no options to enable the Broadband connection, despite the device showing up in the Device Manager. I am not entirely surprised because similar issues were common in Windows 8.1 when I updated broadband card drivers.

So what do I do now? Give up on broadband on Windows 10TP? Reinstall? Try other drivers? Or do I simply steal the USB drivers from Win 10 installation and force them in Win 8.1, hope they work and cure the sleep issues and wait another year until the finished product goes to Win 10 SP1 and hope it works?

Advice needed. Thanks.