Page 1 of 3 123 LastLast
  1.    10 Apr 2016 #1
    Join Date : Apr 2016
    Posts : 7
    Windows 10 Pro

    Yet another gigabit ethernet issue


    Hello everyone,

    Found this forum from my Google searches but couldn't find a similar issue.

    I use ethernet cable to connect my laptop to a router. My router supports gigabit connection and the wiring of the house is cat 5e. Yet the connection is very unstable on my machine and I hardly see 1 Gbps negotiation. It is mostly auto negotiated as 100 Mbps. Read similar topics and saw that the problem often lies from the infrastructure. However, I did see 1 Gbit connection a couple of times within Windows 10 so I eliminated that out of the equation.

    Here's what I have tried so far:


    • I tried to set to 1 Gbps full duplex from auto negotiation in ethernet card settings. (I have onboard RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller) This did not change the negotiation speed, it remained on 100 Mbps.


    • I tried booting to Ubuntu from an USB drive to check the connection and it was 1 Gbps and pretty stable; by that I mean it did not decrease the negotiation speed. Here you can see the hardware output from Ubuntu: Hardware output
    • Strangely, after rebooting from Ubuntu to Windows 10, I saw 1 Gbps connection on ethernet status. However, this was temporary and switched automatically back to 100Mbps after some minutes. Plugging the ethernet cable out and back in multiple times sometimes helps to get 1 Gbit connection but this too is a temporary solution.




    Any tip would be appreciated. Thanks.
    Last edited by erdihu; 10 Apr 2016 at 09:58.
      My ComputerSystem Spec
  2.    10 Apr 2016 #2
    Join Date : Jul 2015
    Posts : 9,550
    Windows 10 Pro

    At a minimum, upgrade the plugs on the ends of the cables to 3-piece CAT6:
    Ideal RJ45 Cat6 Modular Plugs (25-Pack)-85-366 - The Home Depot

    and be sure to use a good quality, ratcheting crimping tool. Your problem is almost guaranteed to be the wiring.

    If you are using wall jacks, make sure they are rated CAT6 as well.
      My ComputerSystem Spec
  3.    10 Apr 2016 #3
    Join Date : Apr 2016
    Posts : 7
    Windows 10 Pro
    Thread Starter

    Hi,
    Thanks for the answer. I did not understand how Ubuntu can manage to keep 1Gbps connection but Windows keeps reducing the speed to 100Mbps on the same infrastructure. Can it be a driver issue?
      My ComputerSystem Spec
  4.    10 Apr 2016 #4
    Join Date : Jul 2015
    Posts : 9,550
    Windows 10 Pro

    Different levels of fault tolerance. Ubuntu would appear to be more tolerant of faults than Windows. Might want to look at your packet loss statistics between Ubuntu maintaining a Gigabit connection at the expense of increased packet loss vs. Windows dropping the speed due to the likely high packet loss occurring at Gigabit speeds.

    There are several VOIP testing sites that will measure network performance. It would be interesting to compare the results in Ubuntu at Gigabit speeds against Windows at 100 Meg.
      My ComputerSystem Spec
  5.    10 Apr 2016 #5
    Join Date : Apr 2016
    Posts : 7
    Windows 10 Pro
    Thread Starter

    What kind of websites can be used to measure packet loss? Ping tests from cmd show 0% loss.
      My ComputerSystem Spec
  6.    10 Apr 2016 #6
    Join Date : Jun 2014
    Posts : 554
    Microsoft Windows 10 Pro 64-bit

    There is a couple ways to use the ping command

    To continuously send ping,
    Code:
    ping -t 8.8.8.8
    press Ctrl + C to stop it

    To send a number of ping's
    Code:
    ping -n 10 8.8.8.8
    In this example I sent 10

    As far as I know if you try these command's with linux it should work the same.
      My ComputerSystem Spec
  7.    10 Apr 2016 #7
    Join Date : Jul 2015
    Posts : 9,550
    Windows 10 Pro

    Quote Originally Posted by erdihu View Post
    What kind of websites can be used to measure packet loss? Ping tests from cmd show 0% loss.
    I've used this one in the past:
    8x8, Inc. VoIP Test and Broadband Speed Test

    But you want to compare your results Gigabit vs. 100 Meg, not just the green light for VOIP
      My ComputerSystem Spec
  8.    11 Apr 2016 #8
    Join Date : Nov 2015
    Posts : 6
    Windows 10 Home 64bit

    Sounds like the cable. If you have not used a cable tester then the infrastructure is still suspect.
    HDE® Network Cable Tester: Circuit Testers: Amazon.com: Industrial Scientific
      My ComputerSystem Spec
  9.    11 Apr 2016 #9
    Join Date : Jul 2015
    Posts : 9,550
    Windows 10 Pro

    Quote Originally Posted by Xtech View Post
    Sounds like the cable. If you have not used a cable tester then the infrastructure is still suspect.
    HDE® Network Cable Tester: Circuit Testers: Amazon.com: Industrial Scientific
    I have one of those. That only checks continuity, though. It doesn't check capacity. You can get all green lights on it but still not be able to get Gigabit connectivity. I originally ran cheap, Chinese CAT 5e cable from EBay in my house (basement runs, from main router to two hubs). I had a perfect connection according to that tester, but only 100 meg connection between the router and hubs. Replaced the cable with good CAT 6 from Home Depot but was using the cheap Chinese EBay connectors I had bought with the cable from EBay. I had a very hard time getting good continuity and always had one or two lights on that tester that wouldn't light.

    So then I got the good 3-piece CAT6 connectors, also from Home Depot and now I have rock solid Gigabit connections. I also attempted to make 12ft patch cords to go between my hubs and the devices. I used the cheap CAT 5e cable with the good 3-piece connectors. Still only 100 meg connection - even through only 12 ft of the cheap cable. I made patch cables with the good CAT 6 cable and, again, rock solid Gigabit connection between hubs and devices.
      My ComputerSystem Spec
  10.    11 Apr 2016 #10
    Join Date : Apr 2016
    Posts : 7
    Windows 10 Pro
    Thread Starter

    I tried to do a test, but couldn't manage to install Java on a live Ubuntu. Therefore I couldn't run the test on Ubuntu.

    Based on the comments here, I tried with two different (but shorter than what I used to use) 5e cables which are ~3 meters long and they were all able to give 1 Gbps connection. My regular cable is a Belkin and it is 5 meters long. I highly doubt that extra 2 meters causing the problem. I will try changing to a better cable, preferably a CAT 6 but it is not a requirement. Do you guys have any recommendations? I should mention that I live in Europe and ordering from websites such as Amazon would probably double the cost of cable price due to shipping fees.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Sleep issue + Full Screen Video issue
Hello! I bought a Windows 10 Asus laptop about a month back and have been running into a few issues. I actually have tried asking the Microsoft tech forums directly but with a lack of responses I feel I need to ask elsewhere. There are two...
General Support
Windows 10 slow minimizing/maximizing issue & search issue.
Hello! I upgraded to Windows 10 today. I have two issues. 1. I play a game called "Starcraft II" and I have a problem with the game minimizing and maximizing sometimes very slowly, every 5th attempt or so. During this time it takes up to 40...
General Support
Switching from ethernet connection to Wifi issue
Hi guys. Bit of a "first world problem" here i know but it is slightly irritating and really would appreciate any help There is 2 computers and 2 virgin superhubs in the house i live in (not both mine) both ethernet connected. Occasionally i...
Network and Sharing
Issues with integrated Ethernet and PCI-E Ethernet adapters
Hello, Recently my on-board Ethernet port stopped working. At first I noticed that I no longer had the Wired Connection in the bottom right of my taskbar, instead replaced by the Wi-Fi symbol. I checked to make sure that my ethernet cable was...
Drivers and Hardware
Ethernet adapter hardware or software/driver issue?
I'm currently getting a strange issue with the on-board ethernet adapter on my older secondary system I use in the living room that I use for mainly just desktop apps. Before upgrading to Windows 10 pro x64 yesterday I was running Windows 7...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:08.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums