If I plug in my D hard drive, I lose my network?!?! Solved

  1.    #1

    If I plug in my D hard drive, I lose my network?!?!


    Here's the background:

    Computer has an Asus M5A88-M motherboard, with an AMD FX-8350 cpu. It had been running Win7/64. It has two harddrives, an SSD Samsung 850 evo (C drive) and a WD Black spinner (D drive). In Win7 I was unable to get the SSD into AHCI mode. (The mobo has Sata ports 1-4 as either IDE or AHCI or RAID, and ports 5-6 as IDE. I have Bluray ODD in port 6.)

    I decided to upgrade to Win 10. Prior to the upgrade, I disconnected the D drive, which shouldn't have anything on it but games and some personal docs and pics. I performed the upgrade with just C connected.

    All was good.

    I successfully changed my C drive to AHCI mode. Rebooted several times. All was still good.

    By "all is good", I mean EVERYTHING seemed good, and the internet/networking worked.

    This morning, I decided to plug in the D drive back into SATA port 2. Upon booting, there was a yellow exclamation symbol over the network connection near the task tray and I had no network at all. I used a usb stick to upload the latest Win10 Network driver for the mobo's Realtek 8111E network interface. The yellow error symbol remained.

    I tried various troubleshooting techniques (safe boot with network, limited services, etc.) and nothing changed.

    The network switch shows connectivity and the port on the rear of the computer shows a solid green light and flashing yellow light. That indicates Gigabit speed connection and data input/output. This is with the yellow exclamation symbol and no network functionality

    I did notice that the network symbol seems good at first during bootup. Then, as the Win10 bootup music fades, the yellow icon appears.

    If I disconnect the D drive from Sata 2, I regain full network functionality.

    (D has been on Sata 2 (in IDE not the current AHCI) for about 3 years with no issues.)

    - Is there a SATA/NIC interference issue?
    - Is there some file on D which interferes with Win10's networking?
    - Is it a problem because D had been IDE and is now being accessed as AHCI (through BIOS setting)?


      My ComputerSystem Spec

  2.    #2

    Additional information:

    - I've just powered down, disconnected the D drive, booted and again all is good...

    - Powered down again and connected D drive to Sata port 5 (an IDE drive). Booted up...and all is good.

    The problem seems to be using D drive (which is PURELY a data drive as far as I know) in the AHCI mode. Looking at Disk Management, the D drive seems to be an MBR style.

    Note that the D drive is totally accessible when it is in the Sata 2 port (AHCI port). There is nothing wrong with accessing or using D drive. The only symptom is total network dysfunctionality. (Sata port 5 allows networking and D drive access.)

    I'd like to use it in one of the AHCI sata ports (1-4).

    Still stumped...

      My ComputerSystem Spec

  3.    #3

    - plugged the D drive into Sata port 3 (AHCI port). Networking worked.
    - plugged the D drive into Sata port 2 (AHCI port, which originally seemed to be the cause of the issues). Networking worked.


    I guess it fixed itself. Marking this as solved. Do I gain points?
      My ComputerSystem Spec


Related Threads
I may have posted this before, so I apologize for being repetitive. I have a hard drive that is connect to my modem / router via a usb connection. The drive is accessed via \\mynetwork\NETWORKHD After rebooting my router, this will work for...
Usually when we plug in a SATA drive it will show up in explorer but it doesn't now after I install Windows 10 (clean install). It work well when I'm on Win 7. I've check the BIOS it indicate all ports AHCI an I never change anything since Win 7....
I have a usb connected hard drive connected to my Bell 2000 router. The instructions to access this drive is to go to the Documents folder and enter \\mynetwork. This then shows the shared hard drive as \\mynetwork\NETWORKHD. If I now click on...
when I plug in a usb drive its not shown in explorer I also hot swap SSD drives and as far as windows is concerned they are not there! In win 7 I used to get a sound and they would appear in the explorer window almost immediately. does anyone...
Source: Google Drive Blog: Introducing the Google Drive plug-in for Microsoft Office Download: Google Drive plug-in for Microsoft Office
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:32.
Find Us