Windows 10: Slow RDP (Prior to Connection) and Task Manager Solved

Page 1 of 2 12 LastLast

  1. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
       20 Mar 2016 #1

    Slow RDP (Prior to Connection) and Task Manager


    Hi There,

    I've burnt a hole in google's bottom line search for answers for this, but I have come up negative on all counts.

    Hence I have to change from been a lurker to a poster.

    Machine: 4 year old, Intel 2 core hardware (3GHz ish), 8G RAM, - All running off 250GB SSD. Normally - for desktop apps and general run of the mill stuff - this thing is blisteringly quick.
    Did a fresh install of Win10_64. Thumbs up, all sweet. Went to set up RDP links for the services that this machine has to access - uh oh. Open task Manager uh-oh.

    Now - to explain. Notepad - launches in less than a split second - chrome, IE, etc (the heavier apps) take < 1s for a window to appear. A little longer and the window is populated.

    Task Manager (right click off explorer) maybe 10 seconds, before it will show itself.

    RDP - now we are in a different league. Windows knows something is fishy, because it politely tells me that the program is unresponsive by redrawing it's taskbar. When it gets to typing an address into the RDP, it can take upto 5 seconds prior to a keystroke echoing on the screen. I have TaskMan open at this point, the system is idle. Nothing is being stressed, especially not the RDP App. Establishing a saved RDP session can be 20 seconds, establishing a new one takes minutes. Once the RDP session is open this problem is gone.

    Thoughts? My best guess is there is some sort of GUI lockup somewhere. I managed to diagnose one of these for a friend last week - it turned out to be OpenGL Resource starvation across multiple apps when it looks like global locks were not being handled correctly. This only took me about 15 min to figure this out. This RDP issue I have spent considerably longer on, and since this is all native windows apps, and they work on all other setups in the same environment, I'm a bit stumped.

    Oh - the machine previously had Win7_32 on it and there was no issues.

    Has anyone seen this before? - any pointers?

    Before anyone asks - there is nothing but default AV on there, so nothing hooking the OS in inappropriate places.

    Thanks
      My ComputerSystem Spec

  2.    21 Mar 2016 #2

    What is your graphics hardware? Needless to say, I had some big issues with the taskbar taking forever to load. The window would come up, but nothing would show inside, for like 10 seconds or so. One of the services wasn't showing up correctly causing task manager to hang. NVIDIA Geforce GT 630 Driver version 331.82. Updating the drivers fixed that problem. No issues now.

    Now, Remote Desktop Connection is much different. I haven't played with it on Windows 10, but used it on Windows 8.1 and had no issues with it.

    Have you by chance opened an elevated command prompt and do sfc /scannow
    Just to check to make sure there are no system errors.

    Win7 32 or 64 bit had no issues with remote desktop.

    Funny, now I'm wanting to check that out now
      My ComputerSystem Spec


  3. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
    Thread Starter
       21 Mar 2016 #3

    Hi Imaneke,

    Thanks for the suggestions.

    These faults were present immediately after a fresh build. Yes - sfc /scannow came up with issues - but they revolved around directory ownership. I can't see that being an issue.

    DXDiag says it is a GeForce GT 620 running 10.18.13.5891 - which I am pretty sure are the latest set of WQHL released drivers for that HW.

    Yep - it stinks of graphics card conflicts - but I just can't think why.

    Thanks
      My ComputerSystem Spec

  4.    21 Mar 2016 #4

    There should have been no conflicts after a fresh install. That is kind of odd.
      My ComputerSystem Spec

  5.    21 Mar 2016 #5

    System file corruptions are odd too after a fresh install. I've never seen that before.
      My ComputerSystem Spec


  6. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
    Thread Starter
       21 Mar 2016 #6

    Thanks for your musings. A reasonably expert user has been using this system for about 2 months, after which time I have performed the scan. I wouldn't have expected to see any faults, either, and didn't think to check at that time.

    I've also noticed that Win+X, admin shell is also slow to launch. When I get back there today, I'll see if it happens to non admin, as well.

    Thanks
      My ComputerSystem Spec


  7. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
    Thread Starter
       22 Mar 2016 #7

    Ok - I just had a look at that machine. Command Prompt (User mode) comes up quick, as you would expect.

    Admin command prompt behaves as follows;
    1. Instantly clears the desktop and throws up the security warning.
    2. Click Ok - dialog disappears, and the desktop doesn't return. for about 3~4 seconds.
    3. Desktop returns, command prompt app doesn't appear.
    4. 5 seconds later (desktop is fully functional), then the Admin command prompt pops up.

    For me - and I program as well; the fault's DNA suggests it has to be on the windows event loop, but a call made to the GUI subsystem, that blocks, but does not wait - so no CPU time is being registered against any particular task.

    Hmmm - I might try bleeding edge display drivers.
      My ComputerSystem Spec

  8.    22 Mar 2016 #8

    Latest driver is 361.43
      My ComputerSystem Spec


  9. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
    Thread Starter
       22 Mar 2016 #9

    Thanks for that - I'll try that tomorrow.
      My ComputerSystem Spec


  10. Posts : 8
    Win 10/ W7 / XP / OpenBSD/ Ubuntu / Centos
    Thread Starter
       28 Mar 2016 #10

    I've got a bit warmer:

    Microsoft Visual Studio 2010 Tools for Office Runtime : 10.0.50903 - removing this fixed the issue on one machine, however not the original machine with the issues.

    I've managed to clone a few VMs and I have seen this issue now on two of 3 of them.

    So it isn't hardware.

    I'll keep poking.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Task manager crash in General Support
Hi, I've tried to re-install windows several times prior to creating this thread, but i always encounter the same issue of Task Manager crashing and causing windows explorer to crash and it's annoying it usually does it for 30 minutes after the...
Task manager and RAM speeds in General Support
Hello, I have recently installed new RAm (Corsair Vengeance 16GB 1866 mhz). In Task Manger it's showing the ram speed as 1400. Bios is showing at 1866 and also in CPU Z. XMP is enabled. Any ideas? Is this a win 10 bug etc Thanks in...
CPU @ 100% in Task Manager.. but in error in Performance & Maintenance
Hey guys Screenshot: Imgur Seems to be happening since I installed Windows 10 on my machine. I am 100% sure it is in error as speedfan reports my CPU usage at 1/2% and I am seeing no problems when playing games such as CSGO and h1z1. My...
Task manager App History tab in General Support
Hi, In task manager on the app history tab I have a listing called Uninstalled Processes. In has used about 58 minutes of Cpu time since I cleared the history about a week ago. Any Idea how I can find out what the uninstalled processes are or any...
Solved Task Manager App Name Bug ? in General Support
Upgraded from 8.1, finished installing all W10 updates and I was looking in the App History tab in Task Manager and I saw this : 32362 What the heck is that ? I need to say that I checked for updates in the Store App and it downloaded 2...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:59.
Find Us