Page 1 of 7 123 ... LastLast
  1.    13 Mar 2016 #1
    Join Date : Mar 2016
    Posts : 8
    Windows 10

    Samba access from Android device stopped working


    I used to be able to access my Windows 10 machine from my Android tablet via smb:// but this has now stopped working. My Android file manager app can still discover and get the correct name of my PC, but username/password is no longer accepted.


    The only thing that has changed since I last attempted to access my PC from my tablet is one or two automatic Windows updates.


    I tried trouble shooting and got the “one or more network protocols are missing on this computer” error, which it says it fixed in administrator mode, but it didn't change anything.


    Googling on various fixes mostly seem to result in pages of people not able to connect to the internet at all, but that is not my problem.


    Anyone encountered this?
      My ComputerSystem Spec
  2.    13 Mar 2016 #2
    Join Date : May 2015
    Central IL
    Posts : 4,035
    Mac OS Sierra

    There is a File sharing app out there for Android devices. When connecting to workgroup shares on an Android OS or iOS device, the OS can block you from doing so, to protect the OS and device.

    Windows uses CIFS for sharing, not SAMBA. The version of Samba that Microsoft uses, is a very crippled version and has had issues recently since the last update. Download ES File Explorer from the Google Play store and use that to access your shares. I have never had any issues with it.
      My ComputerSystem Spec
  3.    14 Mar 2016 #3
    Join Date : Mar 2016
    Posts : 8
    Windows 10
    Thread Starter

    That app is exacly what I'm using!

    When you connect to your named PC in the Lan tab of that app, and the password dialogue comes up, if you look at the top, it actually says smb://your.ip.here which is why I assumed the app used samba. Is there a setting to force it to use cifs instead? It's very weird if the app switched a setting during the last month or so, because I haven't used it since last time, and last time it worked.
      My ComputerSystem Spec
  4.    14 Mar 2016 #4
    Join Date : May 2015
    Central IL
    Posts : 4,035
    Mac OS Sierra

    Stop entering the smb:// when setting up the connection. You have to use the IP or at the bottom with the list of devices, just click on it and enter username and password.

    Android and iOS devices do not have the capability of using Samba, CIFS, NFS, is why you have to use third party apps.

    If you press the plus sign in the upper right corner of the app and choose the type of OS, it will show at the bottom in "Network Neighborhood", available devices with shares.
    Last edited by bro67; 14 Mar 2016 at 08:44.
      My ComputerSystem Spec
  5.    14 Mar 2016 #5
    Join Date : May 2015
    Central IL
    Posts : 4,035
    Mac OS Sierra

    You cannot add smb:// to the IP, because it will always cause issues with the File Explorer app. It is already coded to understand the various ways of connecting to shares.
      My ComputerSystem Spec
  6.    14 Mar 2016 #6
    Join Date : Mar 2016
    Posts : 8
    Windows 10
    Thread Starter

    Thank you for trying to help me, but please read carefully what I said again. You misread two of my points:


    1. The android app finds my NAMED PC in the lan tab! I do not enter anything!
    2. The password prompt of the android app ITSELF pops up smb:// with the ip after I click the named PC. I do not enter anything!


    (Well, apart from my username and password, which as of last month, no longer works.)

    I do not have a plus sign in the top right corner of ES File Explorer, only an X. Only place I found a plus sign is in the Windows management, and there I can choose http(web), file(Local), https(Web) and samba(LAN). This again, leads me to think that the problem is not with ES File Explorer, but rather a Windows 10 update which somehow sabotaged samba access.

    I actually found this topic which you also posted in, but disabling Samba v2 and v3 via Powershell did not resolve the problem for me:

    One or more network protocols are missing on this computer - Windows 10 Forums
      My ComputerSystem Spec
  7.    14 Mar 2016 #7

    Hi there.

    Why not use this ANDROID app on your phone

    ES-file explorer -- it's free and will scan your network --finds all my Windows shares -- you might need to enter your password on Windows shares depending on how you enabled the sharing (On Windows).

    Works fine on my Samsung S5

    Can do a lot of other interesting things too.

    On Android phones get it from Google play store. FREE.

    19 Things You Didns ES File Explorer Can Do


    In particular I've found this one useful in the past : I'll bet a load of people here didn't realize you can mount a USB device on your phone too !!!!

    ..................................................

    7. Mount a USB Drive on Your Android Phone

    Most (if not all) Android devices use a USB connection for charging and transferring files, and thus conveniently work with pen drives, too. So if you’ve got photos and videos to transfer—or a movie to watch on a long plane ride overseas—you don’t have to limit yourself to a laptop or wait for the long transfer process. Simply plug in your pen drive and start watching the movie.

    You’ll need a physical USB OTG (On-the-Go) cable with a male microUSB connector-to-female full size USB port, rooted Android device, and two apps: StickMount to mount the pen drive and ES File Explorer as a file manager. To perform the necessary steps we have an article on how to use a USB drive with your Android device. While the cable is a tad bit bulky, it’s still convenient if you travel a lot or have a flaky Internet connection.

    ............................................................

    These days with additional micro SD cards for storage then not so important but if your phone doesn't have an additional micro sd card then could be of interest.

    BTW for those thinking of new Samsung S7 -- that finally has bought back the micro Sd card again for additional storage. The S5 had it but not the S6. In all ways round IMO the S6 was a dog and not worth changing from an S5 (which also still has replaceable battery).
    The S7 might be worth a look but I can't really see advantage over S5 currently. The S6 though -- AVOID -- there will be some cheap ones on the market now S7 is out. Again AVOID.

    Cheers
    jimbo
      My ComputerSystem Spec
  8.    14 Mar 2016 #8
    Join Date : May 2015
    Central IL
    Posts : 4,035
    Mac OS Sierra

    Jimbo that is the one that I posted. Use it all of the time along with ES's FTP manager app, when accessing my NAS. Best thing is that it is pretty much dummy proof and so easy to use. Really do not know why the OP thought that they have to use smb://, when it does not even ask for it when setting up the device you want to access.
      My ComputerSystem Spec
  9.    14 Mar 2016 #9

    Quote Originally Posted by bro67 View Post
    Jimbo that is the one that I posted. Use it all of the time along with ES's FTP manager app, when accessing my NAS. Best thing is that it is pretty much dummy proof and so easy to use. Really do not know why the OP thought that they have to use smb://, when it does not even ask for it when setting up the device you want to access.
    Hi there

    I missed that - but agree it's not even IDIOT proof -- It's also JIMBO proof so it must work OK !!!! Actually worked first time on my phone and I'm usually hopeless with those sorts of devices- I've only just realized that Phones actually aren't used about 90% of the time for making phone calls !!!!.

    Cheers
    jimbo
      My ComputerSystem Spec
  10.    14 Mar 2016 #10
    Join Date : Mar 2016
    Posts : 8
    Windows 10
    Thread Starter

    Jesus Christ the lack of reading comprehension here. I get that you are trying to help, but holy shit...

    I AM USING THE APP YOU ARE SUGGESTING. IT WONT ACCEPT USER/PASSWORD TO MY PC ON THE LAN TAB. NOW WHAT??


    Have either of you comprehended the fact that I had everything working fine up until the last Windows 10 update or two?

    (Also, you apparently don't get that I have not done anything to display my IP... the app pops this up when I click on my PC icon after a network scan, as you can see in the image below. Finally, it's not a phone, it's a tablet.)


    Click image for larger version. 

Name:	unspecified.png 
Views:	3 
Size:	67.5 KB 
ID:	69388

    Heck, if you guys select the properties of your Server in the app, does the path not say smb:// ?
      My ComputerSystem Spec

 
Page 1 of 7 123 ... LastLast


Similar Threads
Thread Forum
win10 VPN samba Android
yo dudes! im so i got a little project going on here and its not going well. I have my win10 pc at home and i want to access my network shared hdd's from my android when im out and about. I am using Total Commander on my Android. I can browse...
Network and Sharing
Solved Can't access Samba shares on 10049
I just reinstalled after I was having issues. Everything seems to be working smoothly, except that I can't access the shares on all but one of my other computers for some reason. Most devices that aren't running either some flavor of Windows or...
Network and Sharing
Solved can't access network device normally? weird access ...
Hello : I can't access network device normally ? It is a internet power switch . For example if I type in 192.168.1.5/20000 , I can access the device . But with 192.168.1.5:20000 gives no access . Ideas , If I could get the latter to work...
Network and Sharing
Solved Android Device Upload photos and Videos
I have tried uploading images and videos using Windows 10 without any success. Win 7 seemed to work perfectly, but is not the same with win 10. When connecting the Android device to Win 10, it wants to upload everything to Photos, but after a few...
Drivers and Hardware
Solved W10 access from SAMBA now OK (build 10074)
Hi there On previous builds of Windows I was getting strange mappings on the "C" drive from SAMBA - it was only showing Boot and missing the rest of the directory. Other drives were fine ???!! Clean install on build 10074 seems to have fixed the...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums