I had a server computer that was running windows 7. It was working like a charm, but suddenly I was unable to remote to it. I found a monitor and keyboard that I connected. My server then told me that it had installed windows 10. Wow thanks… That is something I would like to have a say in… But oh well might as well get with the times and use windows 10.
As I am using it as a server it is running, iis, ftp, plex, and some other servers. Most of it were still working after the conversion to windows 10, but I’m been having some real problems with the normal sharing of files. When I use my desktop computer (also running windows 10) to brows the network I get the following error when dobbelt-clicking my server computer:
“\\SERVERNAME is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Logon faliure: the user has not been granted the requested logon type at this computer.”
So ok… there are always problems with filesharing with a new windows installation. So I did the following:
· Made sure file and printer sharing were turned on
· It was using: Use user accounts and passwords to connect to other computer
· Password protected sharing sharing were turned off
· I turned on sharing so anyone with network access can read and write files in the public folders
· My network adapter is using my router ip address as DNS server
· My network adapter has Netbios over Tcpip enabled
· I went to Local security Policy and made sure that nothing were listed in “Deny acces to this computer from the network”
· I Local Security Policy I verified that “Access this computer from the network” included Everyone
· I went to Computer Management to ensure that the guest user were enabled.
Some of these things normally does the trick. But no…
I then tried to connect to \\ which is the internal ip address of the server. That worked perfectly. I am able to see all my shared folders and copy files as I want.
It turned out I have the same problem for remote desktop connection. I can only connect using the ip address, which works fine.
Ok then… From my desktop computer I tried to ping the server name and I get back.
When I browse the network I see all my connected computers including the server, but when I dobbelt-click it I get the same error as I mentioned above.
I tried to go to my router and look in the DCHP clienttable it all looks good. It finds the server name and the ip matches
I have tried to restart the router and all computers involved.
Now I’m at a loss. It all works when using ip address but not when using computer name.
I could of course hard code the server name and ip in my desktops hosts file but that would be a hack and I would worry that other windows 10 computers would have the same issue. One my other computers still running windows 7 have no problems. It can see the server and browse all folders and files.
Any ideas ??