Windows 10: Very slow internet after upgrade to 64bit

  1.    27 Feb 2016 #1

    Very slow internet after upgrade to 64bit


    Hi, I just upgraded from Win 10 32 to Win 10 64 bit and my internet connection is very slow, about 20/30 kb/s. It was a fresh install, deleted everything and reinstalled from scratch. I have looked on the forums and cant find a solution that works, I've checked the network adapter drivers for my wireless and they're up to date. I've troubleshooted the problem and they said something was wrong with the network configuration which was solved, but still no change in the internet speed. I've got broadband and should be downloading at hundreds of kb/s..any ideas would be gratefully appreciated.
    thanks,
    NIck
      My ComputerSystem Spec

  2.    28 Feb 2016 #2

    OK, this morning I tried my internet connection again, downloading a game via an installer. started off very fast for the first few seconds about 50Mb/s then dropped to about 5 Mb/s and then eventually dropped back down to where it was yesterday at about 0.25 Mb/s. If anyone has an idea as to what the problem might be I'd be very grateful.
    thanks,
      My ComputerSystem Spec


  3. Posts : 4,617
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       28 Feb 2016 #3

    Nickm43 said: View Post
    OK, this morning I tried my internet connection again, downloading a game via an installer. started off very fast for the first few seconds about 50Mb/s then dropped to about 5 Mb/s and then eventually dropped back down to where it was yesterday at about 0.25 Mb/s. If anyone has an idea as to what the problem might be I'd be very grateful.
    thanks,
    Two things come to my mind, one is that you can't upgrade/change from 32-bit to 64-bit [or from 64-bit to 32-bit], has to be a clean install, and that brings up the second thing which is getting 64-bit drivers installed for devices.
      My ComputerSystem Spec

  4.    28 Feb 2016 #4

    Hi Berton, thanks for your reply, yep I did a clean install and reinstalled drivers, but still have a slow connection. Have tried Microsoft support aswell. Any other ideas appreciated.
      My ComputerSystem Spec


 

Related Threads
Can anybody solve this one? After upgrading to Ten, my Internet speed plunged from 18 MBPS down to barely over 1 MBPS. It's specific to Windows 10, and here's I know: I reverted back to Windows 8.1 and my net speed returned to normal. A week...
Hopefully somebody here can help me. I've looked around everywhere to find a solution for this issue, but this problem differs from all the threads you can find in many forums around there: it already worked well for me :sleepy: My problem: I...
Solved Internet Explorer is very Slow... in Browsers and Email
When I first upgraded IE was OK but for some unknown it has become very slow. What can I look for?
Hi hope somebody can help. Since upgrading to windows 10 my internet speed on my Packard Bell PC has dropped to almost nothing, less than 1mb. Before upgrade it was around 76mb. All my other laptops, tablets etc are getting good wifi speeds. When I...
I recently upgraded from W7 to W10 on my W7 laptop. The install went well, no problems to report. Since then my broadband speed has suffered badly. I've just tested the speed - the download speed is 1.6mbps and upload speed 0.29mbps. It's not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:03.
Find Us