Windows 10: Ethernet Not Working Solved


  1. Posts : 3
    Windows 10 Home 64-Bit
       26 Feb 2016 #1

    Ethernet Not Working


    Hi there!

    I have no experience at all with computers/connection issues, so apologies for my poor use of terminology.

    I live in the Bay Area and I have xfinity/Comcast.

    Around a week ago, I stopped being able to connect to Ethernet. After troubleshooting, I found that the error was "One or more network protocols are missing" or "Windows Sockets Empty".

    I have already tried the following things:
    1. Reset my computer / made sure all the cords were plugged in
    2. Did a "netsh" in command prompt to reset my IP
    3. Gave "Full Control" to everyone in folder 26 in my Registry Editor
    4. Did a "netsh" to reset my winsocks
    5. Disabled NETBIOS on both wifi/ethernet

    I also couldn't find any new drivers...

    Each time I tried one of these fixes, I would have ethernet for ~5 minutes after I restarted my computer. Afterwards, it would instantly disconnect me and connect me back to WiFi.
    After I tried disabling WiFi, my ethernet connection would still dc, but I would simply have to troubleshoot it, and would work again after restarting my adapter.

    Is there any way for me to fix problem for good? My WiFi cuts off really randomly from time to time and that's really frustrating..

    If there's anything I missed please let me know and I'll try to provide it!

    Thank you so much!
      My ComputerSystem Spec

  2.    26 Feb 2016 #2

    The link that shows up on your post - "I also couldn't find any new drivers..." - If you posted that intentionally, do not use the 'driver updater' program it links to. It's malware. My question would be who is the oem of your computer, and which LAN card make/model?
      My ComputerSystem Spec


  3. Posts : 3
    Windows 10 Home 64-Bit
    Thread Starter
       26 Feb 2016 #3

    bookfox said: View Post
    The link that shows up on your post - "I also couldn't find any new drivers..." - If you posted that intentionally, do not use the 'driver updater' program it links to. It's malware. My question would be who is the oem of your computer, and which LAN card make/model?
    I didn't put that link there, it must have automatically linked. I asked my friend who's more tech-savvy to see if there were drivers I could update and he said he couldn't find any.

    For OEM, I think it's MSI.
    Lan card (I think): Intel Dual Band Wireless-AC 7260 and Qualcomm Atheros network controller
      My ComputerSystem Spec

  4.    26 Feb 2016 #4

    I know you said you checked for drivers, but if you have the model number of your Qualcomm Atheros LAN card, check here for an update. It doesn't list Win 10 drivers but the Win 8 drivers should work fine. https://www.atheros-drivers.com/athe...k-drivers.html . In my day job (tech support for Costco), I've lost count how many times updating the drivers via that link have resolved connection issues. IMO, I would uninstall the driver your LAN currently has - then download and run the ones from the site.

    Even though I understand you're not having an issue with wireless, the Intel AC 7260 drivers are here on Intel's page. Note: the link goes direct to the Win 10 drivers for your card. https://downloadcenter.intel.com/dow...s-10-64-bit-WP-
      My ComputerSystem Spec


  5. Posts : 3
    Windows 10 Home 64-Bit
    Thread Starter
       26 Feb 2016 #5

    Okay, I updated my drivers and the problem seems to have disappeared... Hopefully it'll stay like this.

    Thanks so much for your help!
      My ComputerSystem Spec


  6. Posts : 3,701
    Mac OS Sierra
       26 Feb 2016 #6

    There is a Sticky thread on this subject already.
      My ComputerSystem Spec

  7.    27 Feb 2016 #7

    @vardaeus: NP. Glad I could help.
      My ComputerSystem Spec


 

Related Threads
Hi everyone, First off, I'd like to thank everyone in advance for their time and help with this issue. I recently upgraded to windows 10 on my desktop. I've run into a problem with my "Broadcom NetLink TM Gigabit Ethernet" card, basically the...
Hi there! So I tried to update from Windows 8 to 10 last week. That didn't work for me, so I had to format everything and install Windows 10 afterwards. At first neither W-LAN nor LAN would work. Then I un- & reinstalled the W-LAN driver so...
I am completely wiping my hardrive with DBAN and doing a clean install of windows 10 with a dvd I created with the media creation tool. Will the fresh installation of windows come with a driver for ethernet cable so I can get on the internet. I...
Hello, I am having trouble getting my internet connection to work with an ethernet cord. I have no problem using wifi, but i get disconnected on wifi pretty frequently. I have two ethernet cords in my possession, one of them is new, and neither...
Hello, Recently my on-board Ethernet port stopped working. At first I noticed that I no longer had the Wired Connection in the bottom right of my taskbar, instead replaced by the Wi-Fi symbol. I checked to make sure that my ethernet cable was...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:32.
Find Us