I got missing network protocols and I'm about to cry. Help!!!

  1. Posts : 1
    Windows 10

    I got missing network protocols and I'm about to cry. Help!!!

    When I run the troubleshooting I keep getting the message that says: "One or more network protocols are missing in this computer". When I run the "netsh winsock reset" in the Administrator Command Center, I get the messages: " The following helper DLL cannot be loaded: NETIOHLP.DLL" and "The following helper DLL cannot be loaded: NSHIPSEC.DLL".

    How can I fix this problem? Please help me.
      My Computer

  2. Posts : 43,212
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Hi, you can try the ideas here from MS:
    winsock netsh command errors - dll files cant be loaded - Microsoft Community

    but it may be other action is needed.
    (Seems from the above SFC /Scannow doesn't fix this)

    Solved One or more network protocols are missing, solution - Windows 10 Forums
      My Computers

  3. Posts : 5,478

    I multi boot and get this every single time I boot from one Windows system to another.

    I also got it yesterday following a (completely unconnected) BSOD.

    For me, running the troubleshooter does nothing. Nor does running any commands (or doing a clean install or repair install or rebooting the router). It happens (it seems to me) when your Windows doesn't think you shut down correctly and a reboot fixes it.

    The only reliable solution for me when I boot into a new Windows instance is to immediately do a restart.

    Sorry if that sounds a bit IT crowd but it is what works for me.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:45.
Find Us

Windows 10 Forums