Hi folks

always knew Windows networking was of the same order as a Harry Potter Wizard -- Two machines on different networks

1) Bog standard "G" wireless network ch 11 @2.4 GHZ network wifi card says 54 mbs speed --OK no prob.
2) second computer -- 5 GHZ network with 40 GHZ wide bandwidth says 8-- mbs speed -- Twiddling my thumbs on the download.

What's up here --I can't see anything I'm doing wrong but the dinosaur "G" wifi @2.4 GHZ is running rings round the new 5GHZ system with the USB3 adapter for Wifi --I also tried USB2 just in case but no difference.

I also tried on Linux --> the Wifi adapter is ASUS ac 56. On latest CENTOS 7 it wouldn't work at all --on CENTOS 6.7 the old 2.4GHZ gave same result as Windows especially on a decently uncongested channel such as 11 but on 5 GHZ it FLEW --getting almost 750 Mbs.

Note though I just CAN'T get this to work on CENTOS 7 so you Linux guys be careful if you are using Centos and want to upgrade to CENTOS 7. (The driver compiles and you get a blue light for about 3 secs so the hardware is recognized --then it dies and that's it so stay on 6.7 if you want to use this adapter).

I want to stream a NAS box with a Wifi card --don't need LAN cables all over the place --but if I can't get better than 2.4 GHZ "G" then something is wrong.

My router and ISP are mega superfast --have tested with LAN cable direct into the cablebox router.