Windows 10: Can't find "show password" for homegroup

  1.    08 Feb 2016 #1

    Can't find "show password" for homegroup

    Hi folks -

    having trouble recovering my password for a Homegroup, Windows 10. I know, know - I don't know why I don't have it written down along with my other bazillion passwords...

    I'm on the computer I used to set up the Homegroup, which I vaguely recall setting up a year or two ago when we first got this desktop. I'd like for other computers to access files on this desktop, I assume via the Homegroup. but I can't recall the password to connect to this desktop via Homegroup.

    I've read that if I'm logged into the account on the computer used to create the homegroup, I should be able to go through control panel/Homegroup/show or print password - but I don't see that option.

    When I go to CP/Homegroup... it says "bsn on NISNESTPC has created a Homegroup on the network" - and only gives me two buttons to "join now" or "close". If I attempt to "join now" - I get as far as needing to enter the password, of which I can't remember. There are also 2 links for "change advanced sharing settings..." and "start the homegroup troubleshooter". Neither of which are helpful.

    In short - how can I recover my forgotten HomeGroup password in Windows 10??

    Many thanks.
      My ComputerSystem Spec

  2.    08 Feb 2016 #2

    Windows 10 Run Command [Windows-Logo]+[R] and enter the command:
    control.exe /name Microsoft.HomeGroup and click the text Change Password.
      My ComputerSystem Spec

  3. davidhk's Avatar
    Posts : 5,227
    windows 10 Home threshold2
       08 Feb 2016 #3

    Go to the computer that initially created the Homegroup.
    Go to File Explorer > left side, RIGHT click at HomeGroup > click View the HomeGroup password.

    Click image for larger version. 

Name:	View HomeGrou  pasword.jpg 
Views:	5 
Size:	160.0 KB 
ID:	63217
      My ComputerSystem Spec

  4.    08 Feb 2016 #4

    davidhk: thanks for this tip. However I discovered that when I right click on HomeGroup as you suggested, the option to "view the HomeGroup password" is grayed-out. I must be missing something!! Any further advice?

    Railtech: thanks. I haven't tried this yet as I'm curious to know first why the option above is grayed-out for me. But curious to know: when I attempt to change my password, won't I need to know my current one?

      My ComputerSystem Spec

  5. davidhk's Avatar
    Posts : 5,227
    windows 10 Home threshold2
       08 Feb 2016 #5

    You signed in on your admin account or just a standard user account ?
      My ComputerSystem Spec

  6.    10 Feb 2016 #6

    actually - and update:

    Today when I went to look at the Homegroup, it no longer said there was a homegroup created by "bsn321". So I created a new one.

    Now I seem to have admin over it. I will continue exploring how this all works, but in the meantime, some quick questions that are top of mind:

    - When I choose to create a homegroup - it defaults (automatically) names it "bsn321". This is a familiar name I must have used somewhere along the line - but where does the name of the homegroup come from? in this case, It's not my account name, it's not my email address - I'm not sure what it is. and would seem I cannot change the name of the homegroup once it's created. I did notice that if I leave the homegroup, I can start over, but still not sure where that bsn321 is coming from?

    - once i have the homegroup established, and it's set to share my pictures, documents, etc. - how can I access these documents from another computer? I will try to learn more here but any useful links/instruction for laymen greatly appreciated.
    Last edited by bsn321; 10 Feb 2016 at 15:57.
      My ComputerSystem Spec

  7.    12 Jul 2017 #7

    Please help!

    I had the same issue that the original poster has.

    When hit HomeGroup in the control panel, what I got looks like on another computer when clicking the HomeGroup button. It says "Chen on Chen-XPS has created a homegroup on the network" and provides "join now" or "close" two buttons. But I am Chen and this is Chen-XPS! It seems that this computer doesn't know this and treats it some other computer.

    If I use "run" to run "control.exe/name Microsoft.HomeGroup" I got " Windows cannot find 'control.exe/name'."

    I am the only person using this computer and I am the administrator.

    I believe this problem appears after recent OS update.

    Attached Thumbnails Attached Thumbnails image.png   Capture.JPG  
      My ComputerSystem Spec

  8.    13 Jul 2017 #8

    Update -

    So I clicked "join in" button and enter a random password. Of course it doesn't work and it takes a few minutes and eventually shows an error and says this homegroup doesn't exist and let me create a new one.

    I guess it is because the major system update I got a while ago screwed this up.

    Everything is OK now.
      My ComputerSystem Spec


Related Threads
I recently upgraded to Windows 10. Since then searches in the Registry Editor do not work any more (the app consumes 20% CPU, but the search never finishes. Canceling the search crashes the registry editor.:sarc:
Hello how can I delete "saved password" and "form data" of microsoft edge manually ?! after too much search in google .... I trid to delete some value of the following registry address HKEY_CURRENT_USER\SOFTWARE\Classes\Local...
Find "Wake up from sleep" Scheduled Tasks in Performance & Maintenance
Other than going through each and every task in the task scheduler, is there a way to see those that are allowed to wake the machine while it is sleeping? My PC woke up this morning at 3:30 am. It then went back to sleep about ten minutes later. ...
Hi! I upgraded my Windows 7 Ultimate 64-bit install to Windows 10 Pro 64-bit (build 10240 from "winver") last month. The Start Menu search, ever since I upgraded, has always been really slow at finding things, but now it's died. I have a pretty...
I have upgraded 5 machines and clean installed 3 machines. Experienced an issue with one machine with continuous corruption problems After the 3rd attempt I discovered that even with a Clean Install of Win 10 I get unrepairable errors - Sorry...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:23.
Find Us