Intel 7260 AC Wi-Fi adapter


  1. Posts : 470
    Win 10 Pro (x64), OSX 10.11
       #1

    Intel 7260 AC Wi-Fi adapter


    I have a Dell XPS 8700 that came with a Dell 1704 A/B/G/N Wi-Fi adapter. This is a rebranded Broadcom card.
    After Windows 10 Pro conversion since July 2015, the Wi-Fi adapter worked fine but if I activated Hyper-V with Windows 10 Pro, I got BSODs with error 0x50 like:

    On Fri 1/22/2016 4:14:34 AM GMT your computer crashed
    crash dump file: C:\WINDOWS\Minidump\012116-7046-01.dmp
    This was probably caused by the following module: bcmwl63a.sys (bcmwl63a+0x8EA6F)
    Bugcheck code: 0x50 (0xFFFFF6FB400037A8, 0x0, 0x0, 0x6)
    Error: PAGE_FAULT_IN_NONPAGED_AREA
    file path: C:\WINDOWS\system32\drivers\bcmwl63a.sys
    product: Broadcom WiFi Driver wireless driver
    company: Broadcom Corp
    description: Broadcom WiFi Driver wireless driver
    Bug check description: This indicates that invalid system memory has been referenced.
    This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
    A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: bcmwl63a.sys (Broadcom WiFi Driver wireless driver, Broadcom Corp).
    Google query: Broadcom Corp PAGE_FAULT_IN_NONPAGED_AREA

    I even run memtest for a long time to rule out memory problem with 8-9 passes.

    I experimented with several versions of bcmwl63.sys. Again it works fine with Windows 10 Pro but as soon I work with Hyper-V I still get BSOD occasionally..

    Frustrated, I purchased and replaced the Dell 1704 card with an Intel 7260 AC. I just let Windows 10 installed the driver.
    After one day of working Hyper-V with Windows 10 Pro. It is still running fine!

    I am not solving my problem just side step for now! Have any one have similar experience?

    I am at Windows 10 10586.71 with this XPS 8700.
      My Computer

  2. bro67's Avatar
    Posts : 8,176
    Mac OS Catalina
       #2

    That would not surprise anyone with Hyper-V, that the Broadcom chipset is causing it to crash. I have two laptops with the 7260 mini-PCIe cards in them and have had zero issues. I did have to place the second antenna up in the Battery compartment, only because I did not feel like tearing apart the lid to place it up there.
      My Computers


  3. Posts : 470
    Win 10 Pro (x64), OSX 10.11
    Thread Starter
       #3

    Wow, it is going toward the 72 hours of operating Wi-Fi with Hyper-V without any error!
    Beside the absence of bug check error 0x50, Intel 7260 is AC device, so now I am connecting with 867 Mbps instead of 300 Mbps with the old Broadcom chip.

    The best $24 I ever spend! Thanks Intel
      My Computer

  4. bro67's Avatar
    Posts : 8,176
    Mac OS Catalina
       #4

    I am guessing you are using AC. I get around 265 with mine on Wireless-N on my Toshiba Satellite C850D-st3nx1.

    I can say that doing the change to the better card has been the best money well spent also.
      My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:53.
Find Us




Windows 10 Forums