Windows 10: Intel 7260 AC Wi-Fi adapter


  1. Posts : 470
    Win 10 Pro (x64), OSX 10.11
       07 Feb 2016 #1

    Intel 7260 AC Wi-Fi adapter


    I have a Dell XPS 8700 that came with a Dell 1704 A/B/G/N Wi-Fi adapter. This is a rebranded Broadcom card.
    After Windows 10 Pro conversion since July 2015, the Wi-Fi adapter worked fine but if I activated Hyper-V with Windows 10 Pro, I got BSODs with error 0x50 like:

    On Fri 1/22/2016 4:14:34 AM GMT your computer crashed
    crash dump file: C:\WINDOWS\Minidump\012116-7046-01.dmp
    This was probably caused by the following module: bcmwl63a.sys (bcmwl63a+0x8EA6F)
    Bugcheck code: 0x50 (0xFFFFF6FB400037A8, 0x0, 0x0, 0x6)
    Error: PAGE_FAULT_IN_NONPAGED_AREA
    file path: C:\WINDOWS\system32\drivers\bcmwl63a.sys
    product: Broadcom WiFi Driver wireless driver
    company: Broadcom Corp
    description: Broadcom WiFi Driver wireless driver
    Bug check description: This indicates that invalid system memory has been referenced.
    This appears to be a typical software driver bug and is not likely to be caused by a hardware problem.
    A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: bcmwl63a.sys (Broadcom WiFi Driver wireless driver, Broadcom Corp).
    Google query: Broadcom Corp PAGE_FAULT_IN_NONPAGED_AREA

    I even run memtest for a long time to rule out memory problem with 8-9 passes.

    I experimented with several versions of bcmwl63.sys. Again it works fine with Windows 10 Pro but as soon I work with Hyper-V I still get BSOD occasionally..

    Frustrated, I purchased and replaced the Dell 1704 card with an Intel 7260 AC. I just let Windows 10 installed the driver.
    After one day of working Hyper-V with Windows 10 Pro. It is still running fine!

    I am not solving my problem just side step for now! Have any one have similar experience?

    I am at Windows 10 10586.71 with this XPS 8700.
      My ComputerSystem Spec


  2. Posts : 3,519
    Mac OS Sierra
       07 Feb 2016 #2

    That would not surprise anyone with Hyper-V, that the Broadcom chipset is causing it to crash. I have two laptops with the 7260 mini-PCIe cards in them and have had zero issues. I did have to place the second antenna up in the Battery compartment, only because I did not feel like tearing apart the lid to place it up there.
      My ComputerSystem Spec


  3. Posts : 470
    Win 10 Pro (x64), OSX 10.11
    Thread Starter
       08 Feb 2016 #3

    Wow, it is going toward the 72 hours of operating Wi-Fi with Hyper-V without any error!
    Beside the absence of bug check error 0x50, Intel 7260 is AC device, so now I am connecting with 867 Mbps instead of 300 Mbps with the old Broadcom chip.

    The best $24 I ever spend! Thanks Intel
      My ComputerSystem Spec


  4. Posts : 3,519
    Mac OS Sierra
       08 Feb 2016 #4

    I am guessing you are using AC. I get around 265 with mine on Wireless-N on my Toshiba Satellite C850D-st3nx1.

    I can say that doing the change to the better card has been the best money well spent also.
      My ComputerSystem Spec


 

Related Threads
Is Intel HD Graphics Family better than Intel G41 express chipset? The name is only Intel HD Graphics Family there isnt a number after it in dxdiag
Solved 13x TAP-Windows Adapter V9? in Network and Sharing
Hi guys, i really need help on this. Anyways, lets get started. So, as i recently wanted to check why my Gigabit Adapter does not take in Gigabit anymore since the upgrade to Windows 10 Pro, i checked by in the Network Sharing Center, and went under...
I used the upgrade tool to install w10x64. Installation went fine, I can use my computer and all. Problem is that both of my LAN ports don't work. I get the usual red icon in the taskbar that shows no internet. I went into networking and it doesn't...
Usb Wi-Fi adapter not working in Drivers and Hardware
I've recently bought a nano usb wi-fi adapter and on it's packaging it says it's only compatible with Windows XP/Vista/7. Indeed its drivers don't work on Windows 10 9879, the device is recognized but it doesn't work. Is there a way around this?...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:55.
Find Us