The connection is between my Win10 laptop (build 10586.71) and my home Buffalo router. The connection worked fine before from Windows 7, and it still works via my android phone (6.0.1). But now, when I try to connect, I get "The PPP link control protocol was terminated."
Attachment 61908

The settings on the phone, which work are:
Type: PPTP
<checked> PPP encryption (MPPE)

Here are the error messages from the Event Viewer > Windows Logs > Application

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The user SYSTEM has started dialing a VPN connection using a per-user connection profile named home. The connection settings are:
Dial-in User = drew

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The user SYSTEM is trying to establish a link to the Remote Access Server for the connection named home using the following device:
Server address/Phone Number = xxx.xxx.xxx.xxx

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The user SYSTEM has successfully established a link to the Remote Access Server using the following device:
Server address/Phone Number = xxx.xxx.xxx.xxx

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The link to the Remote Access Server has been established by user SYSTEM.

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The user SYSTEM dialed a connection named home which has failed. The error code returned on failure is 734.

CoId={DC1BEFEC-C346-4211-A83C-12322CEC5E1F}: The user DESKTOP-8ONAS5I\drew dialed a connection named home which has terminated. The reason code returned on termination is 828.

I obfuscated the home IP xxx.xxx.xxx.xxx

Thanks!