Page 1 of 3 123 LastLast
  1.    10 Jan 2016 #1
    Join Date : Jan 2016
    Posts : 10
    Windows 10

    Need a PCI Ethernet Network Adapter


    I have been having problems with my computer randomly dropping my internet connection. Usually my ping spikes real high, Skype disconnects me, the game I'm playing disconnects me. I had this problem before upgrading to windows 10 and don't know if its my killer e2200 that came integrated with my motherboard. The driver is updated and I thought I might as well start here before trying to replace modem or router. I also want to add that I have a brand new Cat 6 cable Ethernet cable.

    The only problem is trying to find a PCI Ethernet network adapter that is compatible with windows 10. I would really like to avoid using a USB 3.0 and prefer to use a PCI slot. Of course it doesn't need to say "good for gaming" as I think any generic 10/100/1000 Ethernet adapter will do. The problem is finding one that works with Windows 10. Thanks.

    And if anyone want to try and solve my network problem your welcome to. I notice it only when I'm playing a game and talking to friends on Skype. I might also be listening to music with a mixture of downloaded and streaming from Spotify. When I'm playing a game and talking I will notice that the persons voice is getting broken up and my game starts to lag, ping spikes way passed 1000. When this happens Skype says I'm offline and I'm trying to reconnect. The problem I'm facing leads me to believe it could be my router thinking that I'm taking to much bandwidth or something. I have a Linksys EA4500, and I have my computer under Media Prioritization. My modem is a Motorola SB6141.
      My ComputerSystem Spec
  2.    10 Jan 2016 #2
    Join Date : May 2015
    Central IL
    Posts : 4,349
    Mac OS Sierra

    Changing the adapter isnot going to resolve an issue on the ISP side.

    What do your power levels show on the modem? Post a Screenshot.
      My ComputerSystem Spec
  3.    10 Jan 2016 #3
    Join Date : Jan 2016
    Posts : 10
    Windows 10
    Thread Starter

    Quote Originally Posted by bro67 View Post
    Changing the adapter isnot going to resolve an issue on the ISP side.
    I realize that, I don't know what it is, that's why I would start here. I just feel like all I have is problems with Killer Ethernet adapters.

    Here is a picture of the signal levels of modem
      My ComputerSystem Spec
  4.    10 Jan 2016 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,986
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    My procedure has been to reboot a desktop computer into the BIOS Setup and disable the onboard Ethernet/Network adapter, shutdown, pull the power cord out of the computer and wait a minute so residual power will drain off the motherboard. Pressing the On/Off switch should do the same. Then on newer computer I will install a PCIe X1 NIC/Network Interface Card or if no PCIe X1 slot there should be a PCI slot and use a PCI card. May have to install software but should have come with it. The advertisements for such a card should specify the OS it will work with.
    An example of a PCIe X1 card, many others available:
    Intel EXPI9301CTBLK PCI-Express Network Adapter - Newegg.com
      My ComputerSystem Spec
  5.    10 Jan 2016 #5
    Join Date : Jan 2016
    Posts : 10
    Windows 10
    Thread Starter

    Berton that's funny I was looking at that card. I have just been getting mixed reviews on it saying that it works on windows 10 while a few have reported that it doesn't work on windows 10.
      My ComputerSystem Spec
  6.    10 Jan 2016 #6
    Join Date : Aug 2014
    Forever West
    Posts : 3,986
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Quote Originally Posted by ranar View Post
    Berton that's funny I was looking at that card. I have just been getting mixed reviews on it saying that it works on windows 10 while a few have reported that it doesn't work on windows 10.
    I was looking for something else and that was just the first in the list of many they offer.
      My ComputerSystem Spec
  7.    10 Jan 2016 #7
    Join Date : May 2015
    Central IL
    Posts : 4,349
    Mac OS Sierra

    These are what your Signal levels should be. What should my Signal Levels be? Comcast High Speed Internet FAQ | DSLReports, ISP Information

    Normal troubleshooting of signal levels, is to connect the Cable Modem at the Static Block outside, to see if the signal gets better or worst.

    You should only have one splitter between your incoming drop and the Cable Modem. It should state -3.5db on both outputs.

    Sometimes they will "pad" the signal, by placing a splitter with a -7.0db output, to bring the signal down to spec's for the modem.

    Check the error log for the modem, to see what it is showing.

    I would not replace the onboard yet, because I highly doubt that is the issue.
      My ComputerSystem Spec
  8.    10 Jan 2016 #8
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,196
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    @ranar
    Not really sure if it's your Killer e2200 that causes the problem. As you can see, I also have the Killer e2200 that came with my MB. Double check if you have the latest driver for it.

    Click image for larger version. 

Name:	a.jpg 
Views:	3 
Size:	246.4 KB 
ID:	58215
      My ComputerSystem Spec
  9.    10 Jan 2016 #9
    Join Date : Jan 2016
    Posts : 10
    Windows 10
    Thread Starter

    Quote Originally Posted by bro67 View Post
    These are what your Signal levels should be. What should my Signal Levels be? Comcast High Speed Internet FAQ | DSLReports, ISP Information

    Normal troubleshooting of signal levels, is to connect the Cable Modem at the Static Block outside, to see if the signal gets better or worst.

    You should only have one splitter between your incoming drop and the Cable Modem. It should state -3.5db on both outputs.

    Sometimes they will "pad" the signal, by placing a splitter with a -7.0db output, to bring the signal down to spec's for the modem.

    Check the error log for the modem, to see what it is showing.

    I would not replace the onboard yet, because I highly doubt that is the issue.
    I have Time Warner Cable does that matter. I have heard that having 30 something db is okay. As seen at this post:Modem signal levels @ 192.168.100.1 or 192.168.0.1 - TWC Community Forums The setup I currently have going is this:

    @topgundcp
    I checked and I have the same driver version. 8.1.0.31
      My ComputerSystem Spec
  10.    10 Jan 2016 #10
    Join Date : May 2015
    Central IL
    Posts : 4,349
    Mac OS Sierra

    No it does not matter who your provider is. Just matters that the signal change if you connect it directly to where the drop is attached to the Static block.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Solved Realtek Ethernet not showing in adapter settings. And more.
Hi, people. Edit: In post #16, you'll find that the solution is to do a re-install of Windows. Feel free to try all the other methods we've tried. Best of luck. TL;DR Messed around with the drivers, now the ethernet device doesn't show up in...
Drivers and Hardware
IP configuration not valid - interference from ethernet adapter?
Hi guys, I have a self built desktop that I only connect to the internet with using WiFi. But lately the connection on this PC is very intermittent and this is the only device in my house with this problem (so it's not the modem/router?). My PC has...
Network and Sharing
Ethernet adapter big problem
Hi guys, I have big problem for internet connection. I have cable internet (Tv and internet share same cable) but when I turn on my PC icon for connection is with yellow sign (identifying network) or with red sign (cable is unplugged). They...
Network and Sharing
Must reinstall Ethernet Adapter Driver after every restart
I recently upgraded directly from Windows 8.1 64-bit to Windows 10 and I am having some problem with my Ethernet Adapter. My Ethernet Adapter is a Killer e2200 Gigabit Ethernet Controller, which is built in to my motherboard (MSI Z87M GAMING). When...
Drivers and Hardware
Solved Ethernet Adapter Speed variating
Hi guys, this is a standalone addition to another post i have. Anyways, this is weird. Windows 10 seems to have ****ed up my Network Intel driver. So on Windows 8.1, my adapter took in 1GBps, now on Windows 10 (with the correct driver!), it only...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:38.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums