Build 9226 - cant connect to shares?

Page 1 of 3 123 LastLast

  1. gmc
    Posts : 7
    Windows 10
       #1

    Build 9226 - cant connect to shares?


    Just upgraded to the latest build and find I can no longer connect to any samba shares. It worked fine on the previous build.

    Seems to be a common problem - anyone found a solution yet?
    "The account is not authorized to login from this station" - Microsoft Community


    "The account is not authorized to login from this station"
      My Computer

  2. jimbo45's Avatar
    Posts : 10,497
    Windows / Linux : Arch Linux
       #2

    Hi there
    I've posted on this before

    What you have to do is in the W10 Firewall is to BLOCK INBOUND port 139 in advanced settings of the firewall. Note do it on the W10 firewall - leave the others alone.

    Then it will work fine

    SAMBA TO W10 (redsquiirel) -- OK
    W10 (RedSqurrel) to Samba (gylfi) OK

    Blackdog is W8.1 - no problems - it's only INBOUND to W10 from SAMBA and W7 / earlier Windows.

    If Windows (W10) forewall not switched on it won't work --you must block inbpound TCP port 139.

    Note - depending on your network speed you might have to be a little patient if you have large directories.

    You shouldn't have to change any SAMBA Conf settings either. Ensure also the windows shares are still "shared" of course.
    Attached Thumbnails Attached Thumbnails Build 9226 - cant connect to shares?-firewall.png   Build 9226 - cant connect to shares?-snapshot6.png   Build 9226 - cant connect to shares?-snapshot7.png   Build 9226 - cant connect to shares?-network.png  
      My Computer


  3. gmc
    Posts : 7
    Windows 10
    Thread Starter
       #3

    No such luck - not working.

    Firewall is enabled and I've blocked inbound to TCP139.

    This is connecting from W10 to samba shares.
      My Computer

  4. jimbo45's Avatar
    Posts : 10,497
    Windows / Linux : Arch Linux
       #4

    Hi there

    Sometimes it takes a while for the network to propagate. Re-start the Samba server (both NMB and SMB daemons).

    The problem normally is FROM SAMBA to WINDOWS.

    Here's part of my samba config file (renamed to smb.txt to conform to Forum naming for attachments).
    I've just got the basic minimal security in it - fine for testing. Also did you add your user name to samba via smbpasswd -a username. I'm still using the older security system. Open with Wordpad - better formatting.

    Cheers
    jimbo
    Build 9226 - cant connect to shares? Attached Files
      My Computer


  5. gmc
    Posts : 7
    Windows 10
    Thread Starter
       #5

    This fixed the issue:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1.
      My Computer

  6. badrobot's Avatar
    Posts : 5,258
    Win 10 Pro x64
       #6

    gmc said:
    Just upgraded to the latest build and find I can no longer connect to any samba shares. It worked fine on the previous build.

    Seems to be a common problem - anyone found a solution yet?
    "The account is not authorized to login from this station" - Microsoft Community


    "The account is not authorized to login from this station"
    No problems at my end on any of my shared devices (tablets, PCs and NAS). Everything is instantly accessible except I just need to re-enter the passwords.
    Attached Thumbnails Attached Thumbnails Build 9226 - cant connect to shares?-9926_shares.jpg  
      My Computer

  7. jimbo45's Avatar
    Posts : 10,497
    Windows / Linux : Arch Linux
       #7

    gmc said:
    This fixed the issue:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1.
    Hi there

    You shouldn't have to do that as I assume it was connecting TO samba shares FROM a W10 machine that was giving you problems. Normally FROM W10 has no problems whatsoever. The problem comes when you are trying to access W10 shares FROM SAMBA / W7/XP. Windows 8 / 8.1 have Zero problems with W10 connectivity BOTH WAYS. (That includes things like Windows tablets and NAS devices).

    Also the insecure guest stuff you should set in the SAMBA.CONF file how you manage Guest and these "un-privileged accounts".

    Still if your workaround fixes it - that's fine but on the whole fiddling around with the registry shouldn't be the recommended way of getting a system to work properly.

    Cheers
    jimbo
      My Computer

  8. Burgurne's Avatar
    Posts : 476
    Windows 10 Pro
       #8

    gmc said:
    This fixed the issue:

    Using REGEDIT it's necessary to create a DWORD value called 'AllowInsecureGuestAuth' in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set this new value to 1.
    Thank you. That did fix it for me :).

    I had the opposite problem of Jimbo45. Access TO Windows 10 from other Windows 8.1 PC's was not a problem, but FROM windows 10 to any other device (EXCEPT my WD Live TV ??) gave the error:
    "The account is not authorized to login from this station"
    After editing the regdatabase as described above, it now works.
    But as Jimbo45 is writing ... it should NOT be nessesary to fiddle around in reg.database, but so far this is the only solution I have found
      My Computer

  9. jimbo45's Avatar
    Posts : 10,497
    Windows / Linux : Arch Linux
       #9

    Hi there

    If you have a W7 or Vista or XP machine (real or Virtual) can you also check whether those machines will connect TO W10 shares with that fix applied. I'm also assuming you are using standard DHCP on a home type LAN and not a special domain logon or using HOSTS or other stuff with fixed IP addresses.

    My XP sand W7 systems connect both ways just fine without the registry fix suggested. The firewall rule was needed though in my case.

    Cheers
    jimbo
      My Computer

  10. Burgurne's Avatar
    Posts : 476
    Windows 10 Pro
       #10

    Sorry, I only have 2 other PC's both running windows 8.1. (A laptop and an "office"-PC)
    Yes, I'm running standard DHCP on homelan.

    The WD Live TV that did work "out of the box" is a Linux kernal AFAIK, the firewall rule was not applied.
      My Computer


 
Page 1 of 3 123 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:48.
Find Us




Windows 10 Forums