1.    06 Jan 2016 #1
    Join Date : Nov 2015
    Posts : 9
    Windows 10

    Homegroup not functioning properly

    I have four PCs in my home network, plus a ReadyNAS Duo and a Samsung Laser Printer:
    PC 1 – Custom build server running Windows 10 Pro. Ethernet connection.
    PC 2 – Custom build desktop running Windows 10 Home. Ethernet connection.
    PC 3 – Samsung laptop running Windows 10 Pro. Ethernet connection.
    PC 4 – Samsung laptop running Windows 10 Home. Wireless connection.

    All windows installations are TH2 (version 1511 build 10586.36) and up to date.

    I have tried to set up a Homegroup across all four machines. Three work, and one partially works. The following describes how I set up the Homegroup. Note that I logged on the all the machines using the same Microsoft account

    1 – Started the server and the desktop. Used RDP on the desktop to access the server- which runs headless. Created the Homegroup on the server and then logged off.

    2 – Started the Homegroup app on the desktop, and noted that the server had established a Homegroup. Joined the Homegroup and waited for the shares to replicate.

    At this point I could see both machines in a file explorer 'Network' view, and in the file explorer 'Homegroup' view.

    All going to plan so far…

    3 – Started PC 3 (the Samsung laptop running Windows 10 Pro) and logged on with my Microsoft account. Joined the Homegroup and waited for the shares to replicate.

    At this point I could see all three machines in a file explorer 'Network' view, and in the file explorer 'Homegroup' view.

    Still going to plan…

    4 – Started PC 4 (the Samsung laptop running Windows 10 Home) and logged on with my Microsoft account. Joined the Homegroup and waited for the shares to replicate…

    At this point theHomegroup screen showed a message 'No other homegroup PCs are available at the moment'

    In file explorer however I could see all the machines in the network…

    Time to start researching Homegroup problems:

    There appeared to be a number of solutions all of which had worked for some people and I have checked/implemented all of the following on PC 4:

    1 – Run the Homegroup troubleshooter, including the network troubleshooter. No effect.

    2 – Ensured that all accounts were password enacted, rather than PIN. No effect

    3 – Implemented the IPv6 registry hack. No effect.

    4 – Implemented the Windows services checks outlined in post #51 of the following forum thread:


    5 – Other salient points:
    a) Windows firewall is on, in all cases (it makes no difference for three machines)
    b) Windows Defender is running (as above)
    c) No third party firewall or AV software.
    d) All IP leases have been renewed.
    e) Network discovery is turned on on all machines

    This is very irritating, although I would accept it is largely moot since I can access everything I need to via mapped drives and the network. That said, inconsistencies like this shouldn't exist. I'm wondering if I've missed anything else?

    Thanks to all those who have posted on this subject previously. Your thoughts have got me a long way - just need a little more to push this over the line!


    Edit 7-1-15
    I've just tried exiting the Homegroup on all machines and then deleting the following files

    • idstore.sst
    • idstore.sst.lkg
    • idstore.sst.new

    from the C>Windows>ServiceProfiles>LocalServices>AppData>Roaming>PeerNetworking folder of the machine that created the Homegroup.

    After a reboot and creating a new Homegroup the same problem exists and I'm no further forward

    Can anyone suggest anything else I could try? I really don't like being beaten by a computer!

    Last edited by Bolehill; 07 Jan 2016 at 12:25.
      My ComputerSystem Spec


Similar Threads
Thread Forum
Homegroup not Functioning, cant leave homegroup
I cannot leave the homegroup. we had 2 computers in the network with windows 7 and windows 8.1. Windows 7 upgraded to windows 10. and the other one did a clean install of windows 8.1. Now i cannot leave the homegroup from windows 10 and the windows...
Network and Sharing
No System Sounds functioning after Win10 Update
I have updated to Windows 10. After scouring the internet for options, I need to turn to ask the experts. Movies play, songs play... even the system sound previews play when I pick a sound scheme. But under normal computer operation, no system...
Drivers and Hardware
Start Menu not functioning
Hi,Im Fatcat from Asia. Just installed Win 10 Ent. Found out that Start Menu which contains few functions refused to work - every time I click the items, it wont execute...please refer to the image. regards. 37457
General Support
uninstall feature in Control Panel not functioning
I upgraded windows 7.0 on my Dell XPSL501X to windows10.0 I got a new Cannon Cloud Printer and don't need the many HP programs (in Control Panel-Programs & Features) as I dont have it linked to an HP printer any longer. I tried several times...
Software and Apps
Two monitors not functioning?
I have been trying to solve a resolution issue - another issue... for two days. Anyway I selected 1920 x 1080 29Hz interlaced in CCC by accident, I thought it'd revert and it didn't. I can get on the pc using HDMI however whenever I plug a VGA...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:48.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App

Windows 10 Forums