Apologies if this has been addressed already but I haven't been able to find a post with this particular issue.

Here's the background information:
I have a Dell Vostro 3750 notebook which I upgraded from Windows 7 Home to Windows 10 using a Windows 10 "1511" build DVD. The upgrade was successful and I only had to reinstall one application. Since I have a network-attached disk, I use an Asus USB AC56 adapter connected to one of my USB3 ports for my WiFi instead of the built-in WiFi. This notebook is also used by other members of my family so I have a local administrator account and local standard user accounts for daily use. The WiFi is connecting to a Netgear R7000 router on the 5 GHz band (802.11ac).

Now the issue:
What often happens when the machine is booted, rebooted, or wakes from sleep is that the WiFi is enabled but the network shows "No Internet". All I have to do to get the Internet back is to unplug the WiFi adapter from the USB3 port and plug it back in, or go into the WiFi app to disconnect and reconnect to the WiFi network.

I have tried the following:
1) installed the latest USB AC56 drivers from the Asus website
2) edited the WiFi adapter properties to prevent Windows from turning off the device to conserve power.
3) tried using a different USB3 port (I believe the 2 USB3 ports are connected to different controllers).

There is no VPN software installed, but I do have VMWare Player 12.1 installed.

This isn't a huge issue since it is easy enough to get Internet access back, but I am curious if anyone else has seen this issue where WiFi is enabled but will not connect to the Internet. This was not an issue with Windows 7.