"one or more network protocols are missing on this computer"

Page 1 of 2 12 LastLast

  1. Posts : 6
    Windows 10
       #1

    "one or more network protocols are missing on this computer"


    This happened after the latest major update.

    I've tried the following steps with no success 1) sfc /scannow. This showed no errors

    2) netsh advfirewall reset netsh int ip reset*** netsh int ipv6 reset netsh int ipv4 reset netsh winsock reset *** This command did not work originally until I went to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControl and changed Control/NSI folder 26 permission to everyone (This box was unchecked again after reboot

    3) ipconfig /flushdns ipconfig /registerdns ipconfig /release ipconfig /renew

    4) Disabling and Renabling the Network Adapter within device manager.

    5) Uninstalling the driver

    6) Installing the latest drivers both from the Asrock/intel website and googling my network adapter.

    7) I saw the fix where someone deletes the Windows 10 WIN and WIN2, and replaces with a clean Windows 7/8 version in this registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2

    - Did not work also, it gave me a new problem no ethernet something which troubleshoot can't also fix.

    8) Finally Reset W10. Still get the same error
    Been almost two weeks now I don't have internet.

    This is so disappointing.. I read so many topics regarding this and not even a sure fix. Hope someone can help.. It's been weeks now. I'm so close pirating to W7 just to make everything work again..
      My Computer

  2. lx07's Avatar
    Posts : 5,479
    2004
       #2

    I had this today and coincidentally did all of your items 1 - 6 with no luck (I guess we looked at the same sites for recommendations). It just degenerated from "One or more protocols missing" to saying it was connected to "unknown network" with no internet access and I couldn't ping my router (despite having an IP address assigned). Then ping stopped working completely with "general failure".

    I've just completed a repair install and it has fixed it (which was quite a surprise actually, I didn't think it would).

    You could give it a try if you can download a Windows 10 ISO somehow Repair Install Windows 10 with an In-place Upgrade - Windows 10 Forums
      My Computer


  3. Posts : 6
    Windows 10
    Thread Starter
       #3

    I actually managed to download an Iso with the media creation tool. Will that work?
      My Computer

  4. lx07's Avatar
    Posts : 5,479
    2004
       #4

    Tampy said:
    I actually managed to download an Iso with the media creation tool. Will that work?
    That will be fine. Hope it works for you too...
      My Computer


  5. Posts : 166
    Win 10 Pro 64Bit
       #5

    Hi

    Have you tried right clicking on your network icon in the notification area and selecting Troubleshoot problems. I had the same issue and this fixed it for me.

    Regards
    UKMedia
      My Computer


  6. Posts : 14
    win 7
       #6

    We have 2 desktops, 2 convertibles and an hp tablet. We started with total mess network wise - tried most of the fixes and none really helped. I removed homegroup and started over making sure ALL units were in homegroup and still had problems. After many tries of fixes etc. I discovered two of the units were in different workgroups???? on how that happened.

    We are finally able to see all computers on all the computers but are left with two network drives which show up as media units but never show up and available in the computer area on all computers. Both show up fine on my desktop but never on any of the other units.

    Have rebooted, checked settings and have no idea what to check now.

    We have used networking of some sort for years and depend on it - have been without it now for way too long.
      My Computer


  7. lx07's Avatar
    Posts : 5,479
    2004
       #7

    exscentric said:
    Have rebooted, checked settings and have no idea what to check now.
    You might have more luck if you open another thread for this problem with a title like "Can't access network drives".

    This thread "One or more protocols missing" is a rather specific problem reported by the troubleshooter after upgrading to 1511 and not the same as your issue in that it blocks all internet and network access.

    Your question might get lost if you just leave it as a comment here (and sorry, I don't know any answer).
      My Computer

  8. Berton's Avatar
    Posts : 11,597
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909
       #8

    lx07 said:
    You might have more luck if you open another thread for this problem with a title like "Can't access network drives".

    This thread "One or more protocols missing" is a rather specific problem reported by the troubleshooter after upgrading to 1511 and not the same as your issue in that it blocks all internet and network access.

    Your question might get lost if you just leave it as a comment here (and sorry, I don't know any answer).
    exscentric, if you'll start a new thread as suggested, I could respond with what worked for me and my 2 NAS drives.
      My Computers

  9. lx07's Avatar
    Posts : 5,479
    2004
       #9

    JamesBayley said:
    I have just solved this on my computer after many weeks. I have blogged the solution.
    Changing authority on the nsi 26 key was one of the things I tried with no luck (and so did the OP if you see their second attempt in the original post).

    Repair install did fix it for me but that is obviously not really finding the cause...
    Last edited by derekimo; 04 Jan 2016 at 21:37.
      My Computer


  10. Posts : 14
    win 7
       #10

    I posted here due to the protocol problem which I get when doing some of the troubleshooting MS has provided. I'm following other threads here as well waiting for a fix that might fix our problems.

    My concern is when MS, if they do, provides a fix that works what is going to happen with all the "fixes" already attempted
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:13.
Find Us




Windows 10 Forums