Homegroup seems stuck in join loop?

  1.    30 Dec 2015 #1

    Homegroup seems stuck in join loop?

    Short version: Windows is saying it sees a homegroup on my PC under my user ID, but it is not actually in the homegroup - it is forcing me to try to join the group it says I already created!

    All homegroup functions have recently stopped working, after mostly working OK for a year under Win 8 and Win 10.

    Here's what is happening:

    • With all other PCs turned off, I restart my main Windows 10 PC, "Media PC" and sign in under myname@outlook.com.
    • Under HomeGroup, I am then prompted to join a HomeGroup. It says, "myname@outlook.com on Media PC has created a homegroup on the network."
    • But, instead of seeing the homegroup control page, (where you can change the password etc.), it is displaying a "join now" button. I don't have the password, and without the normal homegroup panel, I can't reset the password, or do anything except join.
    • If I so click join, it asks for the password, which I don't know and can't change (see above). If I enter a dummy password, it says "Windows can no longer detect a homegroup on this network." - but then immediately brings me back to the message shown above.

    That makes no sense - it is asking me to join a homegroup that it says my user already created, and denying me the normal homegroup tools to try to fix it.

    I have restarted the PC several times, restarted my router, switched the network from private to public and back (restarting in between), toggled the HomeGroup services off and on, and deleted the contents of the hidden "PeerNetworking" folder. And I am still stuck in this loop - unable to join a homegroup it says I already created.

    Really all I want is simple, 1990s style folder sharing on my home network. Up until this week, homegroups usually were good enough. I thought the days of reformat/reinstall were behind me, but it seems like my last option to restore normal network activity. Any help or suggestions are appreciated.

    Edited to improve late-night clarity.
    Last edited by Tecban; 30 Dec 2015 at 10:18.
      My ComputerSystem Spec


Related Threads
I've tried trouble shooters for homegroup and network I've tried enable ipv6 I've tried making sure all necessary tasks are "running" in the services section of the network and sharing center I've tried making sure all my advanced homegroup...
46244 I have 3 computers running Windows 10. Two were upgraded from Windows 7, and one from Windows 8. May not have had the Homegroup working properly before, and I think I had created one some time ago. I don't know what the password was. But,...
Hello, After upgrading both Desktop & Laptop to Win 10, I am not able to JOIN Homegroup. Both computers show the option Homegroup: READY TO CREATE. Nomally when a Homegroup is created through one of the computers in network, Second or other...
since I upgraded to the 10162 Build I cannot connect to my Home Group like before. The p2p.svc,PNRP svc and the Peer Networking Grouping svc is off!! as a matter of fact there is no " idstore.sst " in the folder that it normally is in....
Stuck in Repair Loop in General Support
I recently updated to build 10130 and now I'm stuck in a "Preparing Automatic Repair" -> Restart loop. Any thoughts on how to fix this?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:46.
Find Us