Windows 10: One or more network protocols are missing from this computer error

Page 4 of 6 FirstFirst ... 23456 LastLast
  1.    12 Jan 2016 #31

    angeloG77 said: View Post
    Same thing happened to me yesterday. I bought a usb 3.0 ethernet dongle and plugged it in and had internet instantly. Now today Im getting intermittent on/off on/off. It doesnt even see the ethernet cable half the time. It goes through looking for problems, i plug the cable in, then it says network protocol missing. Just a heads up, you might not want to waste your time with a new nic it seems to infect it right away
    Ok, thank you for responding. Maybe best way would be to get hold of an older version of W10. Seems like the iso I download contains all the latest updates already.... Its something else than the major november update that creates this because I have never had anything else than 1511 on my computers.
      My ComputerSystem Spec

  2.    12 Jan 2016 #32

    Dadicator said: View Post
    I personally think it's a bug in Windows 10 -- I have never seen this on other systems

    There is another post that describes clean out of old Network Adapter settings: Basics steps => Regedit =>HKLM =>System => Controlset001 =>Control =>Network =>[Look for key such as --- sample below]HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}
    Expand each one => your looking for ones that expand to a Folder called "Connection" in side that folder it will give you the connection such as "Ethernet 1, WiFi, Bluetooth ect." match those with the ones in your Device Manager after un-hiding icon's options -- Then you have a chance at getting rid of some old network adapter files.

    If you don't understand what I am talking about -- "DO NOT ATTEMPT" -- messing with the Registry is serious stuff.
    You are onto something here! When I expand that exact same folder example you gave I now have 17 subfolders. Only 1 of those folders says wifi.

    Then in device manager I was poking around with the settings and found an option to unhide all. I went from 4 listed under network adapters, to 17. Which now makes sense why I had 17 folders in the registry. I viewed the properties on each of these 17 network adapter devices, 3 of them currently say in the device status box:

    "Currently, this hardware device is not connected to the computer. (Code 45) To fix this problem, reconnect this hardware device to the computer."

    My wifi is not working at this moment (typing from mobile). The 3 "network adapters" that are listed as not connected are:

    -Microsoft ISATAP Adapter
    -Microsoft WiFi Direct Virtual Adapter
    -Teredo Tunneling Pseudo-Interface

    The other 14 all SAY in the device status box that they are working. Unfortunately I don't have another PC at the moment to check this against, as all other pc's here are running the same version of Windows 10.

    Unfortunately you lost me at the part about getting rid of old network files... as Im not sure if any of these 17 are considered old.

    You sound like you know what you're talking about though, do you have any other ideas with the new info I just found?
      My ComputerSystem Spec

  3.    12 Jan 2016 #33

    MathiasS said: View Post
    Same problem here.

    Accidently rebooted my computer => a few pending updates was installed/activated. After that, no network connectivity and I get the "One or more network protocols.....".

    I tried all actions proposed here and on other forums, nothing worked. This computer has been running without problems with W10 since I did the upgrade from W7 late november. Since there is nothing much done to the install, I decided to make a clean install....

    Downloaded the W10 iso, pushed it to a USB stick, formated the disk, installed. As soon as the network driver is installed, I get the same message again and no network access. Tried all trix and tips again, no success.

    => Now I have a close to brand new computer that cant run Windows 10.

    What to do next? The only thing I can think of is to install another NIC and see if that helps. The onboard Killer E220 seem to create problems for people.

    Problem solved.

    The very first thing I tried was to swap ethernet cable between computer and switch. No change. And I had other computers on the same switch with the same cables that worked fine. And the cable/switch worked fine 20seconds earlier, before the reboot with updateds being installed.

    However....

    Just to try something, I pulled out an old Netgear FS108 switch and connected everything with the same cables as before. AND NOW I HAVE NETWORK CONNECTIVITY AGAIN.

    And I still have a file server connected to the faulty switch and its still online and working fine. And this problem DID materialize after a reboot. And I did scrap my installation for nothing, my bad.

    So, my two cents - check and re-check your network hardware.
    Last edited by MathiasS; 12 Jan 2016 at 17:32.
      My ComputerSystem Spec

  4.    17 Jan 2016 #34

    I had the same problem for two days. I suddenly couldnt connect to thw internet via wifi or ethernet after the recent Windows 10 upgrade.

    I tried everything I found online to no avail.
    1. Resetting winsock and ip through command prompt.
    2. Uninstalling and installing the network adapter
    3. Updating the driver software
    4. Sytem restore
    5. Restoring to previous build

    The only thing that worked for me is reverting the OS back to Windows 8.1. My PC and laptop were affected. I reverted to 8.1 on my PC then copied the Winsock and Winsock2 registry to my Windows 10 laptop.

    I restarted my router just to make sure and voila! Internet's back on both computers.

    I am not updating my PC to Windows 10 just yet until this bug is addressed by Microsoft.

    Hope this will help anyone still experiencing the problem.
      My ComputerSystem Spec

  5.    17 Jan 2016 #35

    What if you had re-booted the router earlier in the process....?
      My ComputerSystem Spec

  6.    17 Jan 2016 #36

    bro67 said: View Post
    arisutan the problem is that we cannot just nail the problem down to one particular service. Everyone is getting the problem with different software, or when they are just browsing the Internet.

    The proxy issue, you may have to start looking at 7 & 8 as the starting point.
    sorry i didn't see your reply because you didn't quote me
    i've tried almost every fix for any win version and still no luck.. really hoping a win update will save me
      My ComputerSystem Spec

  7.    17 Jan 2016 #37

    I did that too in combination with the solutions I found online with no luck. I did a lot of things on my computer so it's possible that any of those helped in one way or another.

    But the internet only came back when I copied the Winsock and Winsock2 registry files from a non-Windows 10 PC. It's still definitely worth a try if the problem still persists.
      My ComputerSystem Spec

  8.    18 Jan 2016 #38

    arisutan said: View Post
    sorry i didn't see your reply because you didn't quote me
    i've tried almost every fix for any win version and still no luck.. really hoping a win update will save me
    For a less sophisticated fix. I went back to a restore point of January 13, 2016 and now it runs fine. I set updates to DEFER until this issue is fixed in some future patch/update.
      My ComputerSystem Spec

  9.    18 Jan 2016 #39

    wish i could do system restore QQ
      My ComputerSystem Spec

  10.    24 Jan 2016 #40

    I Followed These Steps to Fix That Problem:


    I too had this problem happen all of a sudden this past Friday (01. 22. 2016) morning. I scoured the Internet using the hotspot on my smartphone and found a solution to this problem over at Kapril Arya. An individual named "Nate J" offered the following solution. I applied that solution and I have outlined the steps I took to get my machine back to full connectivity.


    1. Look for a Windows 7 or 8.1 OS machine and export the Winsock and Winsock 2 registry keys to a thumb drive or backup harddrive. Be sure to export a 32-bit registry key if you have a 32-bit system; export a 64-bit registry key to a 64-bit system. If you do not have access to either, here is at least a link to Winsock from a Windows 8.1 64-bit machine; here is also a link to Winsock 2 from the same machine. These files came from Mr. Arya's machine.
    2. First, you may want to set up a Restore Point on your machine before you start tinkering with the Registry just in case.
    3. Next, back up your registry by pressing the Windows and X keys together to bring up the Run command line item. Click on it and it will bring up the Run command line.
    4. Type in regedit. When the dialog box appears click OK. When the User Account Control box appears, click the Yes button.
    5. When the Registry Editor appears, look under the File menu for the Export menu item.
    6. When the Export Registry File box appears, look for a location to save the files in, create a folder named Win 10 Registry Back Up or something similar on either a thumb drive or a back up hard drive.
    7. Return to the Registry Editor and look for the Winsock folder under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
    8. When you are copying the Winsock and Winsock 2 folders from a Windows 7 or 8.1 machine if you decide not to use the links above, simply use the Export function described in bullet point 6 in order to save those two keys for later import into the Windows 10 registry.
    9. Return to the Windows 10 Registry Editor to the Winsock and Winsock 2 keys repectively and right-click on each Winsock Key Folder to select Delete. Answer Yes and close the Registry Editor.
    10. Reopen the Registry Editor, return to the File menu item and look for the Import function. Ensure that the hive is still open under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services.
    11. The Import Registry File box will open to the location where you saved the Winsock and Winsock 2 keys on your thumb drive or backup harddrive.
    12. Click on Winsock first. Winsock 2 may show up too after the import. If it does, right-click on it to delete it. Return to the Import Registry File box to import the Winsock 2 folder.
    13. Once both of the keys have been imported into their place in the registry, close the Registry Editor.
    14. Next, press the Windows and X keys to bring up the Command Prompt (Admin) menu item. Type in "Ping 192.168.1.1." - usually your router's IP Address. If it responds and returns with 0% packet loss then you have communications with your router. "Nate J" suggested that it may be necessary to type in the "netsh winsock reset" command and then reboot if the Windows version of your PC is an earlier version than the files you are replacing the Winsock files with.
    15. Next, type "Ping Google.com." If you also receive a response with 0% loss then you should be able to connect to the Internet without a reboot. To properly close the Command Prompt, type in exit, and it will close.
    16. Check through your router's login gateway to see if it will connect your machine to the Internet. Your router may change its IP address in order to avoid a conflict with your ISP's IP address. It should connect after that.


    It worked for me. Hopefully it will help you too! My thanks goes to Mr. Kapril Arya on his blog and "Nate J" another commenter on his blog for publishing these insightful assists - which helped me and my business get back to work.
      My ComputerSystem Spec


 
Page 4 of 6 FirstFirst ... 23456 LastLast

Related Threads
Solved Network Protocols in Network and Sharing
Problem trying to connect to internet on laptop, but all working as normal on desktop. Investigations revealed....one or more Network Protocols are missing on this computer, also Windows sockets registry entries required for network connectivity...
Network Protocols Missing in Network and Sharing
Noted immediately after 1511 total system update, yet may have been inherited from an earlier build... All is working well, yet Network Troubleshooter reports "one or more network protocols is missing." Various posted remedies have been verified...
One or more network protocols are missing on this computer Restore network protocols to default settings Yesterday I upgraded my previous build of Win 10 Pro (64bit) to the new 1155 build. I had failed to uninstall either bitdefender or...
Solved Missing network in Network and Sharing
Hi, for past 20-something hours i've been testing win10 in various ways. There are two issues i encountered so far. One, i mention Here, and the seccond one is network-related, which i'm gonna describe now. So I decided to make a clean install...
Hi there It seems that for earlier computers such as XP / W7 or even Linux machines connecting TO a W10 machine causes problems unless you connect via an IP address. Even if you apply the "Fix automatically" it still doesn't work and if you...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:31.
Find Us