Windows 10: Network Devices not Showing with File Explorer Solved

Page 2 of 2 FirstFirst 12
  1.    27 Feb 2016 #11

    Worked for me too. My question is: Should I do the reversal step too?
      My ComputerSystem Spec

  2.    28 Feb 2016 #12

    Ed Mullen said: View Post
    Worked for me too. My question is: Should I do the reversal step too?
    Tried it and the answer is no. I suppose when MS fixes this then the reversal should be done.
      My ComputerSystem Spec

  3.    29 Feb 2016 #13

    Sage said: View Post
    The fall update broke the SMB (Server Message Block) component of the OS. Below is a work around that will fix your issue until such time as Microsoft patches this issue.
    1. Open an administrator cmd prompt.
    2. type the following: (press Enter after each line)

    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    then Restart the computer
    All machines Win10 v1511 (b10586.104):

    PC#1 showing up on my laptop without applying the tweak.
    PC#2 shows up on my laptop AFTER applying the tweak.
    PC#3 does not show up on my laptop AFTER applying the tweak.

    AFTER applying the tweak to my laptop, PC#3 shows up BUT not actually able to access ANY of the shared folders, just get error "One or more network protocols are missing" and "Windows sockets registry entries required for network connectivity are missing". Tried admin cmd:
    netsh int ipv4 install and restart but does not help.
    netsh winsock reset and restart but does not help.

    In order to get access to shared folders to work again on the laptop I had to revert using:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto

    Seems I can't win! One way I can see all the shares but cannot access them, the other way some shares don't show up but I can access them (type \\computername).
      My ComputerSystem Spec

  4.    01 Mar 2016 #14

    Many thanks, Sage. It worked like a charm.

    I already had individual desktop icons on three of my four networked PCs but the Network icon didn't show them after installing Win10. It does now!

    On one of my PCs (my wife's) I hadn't extracted the individual workgroup PC icons from Network and I was stuck.

    All's well that ends well.
      My ComputerSystem Spec

  5.    01 Mar 2016 #15

    Thanks!


    Sage said: View Post
    The fall update broke the SMB (Server Message Block) component of the OS. Below is a work around that will fix your issue until such time as Microsoft patches this issue.
    1. Open an administrator cmd prompt.
    2. type the following: (press Enter after each line)

    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    then Restart the computer

    To reverse this change and re-enable SMBv3 run the following commands at at the elevated command prompt

    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto

    then Restart the computer
    I registered just so I could thank Sage. I have been struggling with this problem for months and have spent the last two days looking for a fix and trying all kinds of CMD fixes and none of them fixed anything. Finally something that works on all eleven of my computers.
    Thank you Sage!
      My ComputerSystem Spec

  6.    01 Mar 2016 #16

    stony41 said: View Post
    Many thanks, Sage. It worked like a charm.
    As tends to happen with Windows networking, I have found today that I have one failure.

    I decided to try the fix on my 11-inch laptop that doesn't reside on my home network permanently. When I opened it, it was showing itself and just one of my three other PCs. I ran the fix and unfortunately got the same limited result. Of course, in typical Windows fashion the PCs that it couldn't see could see it.

    This failure isn't critical, but it would have been nice to get the fix to work as it had with my four other PCs.
      My ComputerSystem Spec

  7.    07 Mar 2016 #17

    this may work for you, it did for me.

    mount the nas
    create a shortcut
    put the shortcut in the startup folder
    restart your machine

    with any luck after the system detects your network the nas will show up in network devices
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
I just put the 1511 upgrade on (for the third time, but that's another story). I've noticed that when I open File Explorer I have a WHOLE BUNCH of USB ports that have nothing plugged into them... I have no idea what the upgrade did, but these...
Hi Ms this fault I find really annoying and there's actually no excuse for this particular defect : When copying / moving files with File explorer - progress indicator doesn't show - which makes the whole thing unuseable if you are copying /...
As the title says. I can reach them by the quick access shortcuts I added before the upgrade but they don't show up in WE Network. Rebooting my WD MyCloud solves the problem until next time I reboot my Win10 c.
Hi, I upgraded to Windows 10 yesterday and everything works fine apart from this. I have Garmin edge 510 and 200 cycle computers, when plugged into the computer they are seen by windows and show up in device manager under disk drives. (as they...
Solved CD/DVD not showing on file explorer in Drivers and Hardware
I noticed that on my W10 build, that the cd/dvd (Drive D: in my case) does not show on file explorer. However if I put a blank disk or a disk with data, it will show. This behavior is different than Win7, which always shows the cd/dvd drive. Is...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:55.
Find Us