Page 2 of 3 FirstFirst 123 LastLast
  1.    01 Jan 2015 #11
    Join Date : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3

    Quote Originally Posted by werty View Post
    Hope this time works!

    Edit: these drivers come up with my Huawei E173 Modem running on Windows 8.1
    Yep, the zip file is there. I haven't looked inside, because it wouldn't do me much good (I don't have a Huawei device).

    I think the best path dejager183 can take is to post the device manager screen shot for now. I have been able to get older USB 802.11 adapters to work by installing through Device manager - some devices needed a bit more coaxing (a different mfr'd device with the identical chip, then using that inf file ... but that's a lot of investigation).

    I'm thinking the device might be visible in DevMgr and dejager183 might be able to coerce the install using what they have.

    Your zip file might come in handy, but there is a risk in just installing those drivers. I don't know the specifics of the two devices.

    Thanks for posting them - we'll see how things go and maybe one of us can research the devices a bit further.

    If you have the E173 installed and running, could you provide any additional information (driver version, chipset - there aren't that many really - Intel, Broadcom, Realtek, ....). Also is the E173 phone capable (see I really know nothing about the Huawei devices

    Thanks, it falls back into dejager183's court.

    Bill
    .
      My ComputerSystem Spec
  2.    02 Jan 2015 #12
    Join Date : Jul 2014
    Posts : 80
    Windows 10 Pro/ Windows 8 Enterprise

    Quote Originally Posted by Slartybart View Post
    Quote Originally Posted by werty View Post
    Hope this time works!

    Edit: these drivers come up with my Huawei E173 Modem running on Windows 8.1
    Yep, the zip file is there. I haven't looked inside, because it wouldn't do me much good (I don't have a Huawei device).

    I think the best path dejager183 can take is to post the device manager screen shot for now. I have been able to get older USB 802.11 adapters to work by installing through Device manager - some devices needed a bit more coaxing (a different mfr'd device with the identical chip, then using that inf file ... but that's a lot of investigation).

    I'm thinking the device might be visible in DevMgr and dejager183 might be able to coerce the install using what they have.

    Your zip file might come in handy, but there is a risk in just installing those drivers. I don't know the specifics of the two devices.

    Thanks for posting them - we'll see how things go and maybe one of us can research the devices a bit further.

    If you have the E173 installed and running, could you provide any additional information (driver version, chipset - there aren't that many really - Intel, Broadcom, Realtek, ....). Also is the E173 phone capable (see I really know nothing about the Huawei devices

    Thanks, it falls back into dejager183's court.

    Bill
    .
    Attachment 9958Attachment 9959

    The E173 modem is running on integrated Intel chipset. On the screenshots you can see the driver versions. I don't think it is phone capable - I am using it only to surf the net. In the drivers that I have uploaded there are many hardware ids, I hope the E352 modem hardware id is among them.
      My ComputerSystem Spec
  3.    02 Jan 2015 #13
    Join Date : Dec 2014
    Pretoria, South Africa
    Posts : 25
    Win 10 Beta and Windows 7
    Thread Starter

    Hi guys, the modem had software installed that i removed and replaced with a newer version of Mobile Partner using the dashboard Tool. That is all that is installed on the modem at the moment, I have tried various other versions of Mobile Partner aswel and it still doesn't get "picked up" by Win 10, yet it works perfectly in Windows 7. I tried downloading the drivers werty listed but for some reason i cant download them (yes i am registered on MediaFire). It is very strange that it doesn't get recognised as a modem in Win 10. Any other advise ... please guys, this is turning out to be one heck of a challenge ... lol
      My ComputerSystem Spec
  4.    02 Jan 2015 #14
    Join Date : Dec 2014
    Pretoria, South Africa
    Posts : 25
    Win 10 Beta and Windows 7
    Thread Starter

    Finally, managed to resolve the problem by downloading the Mobile Partner version from the Huawei website designed for Windows 8.1 and updating the Modem Software & Drivers. This installs the drivers for the device and it works perfectly in all versions of Windows including Windows 10 TP.
    Here is the link to the download for the software & drivers should anyone else have a similar problem.
    http://consumer.huawei.com/en/suppor...x.htm?id=31521
      My ComputerSystem Spec
  5.    02 Jan 2015 #15
    Join Date : Jul 2014
    Posts : 80
    Windows 10 Pro/ Windows 8 Enterprise

    Glad you sorted it out! If you have other questions don't hesitate to ask.

    Good luck, werty
      My ComputerSystem Spec
  6.    02 Jan 2015 #16
    Join Date : Dec 2014
    Pretoria, South Africa
    Posts : 25
    Win 10 Beta and Windows 7
    Thread Starter

    Quote Originally Posted by werty View Post
    Glad you sorted it out! If you have other questions don't hesitate to ask.

    Good luck, werty
    Than you for your assistance, i will keep that in mind.
      My ComputerSystem Spec
  7.    02 Jan 2015 #17
    Join Date : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3

    Quote Originally Posted by dejager183 View Post
    Finally, managed to resolve the problem by downloading the Mobile Partner version from the Huawei website designed for Windows 8.1 and updating the Modem Software & Drivers. This installs the drivers for the device and it works perfectly in all versions of Windows including Windows 10 TP.
    Here is the link to the download for the software & drivers should anyone else have a similar problem.
    http://consumer.huawei.com/en/suppor...x.htm?id=31521
    Where there's a will ... there's a way. I probably would have missed that page since it references Mac first - great find and thanks for posting the information.

    Bill
    .
      My ComputerSystem Spec
  8.    04 Jan 2015 #18
    Join Date : Dec 2014
    Pretoria, South Africa
    Posts : 25
    Win 10 Beta and Windows 7
    Thread Starter

    Quote Originally Posted by Slartybart View Post
    Quote Originally Posted by dejager183 View Post
    Finally, managed to resolve the problem by downloading the Mobile Partner version from the Huawei website designed for Windows 8.1 and updating the Modem Software & Drivers. This installs the drivers for the device and it works perfectly in all versions of Windows including Windows 10 TP.
    Here is the link to the download for the software & drivers should anyone else have a similar problem.
    http://consumer.huawei.com/en/suppor...x.htm?id=31521
    Where there's a will ... there's a way. I probably would have missed that page since it references Mac first - great find and thanks for posting the information.

    Bill
    .
    Awesome, I'm always glad if the information is useful to others also.
      My ComputerSystem Spec
  9.    22 Dec 2015 #19
    Join Date : Dec 2015
    Posts : 1
    Windows 10 Pro 64 bit

    Quote Originally Posted by werty View Post
    Attachment 9946 Hope this time works!

    Edit: these drivers come up with my Huawei E173 Modem running on Windows 8.1
    I have same problem how to use this driver.zip i extracted and saw lots of files but not exe or msi file to install it help
      My ComputerSystem Spec
  10.    23 Dec 2015 #20
    Join Date : Oct 2013
    Posts : 336
    Windows 10 Pro x64, Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64

    Quote Originally Posted by iFaizan View Post
    I have same problem how to use this driver.zip i extracted and saw lots of files but not exe or msi file to install it help
    After you unzip the drivers use this tutorial to install using the Device Manager

    Driver Install
      My ComputerSystem Spec

 
Page 2 of 3 FirstFirst 123 LastLast


Similar Threads
Thread Forum
WOL not working
Since installing windows 10 my WOL has stopped working, I'm fairly certain I have the same setup I used to have. Any advice ?
General Support
Working with ICD and Sysprep
Trying to work on creating Windows 10 Image deployment without MDT. Ideally what I am thinking is that I use system Image manager to create an unattend.xml file for the main image. Then I am hoping i can use the ICD to apply Desktop Image...
Installation and Upgrade
Solved PES 2015 not working!
I can't get pes 2015 to start up, it only gives 0xc00007b error. I have the latest amd 15.7 drivers installed.
Gaming
Solved Get Windows 10 App Not Working
I do not have the get windows 10 app on my computer. The windows 10 icon has never appeared at the icon tray. My system is up to date. I have a genuine copy of windows. I have above the minimum PC specs. I have always been connected to the internet....
General Support
Usb Wi-Fi adapter not working
I've recently bought a nano usb wi-fi adapter and on it's packaging it says it's only compatible with Windows XP/Vista/7. Indeed its drivers don't work on Windows 10 9879, the device is recognized but it doesn't work. Is there a way around this?...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:22.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums