Network Protocols Missing

Page 1 of 5 123 ... LastLast

  1. Posts : 234
    Windows 10

    Network Protocols Missing

    Noted immediately after 1511 total system update, yet may have been inherited from an earlier build...

    All is working well, yet Network Troubleshooter reports "one or more network protocols is missing."
    Various posted remedies have been verified or implemented, to no avail.

    Win 7, on the same machine, reports no errors.

    Attached Thumbnails Attached Thumbnails Network Protocols Missing-network_specs.jpg  
    Last edited by borgus; 06 Dec 2015 at 16:58.
      My Computers

  2. Posts : 1,026
    Win10 Version 21H2 19044.1645

    Network Protocols

    Many are experiencing same issue with Win10. Join the search for answer. :)

    Some have tried the NetBIOS method in post #10. I did but it did not resolve slow internet issue. May want to review the entire thread for other info.
      My Computer

  3. Posts : 234
    Windows 10
    Thread Starter

    Network Protocols Missing (possible fix)

    This is an Ethernet wired connection. Error was banished here by following this procedure...

    WARNING: Mucking with the registry can hose Windows. Back up first, preferably creating image file for restore.

    1. Download the two attachments here, names Winsock.reg and Winsock2.reg.
    2 Right-click START|RUN|type "regedit" and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
    3. Extract both Winsock and Winsock 2 folders (to a different folder than the one with the files downloaded here).
    4. In the registry, delete those two folders.
    5. Double-click and MERGE into the registry each of the two folders that were downloaded.
    6. Reboot several times.
    7. If Event Viewer displays an error "The device or resource (wpad) is not set up to accept connections on port "The World Wide Web service (HTTP)" right-click START|CONTROL PANEL|INTERNET OPTIONS|CONNECTIONS tab|LAN settings button and UNcheck "automatically detect settings."

    If problems arise delete the two Winsock folders you added to the registry and merge the ones that you saved.
    Network Protocols Missing Attached Files
    Last edited by borgus; 07 Dec 2015 at 15:51.
      My Computers

  4. Posts : 1
    Windows 10

    I'm getting this problem too on my wired connection
      My Computer

  5. Posts : 3
    Windows 10 Professional

    Same problem here, just upgraded to 1511 on my desktop this evening and I have no internet access. The registry files above had no effect.
      My Computer

  6. Posts : 234
    Windows 10
    Thread Starter

    Suggestion above was not intended to repair "no Internet access" but simply the error message "one or more protocols are missing."
    Have you right-clicked the Net icon in the tray (right-bottom of window) and clicked on "troubleshooter?"
      My Computers

  7. Posts : 3
    Windows 10 Professional

    Yes, I receive the same error message as described in the OP.
      My Computer

  8. Posts : 1

    I have the same problem! "One or more Internet protocols are missing" I tried cmp, uninstall wifi adapter! Nothing worked! I just can't figure out the problem!! Someone help!!
      My Computer

  9. Posts : 3
    Windows 10 Professional

    I just reverted to the previous build and it restored my internet access. Hopefully MS acknowledges this and fixes it...
      My Computer

  10. Posts : 3
    Windows 10 Home

    Thanks for the fix Borgus.

    It didn't work to fix the original problem that I was looking for a solution for, which was the response to:
    C:\WINDOWS\system32>net view
    System error 1231 has occurred.
    The network location cannot be reached.

    But following an upgrade from Windows 7 Pro to Windows 10 Pro, and renaming this particular computer (change of employee), the computer's own name didn't appear in its list of computers on the network. Running your Winsock fix has restored this and it now lists itself among the other network computers. However, the System error 1231 is still there and interestingly, it will open and share all files on other network computers which had permission prior to the upgrade, but it is denied access to any folders and files for which permission was granted to 'everyone' after the upgrade.

    Really frustrating and I'll keep seeking a solution.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:01.
Find Us

Windows 10 Forums