Page 3 of 5 FirstFirst 12345 LastLast
  1.    03 Jan 2016 #21
    Join Date : Jan 2016
    Posts : 1
    Windows 10

    01/03/2016 after losing about 4 hours of my night, I have recovered my internet connection.
    All these threads have been extremely helpful. I considered the winsock recovery but didn't need to do this, but it sounded very correct. I did follow one poster's link (or it may have been from my own search) to reset the TCPIP stack in Windows 10 [ How to reset the TCPIP stack in Windows 10 - YouTube ] That didn't seem to work or possible it helped.Then I tried under 'Recovery' 'Open System Restore'. The system said I had no restore points set. I then uninstalled almost all the Windows 10 updated with a 01/01/2016 or 01/02/2016 installed date (yeah Happy New.. what a way to start), but not all of them as there was about 25 of them, but I did what i thought were the culprits to the 'network protocol missing' error.. I restarted the computer. It took very long as it appeared it was installing windows updates again. I then tried the System Restore again which was now available, which is odd because I didn't set a restore point, unless this network protocol missing was making it appear as such. I then restarted and waited very long. Still no internet. Then did a rebuild recovery which took very long but still no internet. I checked and all the recent updates were gone. I restarted one more time. I worked... go figure...
      My ComputerSystem Spec
  2.    17 Jan 2016 #22
    Join Date : Jan 2016
    Posts : 1
    Windows 10

    Borgus, your fix worked for me. Thanks for posting the Winsock files. The only other change I had to make after I replaced the Winsock folder was to change the DHCP setting to automatically obtain an IP address from the router. I have spent days trying to fix this issue, and your solution has been the one that worked. Thanks so very much!!
      My ComputerSystem Spec
  3.    17 Jan 2016 #23
    Join Date : Jul 2015
    Posts : 149
    Windows 10
    Thread Starter

    Glad it did the job for you and others. As a caution to newcomers to the thread, the Winsock.reg replacement post is targeted only at eliminating the "some network protocols are missing" message, and not to non-connectivity issues.

    An updated, Win-10 approved Network controller from Realtek's site was recently installed here. It worked for a short time, then the circuit went down. After troubleshooters were run, the Gateway was reset and the PC was rebooted, the Net became accessible, but the "net protocols missing" message had returned - again remedied by the Winsock.reg files.

    As that update was made to a very recently installed 1511 build that lists no SFC errors, this hints that updating Realtek's PCIe GBE Family Controller may be a cause, perhaps as a result of a Windows 10 auto-update on some PCs.
      My ComputersSystem Spec
  4.    23 Jan 2016 #24
    Join Date : Jan 2016
    Posts : 16
    Windows 10

    My situation is very similar to Marc's. My Dell XPS 8700 desktop was upgraded to Windows 10 when the upgrade first became available and had been running well. The Jan 13 critical update disabled internet access (Ethernet connection). Network troubleshooter shows internet protocols missing and "Windows sockets registry entries required for network connectivity are missing".

    My wife's Dell Inspiron 15, 3000 series laptop had virtually the same problem a week or two earlier and I was able to get it working again (WiFi connection) by going back to the previous build of the operating system. I'm not exactly sure where I found the revert command, but it wasn't by using a restore point.

    On my PC, I found only 3 restore points, the most recent for the critical update and two previous, minor updates. I tried to go back to the restore point for the critical update, but got a message saying that the restore had failed due to an error writing a registry entry. (I didn't think to try to figure out which one.) It took many reboots to just get back to Windows. When I finally did, internet access remained disabled and the system had no restore points shown.

    I went into control panel, programs, installed updates and uninstalled the latest update. Today I tried advanced startup and found two restore points, the earliest dated 1/16, critical update. I tried to restore to that point, restore completed successfully this time and gave me a message about being restored to 1/16, but the build number didn't change and when I go back into restore points, the 1/16 critical update restore point is still there, along with two newer ones.

    Why don't I have more restore points? On older versions of Windows I would have restore points going back many months.

    I have also tried:


    I am currently at Windows 10 Home, version 1511, build 10586.36. Wife's laptop is Win 10 Pro, build 10240.

    One extremely annoying thing related to all this is that the Windows search bar can't find anything. For example, if you type "restore", it says no results found. Apparently it needs internet connectivity to function, even for local searches.

    Any help would be greatly appreciated!
      My ComputerSystem Spec
  5.    24 Jan 2016 #25
    Join Date : Jan 2016
    Posts : 16
    Windows 10

    Quote Originally Posted by borgus View Post
    This is an Ethernet wired connection. Error was banished here by following this procedure...

    WARNING: Mucking with the registry can hose Windows. Back up first, preferably creating image file for restore.

    1. Download the two attachments here, names Winsock.reg and Winsock2.reg.
    2 Right-click START|RUN|type "regedit" and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
    3. Extract both Winsock and Winsock 2 folders (to a different folder than the one with the files downloaded here).
    4. In the registry, delete those two folders.
    5. Double-click and MERGE into the registry each of the two folders that were downloaded.
    6. Reboot several times.
    7. If Event Viewer displays an error "The device or resource (wpad) is not set up to accept connections on port "The World Wide Web service (HTTP)" right-click START|CONTROL PANEL|INTERNET OPTIONS|CONNECTIONS tab|LAN settings button and UNcheck "automatically detect settings."

    If problems arise delete the two Winsock folders you added to the registry and merge the ones that you saved.
    Quote Originally Posted by borgus View Post
    Glad it did the job for you and others. As a caution to newcomers to the thread, the Winsock.reg replacement post is targeted only at eliminating the "some network protocols are missing" message, and not to non-connectivity issues.
    ...
    For some reason this second bit confused me into thinking that all it fixed was an error message. I finally tried the above and it fixed the missing protocols problem. Now when I run the network diagnostics I get the message:
    "Ethernet" doesn't have a valid IP configuration
    I've reset the router. I have a green light PC end and the router thinks something is connected on it's end.

    When I run diagnostics on the WiFi connection, I get:
    "WiFi" doesn't have a valid IP configuration

    I'm not sure how to proceed from here.

    Thanks in advance for your help!
      My ComputerSystem Spec
  6.    24 Jan 2016 #26
    Join Date : Jul 2015
    Posts : 149
    Windows 10
    Thread Starter

    Did you run the network troubleshooter once again?
    Did you revert to the original Winsock files, which you backed up as suggested in the earlier post?
      My ComputersSystem Spec
  7.    24 Jan 2016 #27
    Join Date : Jan 2016
    Posts : 16
    Windows 10

    Thanks so much for the quick reply!

    I've run "Windows Network Diagnostics" multiple times. It thinks that I have a router issue, suggests cycling power, etc., which I've done.

    I have not tried reverting to the original Winsock files. Wouldn't that put me back where I started?
      My ComputerSystem Spec
  8.    24 Jan 2016 #28
    Join Date : Jul 2015
    Posts : 149
    Windows 10
    Thread Starter

    One would think so, but that's not guaranteed. Before you revert, do a search for...
    ""WiFi" doesn't have a valid IP configuration"

    You will see many hits, which may lead to resolution of the problem.

      My ComputersSystem Spec
  9.    24 Jan 2016 #29
    Join Date : Jan 2016
    Posts : 16
    Windows 10

    thanks
      My ComputerSystem Spec
  10.    25 Jan 2016 #30
    Join Date : Jan 2016
    Posts : 1
    Win10

    Hi Everyone,

    I'm at my wits end here. Sunday morning I received this error on my computer after playing video games for a few hours.

    The most recent windows update I've had was on 1/13/2016, so I don't think it is an issue with a windows update, because this happened more than a week after any updates.

    Anyways, I get this winsock error, and have no internet connection.

    I've tried everything suggested in this thread. I've tried resetting winsock, I've tried flushing/renewing my IP and DNS, I've uninstalled my internet driver and rebooted to have it reinstalled. I've done the registry edit, and while it did get rid of the error, it did not fix my internet connection, so I reverted the process, and have the error again.

    My last resort was to do a complete reset on Windows, deleting all files & folders, freshly installed, and I still have the winsock error. Are you kidding me??

    Anyways, my question is this: Can this be a problem with my modem?? I have a tech with my ISP coming tomorrow after I get off of work to take a look at the wiring and replacing the modem.

    One thing to note is that my modem is a 2in1 and It is not sending out a wifi signal ever since this winsock error appeared. I know this because when I come home, I connect my phone via WiFi, and I'm unable to now. I'm also unable to log into my modem using the 192.168.0.1 path in a browser. The modem (arris) is stuck on "Unit is updating...etc" for hours. Can this be related to the winsock error, at all?

    Thanks.
      My ComputerSystem Spec

 
Page 3 of 5 FirstFirst 12345 LastLast


Similar Threads
Thread Forum
Solved Network Protocols
Problem trying to connect to internet on laptop, but all working as normal on desktop. Investigations revealed....one or more Network Protocols are missing on this computer, also Windows sockets registry entries required for network connectivity...
Network and Sharing
After 1155 build upgrade/system reset..... missing network protocols
One or more network protocols are missing on this computer Restore network protocols to default settings Yesterday I upgraded my previous build of Win 10 Pro (64bit) to the new 1155 build. I had failed to uninstall either bitdefender or...
Network and Sharing
Network machines missing in Explorer
I have 5 computers and 4 are running Windows 10. The machine I use as the main one I upgraded from Windows 7 ULT to Win 10 and have had little trouble but, my number 2 machine I added the insider preview 5 builds ago and since then, when trying to...
Network and Sharing
Solved Missing network
Hi, for past 20-something hours i've been testing win10 in various ways. There are two issues i encountered so far. One, i mention Here, and the seccond one is network-related, which i'm gonna describe now. So I decided to make a clean install...
Network and Sharing
W10 INCOMING connections - missing network protocols
Hi there It seems that for earlier computers such as XP / W7 or even Linux machines connecting TO a W10 machine causes problems unless you connect via an IP address. Even if you apply the "Fix automatically" it still doesn't work and if you...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:33.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums