Page 2 of 3 FirstFirst 123 LastLast
  1.    04 Dec 2015 #11
    Join Date : May 2015
    Central IL
    Posts : 4,361
    Mac OS Sierra

    You are going to have to build a startup script to use net use in command, to map those shares to be connected.

    You need Pro for this fix. Windows 10 asks for network credentials, even though password protected sharing is off - Stack Overflow
      My ComputerSystem Spec
  2.    04 Dec 2015 #12
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,206
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Quote Originally Posted by voyagerxp View Post
    I've mapped the nas to a drive with letter Z and Kodi connects to it fine but now. Now i have a problem that when i restart windows and enter the desktop i get a notification saying my mapped drive is diconnected. When i click This PC my mapped drive has a red X through it.
    Something is missing with your NAS configuration. You should not have to map the drive. Under network, it should show up.
    Here's my NAS with two hard drives:

    Click image for larger version. 

Name:	a.jpg 
Views:	5 
Size:	164.5 KB 
ID:	51956
      My ComputerSystem Spec
  3.    05 Dec 2015 #13
    Join Date : May 2015
    Central IL
    Posts : 4,361
    Mac OS Sierra

    Quote Originally Posted by topgundcp View Post
    Something is missing with your NAS configuration. You should not have to map the drive. Under network, it should show up.
    Here's my NAS with two hard drives:
    You have to map them if you are using them in place of say a person's My Document directory, etc.. There have also been problems with 10, that if you do not map the network shares, you cannot access them.

    Every time Microsofts prorammers touch 10's code, they screw it up even more, every time. At this point a lot of people are considering what is currently rolling out as just Beta code, that is not prime time ready, because of all of the continuous problems that it is having.
      My ComputerSystem Spec
  4.    05 Dec 2015 #14
    Join Date : Jul 2015
    Posts : 25
    Windows 8.1 x64
    Thread Starter

    Before the other day when i did a fresh install of Windows 10 on my laptop i never had this problem before. Below is a picture of My Networks.

    My Networks On My Laptop

    Click image for larger version. 

Name:	Snap3.png 
Views:	10 
Size:	1.71 MB 
ID:	52001

    I have windows 10 on my HTPC in my living room and my nas picks up on that as you can see in the pictures below.

    My HTPC showing my nas in My Network.

    Click image for larger version. 

Name:	Untitled.jpg 
Views:	11 
Size:	900.7 KB 
ID:	52002

    Click image for larger version. 

Name:	Untitled2.jpg 
Views:	10 
Size:	830.3 KB 
ID:	52003
      My ComputerSystem Spec
  5.    05 Dec 2015 #15

    Windows 10 always sees my WD My Cloud Mirror whenever I format. Things I can think of are the NAS settings, firewall on PC/router, AntiVirus such as Avast can block local network.
      My ComputersSystem Spec
  6.    05 Dec 2015 #16
    Join Date : Jul 2015
    Posts : 25
    Windows 8.1 x64
    Thread Starter

    Quote Originally Posted by swarfega View Post
    Windows 10 always sees my WD My Cloud Mirror whenever I format. Things I can think of are the NAS settings, firewall on PC/router, AntiVirus such as Avast can block local network.
    I thought that swartega but i've not changed a single setting in my FreeNas for over a year and i didn't install a firewall when i did the fresh install and disabled the windows firewall. Even my ipad and iphone pick up the nas.
      My ComputerSystem Spec
  7.    05 Dec 2015 #17
    Join Date : Jul 2015
    Posts : 25
    Windows 8.1 x64
    Thread Starter

    Today i reinstalled Windows 8.1 from fresh and my NAS was back in My Network. Does this mean it's a Windows 10 problem?.
      My ComputerSystem Spec
  8.    05 Dec 2015 #18
    Join Date : Jul 2015
    Posts : 25
    Windows 8.1 x64
    Thread Starter

    Right I've just upgraded over the fresh Windows 8.1 to Windows 10 and my NAS was in My Network but it disappeared after I installed the update (Windows Home, version 1511, 10586. What is this update for?.
      My ComputerSystem Spec
  9.    05 Dec 2015 #19

    Maybe this is just a band-aid, but it works for me. Try this

    1. Start > File Explorer
    2. Expand Network (left pane)
    3. Then in the address bar do what you did to see the NAS box
    4. Now look at the left pane and your NAS box will show up under Network
    5. Right mouse click on the NAS and select "Pin to Quick Links"
    6. Under Quick Links above you will see the NAS

    Mine sticks, reboots and shutdowns. Every time I go to File Explorer there it is, one click and I am in. I just did this with my USB thumb drive (used as external storage on router) that was doing the same thing along with my NAS boxes.

    This is just a band-aid for what I think you are looking for to do; one click in to your NAS. If not sorry
      My ComputerSystem Spec
  10.    05 Dec 2015 #20
    Join Date : May 2015
    Central IL
    Posts : 4,361
    Mac OS Sierra

    Update the FreeNas Samba software and everything else. Also check the IPTables.

    If you have not touched it in a year. It needs to be updated.
      My ComputerSystem Spec

 
Page 2 of 3 FirstFirst 123 LastLast


Similar Threads
Thread Forum
Solved Unable to map Network Shares Windows 10
Hi, I've got 2 Western Digital Network drives hard wired on my network, a My Book World and an EX2. Since upgrading to Windows 10 I've had intermittent problems viewing and setting network drives. I've read a lot of other posts and tried a...
Network and Sharing
Unable to access network drive in Explorer
I have a NAS (WD MyBookLive) which cannot be accessed in Windows Explorer on my brand new Surface by IP address (or name- though that doesn't work on any of my devices for some reason). I can access the config page in my browser by IP, and two other...
Network and Sharing
Unable to host virtual network for internet sharing
I've been getting the following error: "The group or resource is not in the correct state to perform the requested operation" Things I've already done trying to solve the problem(To save time from suggesting the same things) : 1) Clean...
Network and Sharing
network issues, unable to enter network credentials
I upgraded two desktops to Win 10 (one from Win 7 and one from Win 8.1). I have issues with setting up a network. First, I tried to set up a homegroup and I failed (i already posted another question on this subject with no luck so far). OK,...
Network and Sharing
Still unable to specify network folder for desktop slideshow
Just installed 10240 or TH1 and I am still unable to specify a network location for the background pics. If this is a bug, I can't believe they haven't fixed it. Am I missing something?
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:10.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums