Windows 10: Unable to access network drive in Explorer

  1.    01 Dec 2015 #1

    Unable to access network drive in Explorer


    I have a NAS (WD MyBookLive) which cannot be accessed in Windows Explorer on my brand new Surface by IP address (or name- though that doesn't work on any of my devices for some reason). I can access the config page in my browser by IP, and two other Win10 devices on my network can access the NAS by IP in Explorer fine, and I can access other devices on my network by IP fine on the Surface but for whatever reason only this computer can't access that NAS in Win Explorer.

    I just got the Surface yesterday and was able to access the NAS fine, the only thing that's changed is I renamed the device and restarted and since then haven't been able to connect. I've restarted both the PC again and the NAS but no change.
      My ComputerSystem Spec

  2.    01 Dec 2015 #2

    There are Networking bugs in the latest update. Read all the posts on here. Some solutions we've discovered so far might work temporarily until MS fixes the problem.
      My ComputerSystem Spec

  3.    01 Dec 2015 #3

    Any particular post you recommend reading?

    Also, after trying a few more things, it seems I get the "Windows cannot access" message trying to access the root of the NAS and one of the shares on it, however the other share (which is set to Public) prompts for a username and password. The other two devices on my network don't get that prompt, and since it's public there is no info to enter, I tried just leaving it blank but of course it comes right back.

    I fixed the issue where other devices can't access the NAS by name (simply renaming it, then renaming it back to the original name), and now it doesn't even show under network. I can access other network devices in Windows Explorer on this computer though. If this were a networking issue caused by a Win update, I'd think it would affect all network devices I would attempt to connect to, not just this one
    Last edited by me10lee83; 01 Dec 2015 at 18:31.
      My ComputerSystem Spec

  4.    01 Dec 2015 #4

    I have the same problem. I also have a MyBookLive. The difference between this device and other windows devices is that the NAS runs Linux, not windows. There is a problem with comms protocols.

    We just have to wait till MS provides an update, but, in the meantime, you could create shortcuts to the NAS resources e.g. \\name. I have a shortcut for \\MYBOOKLIVE and when dbl clicked, it pops up the File Explorer window with shares displayed.

    Meanwhile, we wait...........................
      My ComputerSystem Spec

  5.    01 Dec 2015 #5

    Ok that makes sense about Linux vs other Windows devices. Guess the other Windows devices maybe just don't have the same update my Surface does which is why they still work.

    Manually typing the name/a shortcut doesn't work. I have a network drive mapped to the IP (from before I got the name issue fixed) and it doesn't work, typing the IP and name manually both say Windows can't access, check the name, network connection, etc.

    Guess maybe I just won't be able to connect until they fix it. Hope it's soon!
      My ComputerSystem Spec

  6.    01 Dec 2015 #6

    Oh, damn, my \\NASname is giving the 80070035 error now as well.

    That's another symptom - it comes and goes.

    Grrrrrrrr
      My ComputerSystem Spec

  7.    02 Dec 2015 #7

    linw said: View Post
    Oh, damn, my \\NASname is giving the 80070035 error now as well.

    That's another symptom - it comes and goes.

    Grrrrrrrr
    Same here. Got everything perfect then it all messed up by itself again. There appears to be both Networking and Firewall issues that are sporadic. I turned Firewall off today and it brought back the panel contents instantly. Turned it on and they were still there. That was the first time I tried Firewall on/off to see if it was a bug there also. On the next boot later in the day after lunch everything on the network was invisable again. Tried Firewall on/off again and everything stayed invisible. So that on/off worked in the morning but not in the afternoon.

    This bug(s) has a mind of its own. It's become unpredictable and comical at this point.
      My ComputerSystem Spec

  8.    02 Dec 2015 #8

    Turning Windows Firewall off allowed my NAS to show up under Network, but it was prompting me to login to access either of the shares which are both Public, and by IP it wasn't connecting at all. Turned firewall back on and it's gone again. Firewall back off, now the IP shows in the list of Network devices but not the NAS name (and won't connect by IP or by name manually). Firewall back on, can connect to the root manually but get a login prompt. Off, gone again, back on and can't access it at all! Renamed the NAS due to issues with the name on my other devices, restarted the Surface (fw still off), can connect by name again. Firewall back on, still working (by name and IP)!

    What a mess, but fingers crossed it keeps working. (And now it needs to restart for another update, hope this doesn't break it again!)
      My ComputerSystem Spec

  9.    02 Dec 2015 #9

    I think I kind of have the same/similar problem. I have two NAS drives, one is mybooklive and the other is an iomega hmnhd. I have mapped both drives so they show up as X and Z under 'This PC'. What I am finding is sometimes I boot, go into THIS PC and either the green bar along the top is filling up slowly or the drives will have a red x through them. Initial clicks on them say the resource is unavailable or in use or something along those lines. Even if I go into my network list the same can happen. Say after a minute or so they become available and all is absolutely fine. All the while my other devices such as Windows 7 laptop never have an issue accessing them.

    It's a very intermittent and sporadic issue though. Most of the time all is fine. I think the pattern is if I reboot my machine or switch it off and turn it back on a few mins later the problem is more likely to happen. Generally if I switch off and then turn my machine on the next day then I will never see this issue. Maybe it's something to do with fast startup (which is pretty darned fast) or maybe just a glitch currently in windows 10. Perhaps it has trouble reconnecting to a NAS it was just connected to moments before. Not a huge issue as the unavailability isn't for very long when it happens. But it's sort of thing that makes me levitate towards preferring my older Windows 7 laptop just because it works much better overall. The new machine with Windows 10 is infinitely more powerful but all the little quirks just make me like it less!
      My ComputerSystem Spec

  10.    02 Dec 2015 #10

    After an update and reboot the NAS isn't showing in the list of Network devices anymore but my mapped drives still work, good enough for now! Fingers crossed it doesn't break again
      My ComputerSystem Spec


 

Related Threads
Solved Cannot access shared network drive in Network and Sharing
On my desktop (AKA S4, currently running Win8.1 x64 pro) I have shared out four of the hard drives with full permissions. I have 5 PCs in my network and all can access the four drives. My sister is visiting and currently accessing my network via...
Hello, I am new to this thread and I encountered some problems with my internet. My internet worked fine and I didn't do any changes to it up until it stopped working. I've managed to fix the internet access to allow me to access the internet on...
Cannot access Network drive by IP in Network and Sharing
As the title, my Windows 10 Enterprise PC cannot access to my company's network storage at \\10.63.0.250. In the previous edition like windows 7 or 8, I can access easily by enter \\10.63.0.250 in the Address box in File Explorer or in Run windows...
Hello : I can't access network device normally ? It is a internet power switch . For example if I type in 192.168.1.5/20000 , I can access the device . But with 192.168.1.5:20000 gives no access . Ideas , If I could get the latter to work...
I upgraded two desktops to Win 10 (one from Win 7 and one from Win 8.1). I have issues with setting up a network. First, I tried to set up a homegroup and I failed (i already posted another question on this subject with no luck so far). OK,...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:29.
Find Us