Windows 10: Network Protocols Solved

Page 19 of 27 FirstFirst ... 91718192021 ... LastLast
  1.    21 Mar 2016 #181

    torre said: View Post
    Most having wifi issues seem to be using a laptop. Somewhere in the thread/forum, a knowledgeable poster addressed that issue (sorry, I don't have link).
    I tried everything that has been suggested in this thread but I still have intermittent connectivity issues.

    I did download the driverupdate program that was mentioned but it actually cost money for the program to go beyond just detect if you had outdated drivers, but I was able to find slimware, who makes that same program which actually updates the driver for free.

    I also found that my network card, even after using a couple of different programs was being reported that the driver was "up to date" but after searching the web I found that in fact the network card was in fact out of date.

    This is my network adapter
    Qualcomm Atheros AR946x Wireless Network Adapter
    (if Im not mistaken this was also my last network card in my last laptop which I had this same issues with)

    I was using (published 7/15) driver but in fact the latest revision was (published 9/15) (link below)

    Qualcomm Atheros AR946x WiFi Adapter Driver for Windows 10 64-bit

    But because the problem is intermittent I can only hope this problem has been resolved.


    This is also some related info on this network adapter

    Sadly, while posting this reply it has failed me already. So I really not sure what to do.
      My ComputerSystem Spec

  2.    21 Mar 2016 #182

    Correction, the latest driver is published 11/15

    Ther was comments on the windows help website saying that a user using his same adapter had to use a win8.1 driver for it to work even though they were using Win 10. Not sure but Ill download it since I have the website open.
    (That version is

    This is just getting ridiculous.
      My ComputerSystem Spec

  3. Posts : 562
    Win 10 Pro, 18219 (Skip) 64bit
       21 Mar 2016 #183

    spapakons said: View Post
    So I spent many hours every day browsing the forum, learning things, but also replying wherever I could to help others. . :)

    Respect to you.

    But limited/no wifi is a prominent issue for many. I have a 3 year old Toshiba laptop which Toshiba does not support with Win10 drivers. Others may have the same problem. Perhaps Microsoft will address this issue in future builds.
      My ComputerSystem Spec

  4. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       22 Mar 2016 #184

    Use Aida64 to determine exactly which is your Wi-Fi card model. Then try finding official drivers from the card's manufacturer site. If that driver doesn't work (it usually does work), then try installing the latest driver found on notebook's support site. But I would try the latest card manufacturer's driver first as this is usually newer than that found on notebook's support site. If the driver for Windows 10 doesn't work or there isn't any, then try one for 8 or 7 or even Windows Vista. As I already said a working Vista (or newer) driver is preferable than a generic Microsoft Windows 10 driver that might or might not work.

    For Qualcomm and Atheros cards see here: I always find there what I want.
      My ComputerSystem Spec

  5.    22 Mar 2016 #185

    spapakons said: View Post
    The symptoms you describe mean that the network card doesn't negotiate the DNS server properly and it doesn't get the proper IP addresses. Check the DNS client and DHCP client services. Try restarting these services. Also it could be due to an incompatible driver. Try another driver. Use Aida64 to make sure you have the driver for your exact model. If this is your LAN card, check the Ethernet cable. Try another cable. A faulty cable can mess things.
    It turns out Win 10 didn't like the homeplug adapter I was using.

    Internet access via this homeplug was working fine under Win7 and had done do for years (it's also how I downloaded the Win 10 upgrade in the first place).

    Upgrade to Win 10 and I had the issues described.

    Went back to Win 7, Internet access back.

    Upgrade to Win 10 again (did a reset this time so all third party programs were removed), still no Internet access again.

    Ran a cable direct from the PC to the router, Internet access works.
      My ComputerSystem Spec

  6. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       22 Mar 2016 #186

    In that case you may have to use the same drivers as in Windows 7, not those found automatically by Windows Update. Try this and it could work.
      My ComputerSystem Spec

  7.    23 Mar 2016 #187

    Device PCI\VEN_168C&DEV_0034&SUBSYS_22081A3B&REV_01\4&81c41a5&0&00E3 had a problem starting.

    Driver Name: oem43.inf
    Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
    Service: athr
    Lower Filters:
    Upper Filters: vwifibus
    Problem: 0x15
    Status: 0x0
    Any ideas on this, this is a snap in MMC from the Wifi Driver/Adapter that appears to have trouble starting which is why I always have to enable/disable the wifi to get connectivity

    Im still investigating this but thought I would post this for anyone who would care to chime in.


    Also can someone remind again to to roll back to an older driver, I cant seem to remember.
      My ComputerSystem Spec

  8. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       24 Mar 2016 #188

    I don't have time to check right now because I have to go to work. A quick Google search with the hardware IDs gives these results:

    Since it is Atheros, for drivers look here:

    Download the newest driver you can find. I think this helps.
      My ComputerSystem Spec

  9.    24 Mar 2016 #189

    In case it helps anyone:
    I got the error: "one or more Network Protocols are missing on this computer" also "Windows sockets registry entries required for network connectivity are missing"
    I have a Nethawk R7000 router. I nail down IP addresses for each device by assigning them on a list on the router, so that the router always gives them the same IP. I got a new laptop and allowed it to be given an IP address. I then went into the router admin and locked it to that IP (just pick the device off a list and lock as-is). At that point, internet failed on the laptop - good wireless signal still.
    I then tried everything (reinstall drivers, netbios disable, netsh, registry, throw laptop against wall etc etc). Nothing seemed to worked.
    I then remembered that the last thing I had done was changed the router setting, so I removed the laptop off the list of assigned IPs.
    It immediately started working again.

    This is repeatable.

    All network settings are normal default windows stuff, auto dhcp, auto dns etc.

    Just in case it helps someone.
    And if anyone has any clue why this particular laptop won't work when the router assigns a particular IP, let me know....
      My ComputerSystem Spec

  10. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       24 Mar 2016 #190

    In case the router doesn't assign the proper DNS server addresses to the laptop, you can try to set them manually either on the router (to be valid for all devices) or the laptop (from wireless adapter's properties).
      My ComputerSystem Spec

Page 19 of 27 FirstFirst ... 91718192021 ... LastLast

Related Threads
EDIT: Solved! The second error message I found (about missing ordinal #581 in ieframe.dll) was the clue I needed. The problem happened because I had IE Dev Preview installed. It's an App-V package and it can be easily uninstalled by running these...
28883 My pc wifi 2 adapter network no screnn :(
Hi, I understand the new media player in Windows 10 will cast to a media center such as an Nexus Player or Amazon Fire TV, much like Airplay, but will access local media. Is this a Google Cast (Chrome cast), Miracast, DNLA or some other...
I can no longer see my Network Attached Storage in this build(10049) Enterprise. I have Network Discovery enabled and can get to the device by IP Address in a browser but am unable to map a drive to any share. Anyone else having these issues. I have...
Hi there It seems that for earlier computers such as XP / W7 or even Linux machines connecting TO a W10 machine causes problems unless you connect via an IP address. Even if you apply the "Fix automatically" it still doesn't work and if you...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:51.
Find Us