Windows 10: Internet speed slow on one computer but fine on the rest of computers

Page 1 of 2 12 LastLast
  1.    02 Nov 2015 #1

    Internet speed slow on one computer but fine on the rest of computers


    I just updated to Windows 10 but I think the problem was with Windows 8 too, Sometimes my internet is out on my PC while the internet is still up on my brothers PC, tho this problem happens about 3 times a very few days.. We have 5+ computers in the house and 4 are on daily while 3 is being used daily the 4th one is not very used daily and sometimes off most of the time. So the 2 computers have Windows 10 and 3rd computer has Windows 7 while the 4th computer has Windows 10 also. I read on an article which says that Windows 10 uses bandwidth without you know and I checked task manager and on windows 8 my CPU and Memory was just fine and when I upgraded to Windows 10 my CPU spiked to about 20% and Memory spiked to about 72% and sometimes random numbers appear on all 4 sections( CPU, Memory, Disk, Network).

    So how can I fix this problem or is it just Windows 10?
      My ComputerSystem Spec

  2.    02 Nov 2015 #2

    Bump
      My ComputerSystem Spec

  3.    02 Nov 2015 #3

    Equation said: View Post
    I just updated to Windows 10 but I think the problem was with Windows 8 too, Sometimes my internet is out on my PC while the internet is still up on my brothers PC, tho this problem happens about 3 times a very few days.. We have 5+ computers in the house and 4 are on daily while 3 is being used daily the 4th one is not very used daily and sometimes off most of the time. So the 2 computers have Windows 10 and 3rd computer has Windows 7 while the 4th computer has Windows 10 also. I read on an article which says that Windows 10 uses bandwidth without you know and I checked task manager and on windows 8 my CPU and Memory was just fine and when I upgraded to Windows 10 my CPU spiked to about 20% and Memory spiked to about 72% and sometimes random numbers appear on all 4 sections( CPU, Memory, Disk, Network).

    So how can I fix this problem or is it just Windows 10?
    Have you tried a downoad/upload/latency speed test? Do the test at https://www.speedtest.net a few times and compare
    it to the other PC's.
      My ComputerSystem Spec

  4.    03 Nov 2015 #4

    davexnet said: View Post
    Have you tried a downoad/upload/latency speed test? Do the test at https://www.speedtest.net a few times and compare
    it to the other PC's.
    Everything seems fine..
    Any other solutions?
      My ComputerSystem Spec

  5.    03 Nov 2015 #5

    You can look at the history tab in task manager to see who is using the network over time.

    Is the problem PC wifi or ethernet? I would look in the event viewer/system messages to see if you can find something
    at the time the problem occurs.
      My ComputerSystem Spec

  6.    03 Nov 2015 #6

    davexnet said: View Post
    You can look at the history tab in task manager to see who is using the network over time.

    Is the problem PC wifi or ethernet? I would look in the event viewer/system messages to see if you can find something
    at the time the problem occurs.
    Network stays at 0% all the the time
    Any other solutions?
      My ComputerSystem Spec

  7.    03 Nov 2015 #7

    Equation said: View Post
    Network stays at 0% all the the time
    Any other solutions?
    What is the real problem? Internet performance? or wifi sessions being dropped?
      My ComputerSystem Spec

  8.    03 Nov 2015 #8

    davexnet said: View Post
    What is the real problem? Internet performance? or wifi sessions being dropped?
    When I surf the internet for some reason my PC's wifi drops and I cannot load a page or sometimes the page loads very slow, while the other computers Wifi works properly.. So any solutions?
      My ComputerSystem Spec

  9.    04 Nov 2015 #9

    Any other solutions?
      My ComputerSystem Spec

  10.    15 Nov 2015 #10

    Equation said: View Post
    Any other solutions?
    Don't know if this helps but what I did to fix my Network Usage of 0% was right clicking on the Network Utilization Tab under Processes in task manager and selected Process Name and all of a sudden, my Network Tab displayed real time usage.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I have upgraded my OS from Windows 8.1 to Windows 10. After the installation the internet speed is slow down like a dial in connection (it is slow down if I am using wifi connection and it is fine if I am using a cable/wired connection). It is...
Ever since I've upgraded to Windows 10 I've noticed one weird artifact - torrents are much slower and they take much longer to pick up speed. Now, why would that be? Well, the only observation I could make is that on Windows 10 it takes so much...
Hi hope somebody can help. Since upgrading to windows 10 my internet speed on my Packard Bell PC has dropped to almost nothing, less than 1mb. Before upgrade it was around 76mb. All my other laptops, tablets etc are getting good wifi speeds. When I...
Hi all. I have a weird problem with my internet connection. After i had instaled win 10, my interned slowed down. Before i had speed around 50 mbps (old result under) http://e-speedtest.com/test/785260 Now my speed is 10-15 mbps - no more....
I recently upgraded from W7 to W10 on my W7 laptop. The install went well, no problems to report. Since then my broadband speed has suffered badly. I've just tested the speed - the download speed is 1.6mbps and upload speed 0.29mbps. It's not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:55.
Find Us