I have been having an extreme problem with connecting to the internet. After upgrading to windows 10 from windows 7 home version (I assume windows 10 is the problem) I had connectivity for over a month. Thus I cannot roll back to windows 7 anymore. I have no connectivity now through either the Ethernet card or the Wireless card. I am technical, having worked with computers for a very long time. I have never run into anything before that I could not fix but this has me completely stumped. I, of course, did all the basic standard things first, ie. rebooted the modem, the computer, checked connections and cable etc. Here are the specs on my pc:
Inspiron INSPIRON7720
8 GB of RAM
Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz 2.3 GHz
64 bit operating system
has 4 cores (CPUs) and 8 threads

wifi card:
Intel(R) Centrino(R) Wireless-N 2230
Ethernet card:
Realtek PCIe FE Family Controller

This is the windows system I had prior to the free upgrade to windows 10:
Windows 7 Home Premium, Service Pack 1
MS Office Home and Student 2010
After upgrade:
Microsoft Windows [Version 10.0.10240]
(Windows 10 home)
(c) 2015 Microsoft Corporation. All rights reserved.
Prior to the windows 10 upgrade everything was working fine. I never had a problem with online connections. I had no problem for about 4-6 weeks after the windows 10 upgrade. For the past several weeks it has been getting progressively worse. Now it is gone completely.
I use time warner for cable internet service. All my other devices are working fine over their wifi..a mac computer and two phones, one a note 4 and the other an iphone. Yet my windows laptop does not even see any wifi. It did about a week ago but this has been downgrading rapidly. I tried three different modems from Time Warner. Their modems also act as wireless hubs. I have an Ethernet cable plugged directly into the modem/hub and I have tried three different cables. The laptop does not see either the Ethernet or the wifi. It did until about two days ago. But now it does not even perceive that they are there.
These are the things I have tried…
Calling Time Warner several times and eventually having one of their techs come over. At first time warner was able to do some remote stuff to their modems and that would work for a short while but then it stopped. One guy said it had to do with security protocols, some old and some new and he said it was getting confused and he did something that got it working for 3 days and then it stopped. The tech guy checked the modem, etc. gave me a third type modem, checked the wiring outside the building, all failed.
I tried connecting to wifi at other locations in my town. That would work for a little while and then it stopped.
I searched online for help. I found this advice:
[Solved] Windows 10 Wifi Troubleshooting Not Connecting Limited Access problem in Windows 10 - YouTube
Enter these commands into the command prompt administrator window:

netsh int tcp set heuristics disabled
netsh int tcp set global autotuninglevel=disabled
netsh int tcp set global rss=enabled
netsh int tcp show global
then reboot

This worked for a few hours. I would keep doing this and rebooting and each time it would work for a little while but eventually it stopped working altogether.
I also checked my drivers online. I downloaded a tool from Intel to look for new Intel drivers. I updated whatever needed updating. My driver for Intel(R) Centrino(R) Wireless-N 2230 was up to date already.
I did update the HD Graphics driver for windows 10 64 bit
I went to the realtek site and found an updated driver for Realtek PCIe FE Family Controller and updated it … an updated Ethernet driver for windows 10

Once the drivers were updated, I could not get any internet connection at all anymore, even intermittingly.
I tried to roll back the new Ethernet driver and the rollback hangs.

I tried running system restore and system restore failed.......An unspecified error occurred during System Restore (0x80070057). I again tried restoring the pc back to previous states. Restore tells me it cannot run because it cannot access a file and it says to turn off the anti-virus software so it can access the file. I did turn it off but still got the exact same message.

When I go to Device Manager, double click Network Adapters & right click my Intel wireless there is only an option to disable it so I assumed it was enabled. Same for Realtek controller which works with Ethernet. (I checked this because I noticed the windows 10 system turns off these devices randomly by itself) Yet when I go to "Network & Internet " from Settings and then "change adapter settings" I see that the Local Area Connection is Disabled and the Wireless Network Connection is disabled. When I try to enable by right clicking and clicking enable it does not work. When I run diagnostics it tells me it says there might be a problem with the drivers. But now I cannot get online to do anything about that. I have tried to run repairs as an administrator and the results are the same. When I click on a previous driver (device manager - right click on particular network adapter, update drive software - browse my computer..etc...let me pick...) and choose to try to install it, windows comes back with the message: "Windows encountered a problem installing the driver software for your device...Windows found driver software for your device but encountered an error while attempting to install it." This occurred for both Intel and Realtek. So it seems to me that the first thing to do would be to enable the network devices. But I cannot get past the needless and nonsensical blocks the system has put in place.

When I go to device manager and click either the wifi or the ethernet card and I right click and choose properties, it tells me “This device is working properly”. The drivers currently in use at this point are (properties – driver – driver details):
For wifi card:
Intel(R) Centrino(R) Wireless-N 2230
Driver: file version
For Ethernet card:
Realtek PCIe FE Family Controller
Driver: 10.003.0723.2015

I have run several full virus scans using Kaspersky throughout this process and nothing was found….Please help. I have done everything I can do. If I could, I would go back to windows 7 in a second, but I cannot. Or I would change to an alternative like Apple or Linux. But I am not completely ready to give up on windows yet because changing systems probably will not be so easy. So far there has been no damage to my files. I do have backups.