Dual NIC No Network Browsing on one Subnet

  1. Posts : 2
    Windows 10

    Dual NIC No Network Browsing on one Subnet


    I just finished updating from Windows 7 to Windows 10. My PC has a dual NIC and I am connected to two subnets. I am fully able to browse subnet A, the same as I could in Windows 7.

    However, I am unable to automatically browse subnet B. I previously could in Windows 7.

    In other words, when I go to "Network" on windows 10, all the Computer names on subnet A get populated. None of those on subnet B appear. However, if I manually type in the name of a device on subnet B (\\DEVICENAME) it will open it and I can browse the contents.

    I had no problem in Windows 7 with browsing both subnets. I suspect there is a setting or difference in Windows 10, but I'm unable to find it. I've checked and the Computer Browser service is running, but it seems to only list PC's connected to the one NIC (subnet A) and not the other.

    Any ideas?
      My Computer

  2. Posts : 2
    Windows 10
    Thread Starter


    I played around with this for several hours and still don't have a fully working solution.

    To elaborate on the problem, all the devices on subnet A are Windows devices running Win7, Win8, or Win10. Everything there is working as expected. All the devices on subnet B are linux, with smb shares.

    The linux devices are "appliances". They boot linux but have no linux UI. They are read only and boot a preconfigured linux. They have an SSD attached for storage, which is what I need to access. One device is a linux server.

    From any of the linux devices, they all see each other and they all see the windows 10 PC. No problems there. The only device that win10 can see is the linux server, and I think that is because I have a user on that server that has the same username and password as my win10 account.

    When I browse the network, it doesn't show this device but if I type \\DEVICENAME into the browser, it will open it. I can then pin it into quick access and that sort of works. Scripts on my win10 PC that call it out by \\DEVICENAME work when I run them.

    The appliances are a different story. At first I couldn't access them at all in win10. But I moved the network to public from private, and used a registry hack to allow connections to devices with no password. FYI, these appliances have no option to create users. You either turn samba on or off. If it is on, it publishes a share into the specified workgroup that is the same as the device name. If it is off, you have no share.

    Anyway, now I can access these devices by \\IP_ADDRESS, but I cannot access them by \\DEVICENAME. This will require me to update all my scripts with IP's instead of device names, which sucks and makes it hard to keep things straight. When I run the win10 troubleshooter, it says devices aren't accessible because of a problem with the DNS server. The router is the DNS server, the same one used for the linux server, which works using \\DEVICENAME.

    It just seems like win7 was gathering all the samba share info device names and IP's and then let you browse them. As a result you could use DEVICENAME for the the appliances. But Win10 is not performing this same behavior.

    Still looking for help...
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:20.
Find Us

Windows 10 Forums