Windows 10: Microsoft Virtual WiFi Miniport Adapter Missing

  1.    28 Sep 2015 #1

    Microsoft Virtual WiFi Miniport Adapter Missing


    I've been trying to get my virtual WiFi hotspot working since I upgraded to Windows 10 and it does not seem to be working. In Device Manager instead of finding an instance of Microsoft Virtual WiFi Miniport Adapter I have Microsoft Hosted Network Virtual Adapter installed and this is only present in Network Connections when the hosted network is started and it disappears when it is stopped, unlike the Microsoft Virtual WiFi Miniport Adapter which was persistently in Network Connections. Also, my devices can connect to the hotspot I create but the network itself is limited and they have no internet access even though I have enabled sharing on my Ethernet connection. When trying to troubleshoot the limited connection I get the error message '"Wi-Fi does not have a valid IP configuration".

    Does anyone have any advice on how to get the Microsoft Virtual WiFi Miniport Adapter back? I've tried reinstalling both my Ethernet and WiFi drivers in Device manager but it always installs Microsoft Hosted Network Virtual Adapter instead. Or am I in the wrong ballpark and it is nothing to do with this new driver. Any help would be appreciated!
      My ComputerSystem Spec

  2.    28 Sep 2015 #2
      My ComputerSystem Spec


Related Threads
hello , the title pretty much says it all. i cant create a virtual wifi network using this command netsh wlan start hostednetwork (the "set" command works) the solution is to enable Microsoft Hosted Network Virtual Adapter which is missing ,...
I upgraded from 8.1 to 10.0 2-3 weeks ago. Wifi worked fine until a couple of days ago. Now the icon says "Not connected - No connections are available." But there are! I'm sending this from my Windows 8.1 notebook and it says there are 4 wifi's...
Hello, I have setup Hyper-v on my system but once I setup the virtual switch, my network adapter no longer connects to the Wlan. when I look at network and sharing, it shows the virtual switch but not the real adapter. I followed the steps in the...
Wifi adapter not found after upgrade in Network and Sharing
My desktop computer (formerly operating Windows 7) connects to my wifi router via a Netgear USB adapter. The programme still seems to be installed but computer says 'no network available'. I rather think re-installing the netgear thing is the way...
I have a dell inspiron N4010 W7 SP1. I am trying to download W10 and message from W10 indicates that I need to download a driver for this adapter; opened the device manager and located the adapter and then tried to update the driver and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:16.
Find Us