1.    14 Sep 2015 #1
    Join Date : Sep 2015
    Posts : 3
    Windows 10 Home

    Network drive not showing in elevated apps


    Hi everybody,

    I am using W10 Home and I have just done a clean install and I am in the process of customizing the system to my needs.

    The problem I step into is this:
    I connected a new network drive from within Windows Explorer and if I open:
    - Command prompt window: Drive exist and it is listed by NET USE
    - Admin command prompt window: Drive DOESN'T exist and it is NOT listed by NET USE

    I also use FreeCommander. When I launch it the UAC asks for my confirmation and the network drive doesn't show either.

    I know it sounds stupid but I can't figure out what happens...

    Thanks!
      My ComputerSystem Spec
  2.    15 Sep 2015 #2
    Join Date : Sep 2015
    Posts : 3
    Windows 10 Home
    Thread Starter

    Does anybody had the opportunity to test this in their machines? Is it only happening to me?
      My ComputerSystem Spec
  3.    15 Sep 2015 #3
    Join Date : Jul 2015
    Posts : 3,813
    10 Pro

    It happens to me (and I think everyone). If you do net use from an admin command prompt to map a network drive you'll not see the drive in file explorer (as explorer.exe runs as normal user by default).

    Similarly if you map a network drive through explorer (or net use from a non-elevated command prompt) you'll not be able to use it from a program you run as admin.

    For programs I need to run as admin that also need a mapped network drive (only one program actually for me ) I map one from an admin command prompt first.

    This is I think completely normal - when you run as administrator then you are running as administrator not your normal profile.

    See here - I know it is old link but it works the same for me on 10...Mapped Drives Unavailable via Escalated Command Prompt?
      My ComputerSystem Spec
  4.    15 Sep 2015 #4
    Join Date : Sep 2015
    Posts : 3
    Windows 10 Home
    Thread Starter

    Hi Halasz!
    I really appretiate your comments. At least now I know that it wasn't my problem!

    However I don't think I agree with you about this being "completely normal": if you are an administrator you should be able to control the whole local machine not at "session" level!
    Anyway, it's my opinion and I can't do nothing about it... The ways of Microsoft are inscrutable!!!

    So your workaround is map the drive twice?
    I tried to map it on the admin command prompt with NET USE and the "Persistent" modifier but the mapping does not persist between reboots... Is this also "normal"?

    Thanks for your comments.
      My ComputerSystem Spec
  5.    15 Sep 2015 #5
    Join Date : Jul 2015
    Posts : 3,813
    10 Pro

    Quote Originally Posted by Frn747 View Post
    So your workaround is map the drive twice?
    I tried to map it on the admin command prompt with NET USE and the "Persistent" modifier but the mapping does not persist between reboots... Is this also "normal"?
    I just tested the /p:yes switch. You are right - it persists over re-boot if you map a drive in normal cmd prompt but not if you map it in administrator cmd prompt. I don't know if this is "normal" but it is what happens to me too...

    I guess you could set up a scheduled task to run at log on to do it. For me I did it manually. I didn't notice it didn't persist until you mentioned it as I only ran my program that needed it once...
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
MyCloud NAS not showing up in Network computers
Hi everyone! Just got an ASUS ZenBook UX305 and am having trouble mapping network drives as I can't connect to the devices via explorer (either in the list in Network under "computers" or my manually browsing to the device name or the IP...
Network and Sharing
Phone showing on my PC Network
I have just installed Windows 10 and noticed something ive not seen before on my Network, it shows a phone G510-0100. I don't recall every adding this phone and i cant see how to remove it. Any help will be most grateful
Network and Sharing
Second SATA drive showing in BIOS but not Device Manager
I've just added a 2nd HD to my Dell system with Win 10. It shows in the BIOS and Seagate tools finds it. It does not show up in Device manager or Computer Management/Storage - Disc Management or anywhere. Not sure if this si Won 10 specific. Anyone...
Drivers and Hardware
WIFI Networks not showing up in the network tray
I just upgraded to windows 10 via windows updater tool (available on microsoft's official website). I'm using an external adapter i.e. TP-LINK-WN722N to connect to the wifi network because apparently, the router is located far off from where I use...
Network and Sharing
Windows 10 Showing Empty On Optical Drive???
I'm trying to Install some software on a disk. The disk drive is recognised but there is nothing in it ? Despite showing it's full.
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:10.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums