Thought I would pass on a solution that worked for me when I was about to give up and reinstal again, without any guarantee of success.
I installed Windows 10 about 3 weeks ago on my second computer, leaving the main computer on Win7 until I tried it out. Had so many irritating problems with all sorts of things, including software and menu's not working, that I decided to roll back to Win7 However that option was not available anymore. I did a fresh install and loved Windows 10 except for being unable to join my homegroup. I searched and tried what I thought was every option on many support pages, but everything failed and I had the same errors again and again. Unable to start Peer networking and just about all the others I have seen on these pages. Could not find the file "idstore.sst", the folder was empty.
Then I came across this link "Peer Name Resolution Protocol" Service Could not be Started and HomeGroup Is not Working - TechNet Forum Windows 7 Support Team - Site Home - TechNet Blogs

I followed the stages and suddenly had 3 entries where the idstore should be. I deleted all three and rebooted the computer.
I then tried to create a homegroup. Worked no problem. Everything in the Services that should be running, was running.
I left that home group, booted up the Win7 computer and was able to join my original homegroup without any problem.
I know that different solutions work for different set ups, but having tried virtually everything else it was such a joy. I can't afford to pull anymore hair out.
Hope this may work for others having the same problem.