Hi guys,

Was looking to try Windows 10 again and was wondering if anybody had success using Asus products on Windows 10. Previously, I had tried both my NetGear AC6210 usb adapter and my TP Link WDN4800 PCI card. Now when installing the drivers for these products they do work both on 2.4GHz and 5GHz.

However, the speeds the ran at was terrible. So terrible the 90s were laughing at me. So terrible in fact that a farmer in Belarus could plug a cord into a turnip and get faster speeds.

So I built a new computer a week ago and did a clean install of Windows 10 on to a fresh Samsung EVO Pro 500GB SSD. And tried the wifi adapters again. Same issues.

I have tried both the Windows ones, the ones provided by TP Link and even the MediaTek ones for. Both devices will technically work in the sense I can connect but the connection itself is very, very, very slow (<0.2MB/s*).

I felt it might be driver related since I can't find anything in Windows myself or via Google that would suggest it to be Windows 10 itself.

So this time I have decided to look at a replacement device and have selected two I think should work.**

Hence, I was interested if anybody else had success (2.4GHz and 5GHz working at full speeds) with either of these two products on Windows 10.

The first is the Asus PCE-AC56 Dual Band Wireless AC1300 PCI-E Adapter as seen here:http://www.msy.com.au/wa/cannington/...e-adapter.html

The second product was the: Asus PCE-AC68 Dual Band Wireless AC1900 PCI-E Adapter as seen here:http://www.msy.com.au/wa/cannington/...e-adapter.html

*Note: Yes I well aware of the difference in Mbps and MBps (or MB/s if prefer).

**Note: I had these devices on Win7 and they worked fine. After trying windows 10 I rolled back to Win 8.1 and they work again. ----> Concluded it was likely a driver issue.

Any help is appreciated